WordPress.org

Ready to get started?Download WordPress

Forums

no initial $table prefix (2 posts)

  1. ctfarp
    Member
    Posted 7 years ago #

    Hello: I am a novice, and a frustrated one at that. Maybe the server i use isnt very good (awardspace.com), but i wanted multiple blogs and created 2 subdomains. I had received support info. from WP as follows:
    ** MySQL settings ** //define('DB_NAME', 'xxxxx'); // The name ofthe databasedefine('DB_USER', 'xxxxx'); // Your MySQLusernamedefine('DB_PASSWORD', 'xxxx'); // ...and passworddefine('DB_HOST','xxxx.awardspace.com'); // 99% chance you won't need to change this value// You can have multiple installations in one database if you give eachaunique prefix $table_prefix = 'wpi4f_'; // Only numbers, letters, andunderscoresplease! // Change this to localize WordPress. <br>
    Okay, fine, but in the MySQL db it won't let me add a table (although I did assume this would occur auto. if i changed the wp-config.php file), and the wp-config.php file has NO $table prefixes already set up (in other words, I would not be adding text for a 2nd table, only creating .php text which I DO NOT know how to do, for a new table prefix).<br>
    the WordPress tutorial gives these instructions:
    Main blog:

    $table_prefix = 'main_';
    Projects blog:

    $table_prefix = 'projects_';
    Test blog:

    $table_prefix = 'test_';<br>

    Okay, but would I enter this info. into the wp-config.php file AFTER the define fields? Because right now there are no $table_prefix (this text is completely absent). But there are about 14 fields with the same table prefix in MySQL...but I don't know how to populate another table prefix. Can someone help?

  2. Kafkaesqui

    Posted 7 years ago #

    >> $table_prefix = 'wpi4f_';

    That looks like you're assigning a table prefix to me.

    The $table_prefix is set in your wp-config.php. It's usually placed on a line right after the database constants (DB_NAME, etc.) are 'defined', but just make sure it's before wp-settings.php is included (the require_once() line).

    If you are unable to add tables to your database, you have two options:

    1. Use what web site administration admin tools your host provider offers (if any) to set up a MySQL user with the proper privileges.

    2. Contact your host and request they help reset or create a new MySQL user with the proper web site privileges.

Topic Closed

This topic has been closed to new replies.

About this Topic