WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] No index page (21 posts)

  1. huston40
    Member
    Posted 8 years ago #

    Hi,

    Have searched the archives and no solution. My WP 1.5 installation has been working fine. Last night, I posted an entry and afterwards I get nothing (web site not available) when I View Site or enter the URL, with or without index.php added. I cleared the browser cache and it does this on three computers. WP-admin works fine, including post views, etc, but no access to the public. I do not have an index.htm(l) page anywhere. I am using the Semlogic theme, but I changed it and problem was still there. The database is fine. I am going nuts. Can anyone help? thanks.

  2. skippy
    Member
    Posted 8 years ago #

    Can you try reverting your most recent post from published to draft status?

    If the only change from when your blog worked and when it stopped working was indeed that post, then that's where we should begin looking. Make it a draft, so as not to delete it. Then see if your blog works again.

  3. huston40
    Member
    Posted 8 years ago #

    Hey, thanks. Reverting to draft worked. The only thing different with that last post was I included an amazon.com link in an <iframe>. I'll bet that did something. I will try and delete that link and see if it works.

  4. skippy
    Member
    Posted 8 years ago #

    Do please let us know. Feel free to close this topic (by selecting "Resolved" above) at your convenience.

  5. huston40
    Member
    Posted 8 years ago #

    Well, now it is not publishing my new post, with or without the amazon link. I deleted it and rewrote it. The post shows up when you view post from admin, but it not on the home page or in Latest Posts on Categories. Any more ideas? The only other thing besides the amazon link was a stray </P> tag at the end on the original post. Thanks.

  6. skippy
    Member
    Posted 8 years ago #

    When you say "not publishing", do you mean that this post causes the same symptoms as before: a blank page?

    Or do you mean that you click the Publish button, but your front page does not change on your blog?

    Did you future-date this post, by chance?

    Using the admin interface, take note of the post's ID. Then visit
    http://yoursite.com/index.php?p=X
    where X is the post's ID. Do you see your post?

  7. huston40
    Member
    Posted 8 years ago #

    Post does not show up on the front page. The post is there, including coming up under latest posts, when I go to the page ID as you described.

    I just remembered that the other thing that was different was that the previous post got a comment. That was the first comment since I started the blog. Could that be hanging it up? I think I will delete the comment and see. Thanks again

  8. huston40
    Member
    Posted 8 years ago #

    Couple of other things:
    1. when I click on the category in the sidebar, the post is there, even though the number of posts (Category (2) does not reflect it.
    2. The sidebar is not correct on the home page, but it is correct in interior pages
    3. I deleted the comment and the problem remains
    4. My site home page works with Http://mysite.com, but I get a blank with http://www.mysite.com. Just noticed this, but it worked with www before.

    I have not messed with any of the site files.

  9. huston40
    Member
    Posted 8 years ago #

    Now the original problem with no front page is back. Damn. I may just try and reinstall WP. Would upgrading to 1.5.2 be worth a try?

  10. skippy
    Member
    Posted 8 years ago #

    Version 1.5.2 is strongly encouraged. It is the current latest stable release.

  11. huston40
    Member
    Posted 8 years ago #

    This is maddening. I upgraded to WP 1.5.2. I have the exact same problem. It works with the last post as a draft only. If I publish, there is no home page. Something about that last post is screwy.

  12. huston40
    Member
    Posted 8 years ago #

    OK, I deleted the entire post and redid it. It appears that perhaps WP has reached some limit in published posts allowed. THis is only my 13th post, although the number is up to 20 with my deleting and playing around to make it work. Bottom line is if I publish this additional post, the site goes down. Wp-admin works fine and the database has been populated. Is there some setting in the config file or something I should look for?

  13. skippy
    Member
    Posted 8 years ago #

    Can you make a new test post, with just simple text ("This is a test") and publish that? Does it dislpay properly?

  14. huston40
    Member
    Posted 8 years ago #

    That worked. Hmmm. Let me mess around some more.

  15. huston40
    Member
    Posted 8 years ago #

    This is really strange. I figure that my original post was either too long or had some illegal characters that confused WP

    I went back and started recreating the post paragraph by paragraph. It worked until I get to a paragraph with quotes in it. I took out the quotes and it still would work. I deleted the entire thing and started again. I still can't get past that paragraph without it crapping out. I have done longer posts than this. I will deal with it and just break up my post, but if anyone knows anything obvious from my description, please let me know. Thanks, again

  16. huston40
    Member
    Posted 8 years ago #

    I meant to say Wouldn't work in second paragraph above

  17. skippy
    Member
    Posted 8 years ago #

    There have been weird instances of some words causing problems in posts. In one instance, the word "curl" in a post would cause the entire blog to break.

    Are you using single or double quotes? Try using the other, just to see if that makes a difference.

  18. huston40
    Member
    Posted 8 years ago #

    I'll try that, originally, there were the following special characters: #,$, double quotes, brackets, parens, and a few military acronyms. I know the $ should be OK. I tried the single quotes.

    I think I finally figured it out. I removed the square brackets and it appears to now be working. Will do some more testing to make sure.

    Thanks

  19. huston40
    Member
    Posted 8 years ago #

    I think the square brackets were the problem. Don't use them in a post!

  20. That seems rather odd. I use square brackets all the time[1], and they've never given me any trouble...

    [1] For my footnotes[2]
    [2] Which I use a lot

  21. skippy
    Member
    Posted 8 years ago #

    Different hosts may have different oddities. The 'curl' problem mentioned above does not strike everyone. It could be a mod_security rule on the server, or some other filtering mechanism at work.

    I'm glad you found the specific culprit, huston40, even if it makes blogging a wee bit more difficult.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags