WordPress.org

Ready to get started?Download WordPress

Forums

Recipe Card
[resolved] no images in google search (11 posts)

  1. bakeologybylisa
    Member
    Posted 5 months ago #

    hi,

    i'm using recipe card on bakeologybylisa.com. i have images posted for every single recipe on the site, but when they appear in google search, they appear without images. except for two random posts, that do appear with images. can anyone tell me why?

    i emailed yumprint support about this a while ago but got no response.

    thanks,

    lisa

    https://wordpress.org/plugins/recipe-card/

  2. ziggyzip
    Member
    Posted 5 months ago #

    I'd like to know the answer too. Are you using Google Webmaster Tools. I am and it says this:

    We do not detect any structured data on your site.
    Structured data helps Google understand the content on your site, which can be used to display rich snippets in search results.
    You provide structured data by adding HTML markup to your site's pages.
    Read more about rich snippets.
    Visit schema.org - an industry-supported collection of schemas for structured data markup.

    The plugin clearly states that it does have this. So, we should be seeing microformats.

  3. Yumprint.com
    Member
    Plugin Author

    Posted 5 months ago #

    Hi all -

    Can you share links to your posts that are having trouble? I'd be happy to look into it.

  4. iwilkerson
    Member
    Posted 5 months ago #

    I am having this problem too--image not appearing in google searches. Here is a link to one post: http://artofnaturalliving.com/2014/02/17/orange-currant-bread/ Is it possible there is a conflict with Yoast? I see that it takes that meta description over the description in recipe card.

  5. ziggyzip
    Member
    Posted 5 months ago #

    Here's my website: http://www.aiplifestyle.com All the recipes are don't show up. I too am using Yoast and wonder if there is a correlation.

  6. francolambiase
    Member
    Posted 4 months ago #

    Hi I am having the same problem! No image shows up at all!! website is utterlygourmet.co.uk - if you search google for 'utterly gourmet duck egg pasta' the recipe is there, but no image, and it's the same with all other recipes.

  7. bakeologybylisa
    Member
    Posted 4 months ago #

    actually, my issue resolved itself - turns out it was just an issue of giving google enough time to re-index my site, so I used google's webmaster tools to tell google to re-index the pages that weren't showing up correctly. not sure if this would work for everyone else but it's worth a try.

  8. francolambiase
    Member
    Posted 4 months ago #

    hey thanks for that. To be honest my images have never shown at all.... really not sure what to do... I do use Yoast SEO.. could it be that? no idea... would be good if the developers were to read these posts though.. I know they are free but i would rather pay a few £

  9. Yumprint.com
    Member
    Plugin Author

    Posted 4 months ago #

    Hi everyone -

    Google provides a tool that will allow you test whether everything is set up properly on your blog. You can find it here:

    http://www.google.com/webmasters/tools/richsnippets

    Enter an example post url in the box and it will show you all the microformats that it found. Make sure you scroll down to the schema.org section since that is what Recipe Card uses.

    At the very top, you'll also see a preview of how that page will appear in search results.

    Please keep in mind that even if everything is set up properly, it can take a while for Google to reindex your page. As bakeologybylisa pointed out, this can take a while, but you can use google's webmaster tools to tell Google to reindex the page.

    I hope that helps. If you're still having trouble, please send an example page that isn't working to support@yumprint.com.

    Thanks!

  10. iwilkerson
    Member
    Posted 4 months ago #

    In the richsnippets link above, my images have always shown up properly. They just never do in an actual google search--even those that have been there for months. I give an example above...

  11. iwilkerson
    Member
    Posted 3 months ago #

    This is now working for me. Not sure what changed but it was a pleasant discovery. I did post my sitemap to google about a month or so ago. Nothing changed right away and I don't know if that is what impacted this or not, but I am pretty excited!

Reply

You must log in to post.

About this Plugin

About this Topic