WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] No Image Upload in 2.1 (20 posts)

  1. arbitrarymarks
    Member
    Posted 7 years ago #

    I have no image upload in my post window after upgrading to 2.1. The box where the upload was previously now points to my blog's front page, but with a 404 page not found error.

    In the meantime, I can upload images directly to my server and point to them, but can someone explain where the box has gone in 2.1? (I've looked in the upload tab, and it only allows you to scroll through previously uploaded images).

  2. alexz
    Member
    Posted 7 years ago #

    This is also a problem for me.

  3. Xander
    Member
    Posted 7 years ago #

    It was working fine for me on two different installs I made last night... check to see if you uploaded all files to the wp-admin directory correctly?

  4. Keir Whitaker
    Member
    Posted 7 years ago #

    I have the exact same problem. I have checked that all the files are present and they definitely seem to be there. Is there an option that should be checked somewhere that I haven't seen?

  5. Ashram
    Member
    Posted 7 years ago #

    Sounds like a similar problem to mine here. The upload box appears occasionally leading me to suspect a caching issue in the browser, however clearing and turning off caching did not resolve the problem.

  6. Gatoelho
    Member
    Posted 7 years ago #

    same to me...

  7. arbitrarymarks
    Member
    Posted 7 years ago #

    In response to Xander, I did triple-check the files in my install. I wound up rolling back to 2.0.7 and installing FCKeditor instead of using TinyMCE. When I rolledback, the image browser appeared, but I continued to get javascript errors. My Chenpress plugin has solved the problem.

  8. alexz
    Member
    Posted 7 years ago #

    I'm in the meantime not rolling back. Anyone have a clue yet? I looked at the bugtrack and what I can see is that no one have noticed this problem yet!?

  9. ctodddv
    Member
    Posted 7 years ago #

    I too am having the same issue...the upload dialog does not appear on the screen. I have tried with ie7, and Firefox. I have also tried disabling all plug-ins.....to no avail

  10. Ashram
    Member
    Posted 7 years ago #

    I have found a solution to this problem in the forum already. See this thread http://wordpress.com/forums/topic.php?id=6518

    Basically, disable or create a rule for adblocking software.

    Ashram

  11. alexz
    Member
    Posted 7 years ago #

    Yeah. It is my adblocker from McAffee that makes this problem.

  12. goldeneagle
    Member
    Posted 7 years ago #

    Partial success. I tried turning off the adblocker and adding WordPress to the list of trusted sites.

    Good news: at least the "this feature requires iframe support" goes away, and I get a little frame like I used to before I upgraded to WP2.1

    Bad news: the frame just contains a picture of my home page with a 404 message :-(

  13. alexz
    Member
    Posted 7 years ago #

    Maybe you have to upload upload.php under the wp-admin folder again.

    I tried to add my blog as trusted site in McAfee without success.

    Any ideas?

  14. goldeneagle
    Member
    Posted 7 years ago #

    I've re-uploaded everything until I'm a bit bored... Nothing does much good. Thinking of moving back to WP v2.0.5 in desperation. Shame, because I've now ironed out all the other glitches in the upgrade.

    I had no problem adding my own blog as a trusted site (right click on the McAfee button at the bottom right of the scren, select Privacy Service>options then update the "allow list" tab. But it didn't fix any problems for me...

  15. goldeneagle
    Member
    Posted 7 years ago #

    Cracked it.

    The Silaspartners Flickr plugin isn't compatible with WP 2.1 yet. They're working on it apparently.
    Disable the Flickr plugin and the old upload frame comes back. Re-enable the flickr plugin once you've uploaded the files.
    Pheww. This one was driving me seriously crazy.

  16. ginoxy
    Member
    Posted 7 years ago #

    So far we have to use FTP for uploading ? i mean how to fix this matter ?

  17. bbstafford
    Member
    Posted 7 years ago #

    This is in fact the solution - look at the plugins you have and disable the flickr ones. Back comes the uploading photos box, but it looks a little different than previously.

    Thank you to the person who suggested this, what a relief... back to work.

  18. factor1studios
    Member
    Posted 7 years ago #

    I have the same issues. Except on a fresh install, with no flickr plug ins.

    running 2.2

  19. goatlip
    Member
    Posted 6 years ago #

    Just wanted to also confirm that after deactivating Flickr Photo Gallery by Silas Partners (Joe Tan) that the upload bar comes back.

    I upgraded to Flickr Photo Gallery version 0.93.2 and the upload bar is there with the added flicker gallery features.

    If you have any plugin that has to do with photos, uploads, images, galleries, etc. try deactivating that to see if the upload bar shows up.

  20. l0zo
    Member
    Posted 6 years ago #

    I tried all this but mine still doesnt work

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.