WordPress.org

Ready to get started?Download WordPress

Forums

Easy Recipe
[resolved] No Image in Google testing tool (2 posts)

  1. adab
    Member
    Posted 1 year ago #

    Hi,
    Hoping you can help with this one; I'm working on a cakes website and trying to get the Google rich snippets testing tool to show the cake images. Each recipe has its own page, with one image of the cake.
    When I paste only the html created by your plug-in it works fine in the testing tool, showing the appropriate image.
    But when I preview using the url address - which obviously then tests all the html on the page - there's no cake image.
    The image that shows up instead is of the owner of the site - she is verified for Google authorship. It's small than the usual author image, appearing on the left side below the meta description.
    When I compare the data with a site that shows recipe images correctly - eg bettycrocker.com - the only difference appears to be in the RDFA node section: in bettycrocker.com the name and href relate to the appropriate food image. In my case, the name and href relate to link-type-author and the url of the author page on the WordPress site - http://www.oursite.com/author/user-name/
    I tried to strip out the authorship markup, which got rid of the author image. But the RDFA node still links to the author page rather than the cake image.
    Any suggestions on what I'm doing wrong, and how to get the cake image to show up in the snippet testing tool?
    Thanks

    http://wordpress.org/extend/plugins/easyrecipe/

  2. Jayce53
    Member
    Plugin Author

    Posted 1 year ago #

    This is almost alwasy caused by themes generating invalid microformat markup which trips up Google's rich snippet generation.

    You can read more about it (and how to get around it) here:

    http://www.easyrecipeplugin.com/support/google-doesnt-show-rich-snippets-for-my-posts/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic