WordPress.org

Ready to get started?Download WordPress

Forums

No https on product pages - WP eCommerce - WordPress HTTPS (3 posts)

  1. glutenfreerecipebox
    Member
    Posted 3 years ago #

    I am using WP eCommerce and WordPress HTTPS plugins. I added an SSL certificate. When following advice on another forum I accidentally added "shop.mydomain.com" instead of just my domain. I finally have access to my admin panel again, but cannot get the "Visit Shop" or Product pages to work. They are still searching for "shop.mydomain.com." I have added the 2 lines in my config.php file to define my domain and added 2 lines in my function file to redirect to my url: http://gluten-free-gift-baskets.com, but these pages will not work. I had other files that would not work until I forced the pages to go SSL, but you cannot force "The Shop" or any of the product pages to SSL.

    I tried unpublishing and then publishing those page, but no luck.

  2. Mvied
    Member
    Posted 3 years ago #

    This is probably a question for the WP E-commerce developer, but I'm familiar with it, so I can help. :)

    I have a feeling your issue is with the URL's WP E-commerce has stored for its three pages. In your admin panel, go to Shop > Settings. Then, go to the Admin tab, scroll all the way down and click the 'Update Page URLs' link.

    Let me know if it works. :)

    Oh, and thanks for using WordPress HTTPS. If you have any issues with it, let me know.

  3. glutenfreerecipebox
    Member
    Posted 3 years ago #

    I forgot to save this post so that I could update it. I actually tried that last night and it worked. Thank you, though! I am sure this will help others.

    Now I am having shopping cart problems! Ugh!

Topic Closed

This topic has been closed to new replies.

About this Topic