WordPress.org

Ready to get started?Download WordPress

Forums

No graphics or dashboard, and hyperlinks don't work (8 posts)

  1. cacique
    Member
    Posted 8 years ago #

    Immediately following installation, my blog worked. However, a few 'strange' things happened after trying to change the name of the blog, as well as getting the antispam function working.

    All of a sudden, I cannot login to admin, and graphics and dashboard are absent when I access the blog site. Clicking on 'internal' hyperlinks results in the 'site not found' message.

    I have tried removing all files from the server and complete re-installation, but still cannot get past this problem.

    Any ideas or suggestions would be most appreciated. I am a newbie at this (my first installation). I am using v2.0.2, and you can see my blog at http://www.evan-deleyre.com/blog

    Thanks,
    David Thomson

  2. Chris_K
    Member
    Posted 8 years ago #

    It looks like you changed the URIs in the Admin Options General Page (WordPress address and Blog Address). One or both of those are definitely wrong based on what i'm seeing for permalinks on your site. At a guess, you forgot to include "http://" at the front.

    If you're not able to log in to the admin area to fix that, you'll need to edit it directly in the database. I'd suggest this tutorial to get you rolling. http://www.tamba2.org.uk/wordpress/site-url/

  3. cacique
    Member
    Posted 8 years ago #

    Thanks, that worked. Simple when you know how..! ;-)

    There's one thing I neglected to ask, and that is the issue of 'Akismet' and the required API key. I ran into some difficulty when I first tried to retrieve this. I was asked to 'register' which I did, and was promptly issued another password.

    Given that I have the basic blog up and running again, how would you recommend that I proceed from here?

    Thanks again,

    David

  4. Chris_K
    Member
    Posted 8 years ago #

    Note that you need to register at wordpress.COM, not your own blog (the source of which came from wordpress.ORG).

    So, go to wordpress.com. Sign up for an account. Yes, this gives you a free blog. No, you don't need to ever use it. Just log into it and poke around in the Admin stuff and you'll find your API key. Copy that back over to YOUR "real" blog.

  5. cacique
    Member
    Posted 8 years ago #

    Hello, HandySolo:

    That was painless...thanks a million! I think I've got it all covered - for the time being, anyway.

    You've been a big help!

    Cheers,
    David

  6. Chris_K
    Member
    Posted 8 years ago #

    Pleased to help - happy blogging!

  7. Ned1
    Member
    Posted 8 years ago #

    I had similar symptoms in my installation, and the suggested fix worked. I have a development (non-public) installation of WordPress installed on my own local server. Browsers run on the server displayed the blog as expected. Browsers run on other machines on the LAN displayed text only and had link problems as described.

    If you're setting up a local server, do not set WordPress Address (URI) and Blog Address (URI) to "http://localhost". Set them to either the IP address (e.g. http://192.168.1.6) or a symbolic name (http://servername) if your test client machines have Hosts files. BTW, your local server must have a static IP address, or you'll have another problem to solve!

    Hope this helps someone else.

  8. Mauricevandorpnu
    Member
    Posted 8 years ago #

    That fix does indeed work, but now i have the follwing problem.

    If i set the URI address to my local machines ip, i can manage my blog, but nobody can see it on the internet.

    If i change it to my domain name, internet user can view my blog.. but i cant do anything with it...

    anybody got a solution?

    thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic