WordPress.org

Ready to get started?Download WordPress

Forums

no graphics? (7 posts)

  1. edm00se
    Member
    Posted 9 years ago #

    I've installed WP and thought everything was hunky-dory. It looked good when I checked it and I was beginning to get everything just how I wanted it. Imagine my surprise when I check it from a remote machine for the first time and realize that none of the graphics appear. Only black and blue text, nothing of my customized theme, shows up. I've checkd my permissions and everything should be normal. I have no clue what could be doing this, though I suspect something foul is afoot. Again, when I check it locally, it's perfectly fine, when I check it remotely, no graphics whatsoever. All help is appreciated.

  2. edm00se
    Member
    Posted 9 years ago #

    Addendum: It's not the themes. I tried changed to about 4 different themes, including the default, and the themes are not what's causing it to revert to text only.

  3. techwench
    Member
    Posted 9 years ago #

    Are you testing it on localhost, then viewing on another machine?

    Check the options menu and look at your site URL and home url.

    The themes call the stylesheet (and images) according to what's in the WP Admin. It uses <?php bloginfo('stylesheet_url'); ?> so if your url settings are different in the WP admin, then when you view the source from a remote machine, you'll probably see that it's trying to pull a nonexistant stylesheet.

  4. Kafkaesqui

    Posted 9 years ago #

    A link to your blog would help troubleshoot this, but what are your settings for WordPress and Blog address under Options > General?

  5. edm00se
    Member
    Posted 9 years ago #

    blog.rabbitlair.net It's a forwarding subdomain to my broadcast IP, with subfolder, of 68.61.238.195/blog
    Under options, I do have it set to use that as its blogaddress.
    As for testing, I have tested on localhost and then when I test with blog.rabbitlair.net, it works fine on the machine that is hosting it, however any other machines seem to not like it.

  6. This is your problem:

    http://localhost/blog/wp-content/themes/ocadia/style.css is where the blog is looking for the stylesheet. That's why it works on your computer but not anywhere else...

  7. edm00se
    Member
    Posted 9 years ago #

    Well, I fixed it. I'm having trouble connecting to the wp-admin because my home connection is butt slow, and I'm kind of freaked that I didn't realize that right off the bat, but it's all good now. Thanks for the help.

Topic Closed

This topic has been closed to new replies.

About this Topic