WordPress.org

Ready to get started?Download WordPress

Forums

Really Static
[resolved] no files generated (5 posts)

  1. wp.Man
    Member
    Posted 1 year ago #

    the versions posted on the forum are confusing - i used the version linked to in the "current development snapshot" forum, which is apparently 0.43

    yet the release version is 0.520121012

    which is the development version and which is the release version?

    in any case, it is failing to write any files. the error is "Really-Static dont have enoth writing Rights at the destinationfolder ( /home/usr/public_html/static/ )"

    this folder is set to 0777

    also, after attempting to generate the files (which are not actually generated)...

    Warning: Invalid argument supplied for foreach() in /home/usr/public_html/wp-content/plugins/php-really-static-main/main.php on line 2694

    and in my error log...
    2012-11-30 00:42:18.620 [NOTICE] [98.21.130.135:32515-0#APVH_12bytes.org] [STDERR] PHP Warning: preg_replace() [function.preg-replace]: Empty regular expression in /home/usr/public_html/wp-content/plugins/php-really-static-main/main.php on line 640

    also, on the admin > debug page, author writes that the log file to be sent does not contain any password. this is incorrect - the debug log contains both user and password

    http://wordpress.org/extend/plugins/really-static/

  2. wp.Man
    Member
    Posted 1 year ago #

    more confusion on the builds...
    the version on wordpress.org is 0.31
    the "development snapshot" is 0.43
    then there is 0.520121012 listed on their forum, but no link to download it

    lastly, when uninstalling, it leaves behind 50 db entries which have no common naming scheme

  3. Erik
    Member
    Plugin Author

    Posted 1 year ago #

    The current development snapshot is downloadable for everyone here: http://really-static-support.php-welt.net/current-development-snapshot-t5.html

    Your are right there was a error with the verion numbers.

    At wordpress.org i publish every month the newest version, but i keep the version on 0.31 so that users of the old version dont need to update.

    Now to you error, "failing to write any files": which protocol did you userd? ftp, sftp or local?

  4. wp.Man
    Member
    Posted 1 year ago #

    hi eriksef
    i used the local option. i think i created the /static directory under the root html directory /public_html/static if i remember right. i know i gave it 777 permissions for testing.

    i'm now testing the version you linked to. all default settings and i used the quick setup wizard (all tests passed). i chose to run RS in test mode. here is what i am seeing...
    * wp wants me to upgrade to a "newer" version: "You have version 0.5 installed. Update to 0.31."
    * when generating the files (step 4), RS tells me it's done and provides the link "jump to end", yet it is clearly still working. i let it continue until the page stopped loading and all seemed fine. the log file looked good, though i can't read german "tag wurde hinzugefuegt" :)

    i saw no php errors and wp with debugging enabled produced no errors, so all looks good. at this point im going to uninstall it, make some changes to my site, then i will try it again in live mode.

    i saw only 2 options db entries left after uninstall this time - "rs_onwork" and "ftpsaveroutine".

    personally i think it would be good to have the same prefix for all options (rs_)

  5. Erik
    Member
    Plugin Author

    Posted 1 year ago #

    hope all working now, as it should be !

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.