WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] No Featured Image metabox in MU? (26 posts)

  1. MatthewRuddy
    Member
    Posted 3 years ago #

    Is it just me, or does WordPress MU not allow for post-thumbnails? There is no featured image box, and I cannot find any documentation on enabling it for MU. I've tried various themes. Nothing in the WordPress Post-Thumbnails codex pages mentions it not working in MU.

    Do they work?

  2. Kim Parsell
    Volunteer Moderator
    Posted 3 years ago #

    Did you click the Screen Options link in the upper right and verify that the Featured Image box is checked?

  3. MatthewRuddy
    Member
    Posted 3 years ago #

    Yes I did.

    Regardless, I've decided to un-install MU.

  4. Ryan Duff
    Member
    Posted 3 years ago #

    They may be hidden by default in 3.1. You won't see them in single site or multisite. So uninstalling MU will do nothing.

    At best, maybe there's a plugin hiding them?

    Eg. I ran into that issue the other day using WooThemes because I needed to disable WooThemes Dynamic Images so it would revert back to WordPress featured images.

    Hope this helps.

  5. The work fine but they ARE hidden by default on 3.1

    3.1 hides some screen options on posts & pages edit screensby default. Just turn on the ones you want.
    More info here: http://ottopress.com/2011/wp-quickie-metaboxes/

    Alternately, put this in your theme's functions.php if you want the custom fields to show up by default (from this thread):

    // Change what's hidden by default
    add_filter('default_hidden_meta_boxes', 'be_hidden_meta_boxes', 10, 2);
    function be_hidden_meta_boxes($hidden, $screen) {
    	if ( 'post' == $screen->base || 'page' == $screen->base )
    		$hidden = array('slugdiv', 'trackbacksdiv', 'postexcerpt', 'commentstatusdiv', 'commentsdiv', 'authordiv', 'revisionsdiv');
    		// removed 'postcustom',
    	return $hidden;
    }

    (By the way, if you ever customized yours, that's why they didn't vanish. It only changed for people still using default.)

  6. And it;s nothing to do with multisite either.

  7. MatthewRuddy
    Member
    Posted 3 years ago #

    I've tested a single site install and multi-site install, both on the same server. The single site install showed Featured Images by default. The Multi-site install does not. In the screen options tab, Featured Images isn't even there. Both are using the same theme (my own theme, La Rivista) and I've also tried both with the default TwentyTen theme. Exactly the same.

    Single site install:
    Click Here

    Multi site install:
    Click Here

    FYI: These are both two brand new installs. No plugins have been installed, and only two themes; My own and Twenty Ten.

  8. And something else, cause you have La Rivista Post Options, and THAT is not a part of WordPress....

  9. Does your custom theme use caps like edit_theme? Cuz that;s only available to SUPER admins on multisite.

    Lower those caps.

  10. MatthewRuddy
    Member
    Posted 3 years ago #

    It uses edit_themes. I am the super admin of this site.

    The La Rivista Post Option is part of the custom theme. The themes custom meta boxes work fine in both. In both the single and multi-site install, the Featured Image meta box doesn't work with BOTH the TwentyTen theme and my own custom theme; therefore I highly doubt it is a theme specific issue? I also tried out a third theme to no avail.

  11. Found it.

    On multisite, if you do not enable the IMAGE UPLOADS, under Network admin -> Settings, then .... well, that kind precludes having featured images.

    Tick that box. Save.

    Featured images show up on the screen options tab.

  12. MatthewRuddy
    Member
    Posted 3 years ago #

    Yes that worked perfectly. Thanks!

    Matthew.

  13. fmulreany
    Member
    Posted 3 years ago #

    Just had the same moment of panic when I couldn't find the Featured Image meta box on a brand new WP Multisite 3.1 install.

    Thanks for the tip Andrea! All sorted now :)

  14. louis.beziau
    Member
    Posted 3 years ago #

    This will fix the problem
    http://codex.wordpress.org/Post_Thumbnails

  15. bpastorkia
    Member
    Posted 3 years ago #

    Andrea, Thanks a lot!!!
    I was looking for a lot of time!!

  16. redcouchstudio
    Member
    Posted 3 years ago #

    I couldn't find the featured image box either on a brand new 3.1 install. Odd that these image uploads is not on by default!

    Thanks so much. I've been pulling my hair out on this one.

  17. Nuno Morgadinho
    Member
    Posted 3 years ago #

    This gets me every time. Thanks Andrea

  18. Cultivate
    Member
    Posted 3 years ago #

    add_theme_support( 'post-thumbnails', array( 'post', 'page' ) );
    This is the code i've been using in my functions file to add the Featured image meta box on single installation of wordpress.

    However this doesn't work on a network setup. To get it to work i had to remove the array. Do you not need to target post types anymore?

  19. Check to see how they did it in TwentyTen.

  20. Cultivate
    Member
    Posted 3 years ago #

    Yes I have, that's why I know to remove the array. So it becomes add_theme_support( 'post-thumbnails');

    My question was do you no longer need to target post type?

  21. Tim Moore
    Moderator
    Posted 3 years ago #

    You never were required to target post types. The option exists if you wish to only enable support for certain post types (only posts, posts and pages, only pages, etc.).

    In MultiSite, you also need to go into /wp-admin/network/settings.php and check off the three boxes under "media upload buttons." If those boxes are unchecked, post thumbnails won't show up even if you've called add_theme_support( 'post-thumbnail' );

  22. billimebilly
    Member
    Posted 3 years ago #

    Did you guys really solve this?

    It's true that Featured Image metabox appears in main blog, but it doesn't appears in network blog..

    When I navigate to another blog using both admin and super admin, it is not showing, even on Screen Options.

  23. Are the sub blogs using a theme that supports it? Cuz yes, it works for us.

  24. billimebilly
    Member
    Posted 3 years ago #

    AAAAAah yes, it works!
    Thank you Andrea, it was my mistake to make it as an option in my themes to use post-thumbnail.

    Thanks again! ;)

  25. Riaz
    Member
    Posted 3 years ago #

    In MultiSite, you also need to go into /wp-admin/network/settings.php and check off the three boxes under "media upload buttons." If those boxes are unchecked, post thumbnails won't show up even if you've called add_theme_support( 'post-thumbnail' );

    It saved me ,

    network admin -> dashboard -> settings -> upload settings ->

    check the images, videos, ..., thats all , featured image meta box will be shown in your post edit page.

    thanks TIM

  26. JHouse
    Member
    Posted 3 years ago #

    "On multisite, if you do not enable the IMAGE UPLOADS, under Network admin -> Settings, then .... well, that kind precludes having featured images.

    Tick that box. Save."

    Thanks Andrea_r, your solution worked perfectly for me.

Topic Closed

This topic has been closed to new replies.

About this Topic