WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] No Errors but not working (5 posts)

  1. scorpioserve
    Member
    Posted 1 year ago #

    Using WordPress 3.4.2 and EWWW Image Optimizer 1.3.6, the debug info shows
    jpegtran: OK version: Independent JPEG Group's JPEGTRAN, version 9 13-Jan-2013
    optipng: OK version: OptiPNG version 0.7.4
    gifsicle: OK version: LCDF Gifsicle 1.68
    GD: OK   Imagemagick 'convert': OK
    safe mode: Off  exec(): OK  shell_exec(): OK  finfo: OK  getimagesize(): OK  mime_content_type(): OK
    Operating System: Linux

    When I upload a new 2mb image, it uploads fine and says Reduced by 8.1% (181 KB), Image Size: 2MB, Re-optimize, so all looks like it is working.
    If I go to where the image path is from FTP though, I still have a 2MB image in that folder and all the various size ones that wordpress has created for me, there is no new file with a different name like reduced and my original file size remains 2MB

    What am I missing here, I dont know if I am just not doing something correctly.

    What I would like is if all newly uploaded media gets reduced automatically with your plugin and replaces the original, then all the wordpress variants at different sizes get generated.
    For images already in my Media Library I would like to click optimize and for the original file to get replaced with no name alteration to the newly optimized file.
    Is this possible.

    Just by the way this is hosted on my own server with Hetzner Germany and the PHP Config on that is set as follows
    PHP version 5.3.3
    register_globals: off
    magic_quotes_gpc: off
    allow_url_fopen: off
    memory_limit: 64mb
    max_execution_time: 30 seconds
    upload_max_filesize / post_max_size: 16mb

    The only other thing that might be causing the issue is possibly the unusually long urls that this particular site is using
    http://www.seasonsinafrica.com/lodges-in-south-africa/timbavati-private-nature-reserve/kings-camp-private-game-reserve/blog/

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    From what you describe, the only thing amiss is the file size of the original image as you list it at 2 MB. It must surely have been slightly larger, around 2.1 or 2.2 MB. Here is what I would do to verify that things are working properly. Click on the original file, and find the exact file size, down to the last byte--something like 2,134,134 (just making up numbers there). Then upload it into wordpress with the plugin enabled. Go in with FTP (make sure you've refreshed your view in the ftp client), and check the exact filesize on the server in the uploads folder. It ought now to be something smaller, in the realm of the percentages displayed by the plugin.

    In short, the plugin is designed to do exactly what you are asking of it, and I've verified serveral uploaded images on my own server just to be sure.

  3. scorpioserve
    Member
    Posted 1 year ago #

    I still dont think it is working although it looks like it is. Here is my test
    Upload File Name: Rock-Fig.jpg
    Original File Size: 299.41KB
    Dimensions: 576 x 768px

    Uploaded through the media library, after upload this is what the media library records
    Upload File Name: Rock-Fig.jpg
    Reduced by 14.8% (52.2 KB)
    Image Size: 299.41
    Re-optimize

    So without looking at the FTP all seems to be perfect.
    Now I go to the FTP client, disconnect, reconnect, go to the correct folder /wp-content/uploads/2013/01/ refresh the folder just incase
    I Find 7 images for my file
    Rock-Fig-100x100.jpg @ 5.02 KB
    Rock-Fig-150x150.jpg @ 9.91 KB
    Rock-Fig-225x300.jpg @ 25.54 KB
    Rock-Fig-268x200.jpg @ 20.72 KB
    Rock-Fig-310x190.jpg @ 22.31 KB
    Rock-Fig-576x395.jpg @ 75.73 KB
    Rock-Fig.jpg @ 299.41 KB

    Therefore it looks like although wordpress is reporting the correct results they are false, I have also tried altering permissions to 777 on the upload directory just incase, but that did not help.
    Please help, I think I am so close yet it is just not working.
    If you like I can give you access to everyhing.

  4. scorpioserve
    Member
    Posted 1 year ago #

    I did another test quickly, i went to settings and dropped the quality down to 10% just for testing, and now I see what you mean, yes it is working as expected.
    Unfortunately my users, well some of them are uploading 7mb images, and although wordpress is wonderful in making all the different sizes for the main view of the post, when the image is clicked on to show the full size image in a lightbox, that links to the 7MB jpg file and it is just way too big.
    Is there a way to set a maximum dimension for images so anything over 1280px width or height gets reduced to 1280px as an example.

  5. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Well, I hate to burst your bubble, but according to your previous post, it most definitely is not working correctly. As you said, the original image was 299.41 KB, and the optimizer said it reduced it by 52.2 KB, yet it is still 299.41 KB. You should have to edit anything on the quality settings when you are just optimizing JPGs. The quality setting is only used when converting PNGs to JPGs (useful for screenshots that have a lot of photographic elements). If you can contact me via the Contact form at shanebishop.net, we'll see if we can't figure out what is going wrong. It would seem you've discovered some sort of bug, but I'll need to take a closer look to figure out what it is.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.