WordPress.org

Ready to get started?Download WordPress

Forums

Custom Post Type UI
[resolved] "No entries found" in post categories (6 posts)

  1. villarroel
    Member
    Posted 1 year ago #

    Hi,

    I have used this plugin to create a custom post type. I have created some categories that I have assigned to some posts. I've added a categories widget to my page so that the posts appear categorised in a menu. This seems to work ok and when I assign new posts to the categories the count in the menu goes up. However, when you click on one fot he categories it gives you the message "Apologies, but no entries were found."

    The page is here: http://istudyenglishonline.com/english-expressions-idioms/

    Any help would be greatly appreciated!

    http://wordpress.org/extend/plugins/custom-post-type-ui/

  2. CPDesign
    Member
    Posted 1 year ago #

    Try adding this to your theme's functions.php file

    function any_ptype_on_cat($request) {
    	if ( isset($request['category_name']) )
    		$request['post_type'] = 'any';
    
    	return $request;
    }
    add_filter('request', 'any_ptype_on_cat');
  3. Michael Beckwith
    Member
    Plugin Author

    Posted 1 year ago #

    did CPDesigns' idea help at all?

  4. villarroel
    Member
    Posted 1 year ago #

    Really sorry for not replying sooner, been a bit crazy here.

    In the end I decided not to use the custom post types and go back to the normal posts, seems to work a lot smoother.

    Thanks

  5. Michael Beckwith
    Member
    Plugin Author

    Posted 1 year ago #

    Glad you found a solution regardless of the method :)

  6. yanks789
    Member
    Posted 1 year ago #

    I was having the same problem. I used the method mentioned above and it worked perfectly! Thank you, I had been searching for hours!!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.