WordPress.org

Ready to get started?Download WordPress

Forums

No email notification on WP 2 (16 posts)

  1. philpot
    Member
    Posted 8 years ago #

    Hello

    Since I upgraded to WP2 I am not receiving the email notification when someone posts a comment - set up in [OPTIONS]: [DISCUSSION]: Email me whenever...

    It used to work but now it doesn't

  2. Zazen
    Member
    Posted 8 years ago #

    Have also asked this. Glad it's not just me.

  3. philayres
    Member
    Posted 8 years ago #

    I'm having the same issue.

  4. Scope
    Member
    Posted 8 years ago #

    same here

  5. rh2600
    Member
    Posted 8 years ago #

    I was having the same problem, no emails. But I also realised that if someone tried to write a post, or register, once they submitted the form, the next page was broken or blank.

    I disabled LiveSearch as a plugin and the problem went away. So just confirm that posting to your site is working too.

    If Livesearch is the plugin problem for you too, then I recommend posting on the authors blog :)

  6. shaky
    Member
    Posted 8 years ago #

    Same issue here. No LiveSearch

  7. philpot
    Member
    Posted 8 years ago #

    I don't have Livesearch installed.

    I have disabled all plugins, and still I don't get a notification email when a comment is posted. I know the site can send emails (password request works), so it's not that.

    Could it be a permissions thing?

  8. Scope
    Member
    Posted 8 years ago #

    Okay, i stumbled butt backwards into a solution that seems to work for me. Im on a windows IIS shared server, so in order to get permalinks work correctly for me I had to use the 'Permalinks Without mod_rewrite' workaround as explained on the codex...
    http://codex.wordpress.org/Using_Permalinks

    Just a vague guess on my part that 2.0 was handling mail differently than 1.5 and that it was my shared IIs server causing the glitch...
    ie: i couldnt use the default localhost in wp-config.php , had explicity enter the db_host

    so after googling around a bit about php.ini and Mail, a
    php.ini sample (totally unrelated to wordpress) had this entry that caught my eye....

    [mail function]
    ; For Win32 only.
    SMTP = localhost

    ; For Win32 only.
    sendmail_from = me@localhost.com

    so i added the above to my php.ini (that contained only the permalink workaround) adding my info in place of localhost (mail.mydomain.com) and my Email in place of me@localhost.com.

    lo and behold, my email notifications worked. Author notice, Moderation notice etc..

    i removed the second part of the above and it turns out the
    sendmail_from was not needed, so my php.ini contains only the below..as it would not work without it.

    [mail function]
    ; For Win32 only.
    SMTP = localhost

    -----------

    I blabbered about my permalinks issue so youd understand what made me think of this "solution"

    Honestly, I DONT really understand why it does what it does, and I DONT know what negative effects it might have...yes im not so smart :P

    So this is not a real solution , just a workaround that happens to work for me so far....maybe it will help others.

    Hopefully someone alot smarter will explain to us how we can really check/correct/modify mail settings within wordpress's configuration itself. id really rather not depend on this.

    -----------------
    fyi: there are mail plugins that might help folks...unfortunately im also having unresolved plugin issues so i havnt had a chance to see if mail plugin would help

  9. kamiga
    Member
    Posted 8 years ago #

    I, too, do not have LiveSearch installed.

    I'm not seeing notification emails for anything under WP 2.0.

    Any status or fix on this?

    Thanks

  10. popf
    Member
    Posted 8 years ago #

    me too ... any others give a hand?

  11. bitrot
    Member
    Posted 8 years ago #

    I'm getting a related (or possibly the same) issue: I don't get e-mails when comments are held for moderation, but I DO get an e-mail when I approve and publish the comment (which is helpful ;).

    I'm using 2.0.2, with the K2 theme, and I've got both e-mail options ticked (...when: "Anyone posts a comment" + "A comment is held for moderation").

    The fact I get the e-mail on publication means sendmail is set up and configured correctly, so the only explanation is a bug in WordPress.

  12. headlessspider
    Member
    Posted 8 years ago #

    i am having the same issue as above. i'm using 2.0.1.

    i don't know if this is really related but when click on the my admin e-mail address in opntions - general i get:

    note: in an effort to combat spam, we require that this e-mail address match your domain (e.g. you@blog.alanguilan.com).

    i don't know if i can make such an address with the subdomain there.

  13. bitrot
    Member
    Posted 8 years ago #

    I've cracked it! At least, I've solved the problem I was having - no e-mail notification when a comment was put into moderation. I hope this works for some of you too.

    The problem was on line 401 of wp-include/pluggable-functions.php. It's the line inside wp_notify_moderator() that calls wp_mail() function (with the @ error-supression prefix). The problem is that it doesn't pass any mail headers to the function, and hence it attempts to send the mail with no "From" address. Some ISPs/hosts will allow this and others won't, which is why only some people are affected. This occurred to me when I looked at the wp_notify_postauthor() function further up that same file: on line 359, you'll see it does pass headers to wp_mail().

    So, the solution is to replace line 401, i.e.:

    @wp_mail($admin_email, $subject, $notify_message);

    with the following:

    $message_headers = "MIME-Version: 1.0\n"
    . "From: $admin_email\n"
    . "Content-Type: text/plain\n";
    $message_headers = apply_filters('comment_moderation_headers', $message_headers, $comment_id);
    @wp_mail($admin_email, $subject, $notify_message, $message_headers);

    (I hope that comes out with formatting intact!)

    Hope this helps some of you!
    Cheers, Mark.

  14. bitrot
    Member
    Posted 8 years ago #

    p.s. Couple of things I forgot to mention:

    1. You should probably "do the right thing" and get the code to e-mail you in the same character set as your blog. To do this, change the first line above to the following:
      $message_headers = "MIME-Version: 1.0\n"
      . "From: $admin_email\n"
      . "Content-Type: text/plain; charset=\"" . get_settings('blog_charset') . "\"\n";
    2. I guessed at the value comment_moderation_headers that I'm passing to apply_filters from looking at other values passed elsewhere. I've no idea what it does (if anything at all!) but it doesn't seem to do any harm. :-)
  15. keogh
    Member
    Posted 8 years ago #

    wohoo.. - bitrot i will put you're name i my will!! : )) this mod works perfect!! A big kiss to you!

  16. trueepicure
    Member
    Posted 8 years ago #

    I've not been able to get either this mod or the wpphpmailer plugin to work. I've contacted my host to see if they've changed anything on the server end, but I'm not feeling very confident... anyone else come up with other solutions? A new version of WP perhaps??

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags