WordPress.org

Ready to get started?Download WordPress

Forums

BlackBird
[resolved] No comments on posts page (5 posts)

  1. cressie
    Member
    Posted 1 year ago #

    My posts are automatically appearing on a blog page but I can't get the comments feature to work. I want people to be able to post comments in response to blog posts. Is there and option to allow comments for posts? My website is http://www.etiedge.com

  2. paulwpxp
    Font hero
    Posted 1 year ago #

    If all you posts now don't allow commenting at all, the first place to check is the sitewide settings on discussion.
    https://codex.wordpress.org/Settings_Discussion_Screen

    If some posts do, some posts don't, check Discussion metabox on each post editing screen. In case the metabox doesn't show up, pull it down via Screen Option tab (top right).

  3. cressie
    Member
    Posted 12 months ago #

    Thanks for the quick response. My settings in the discussion screen allow for comments but the template for posting doesn't have any option for me to allow or deny comments. When I open the blog page, there is a link that says 'no comments' but there isn't an option to write a comment. The page is here http://www.etiedge.com/blog/

  4. paulwpxp
    Font hero
    Posted 12 months ago #

    but the template for posting doesn't have any option for me to allow or deny comments.

    Did you pull down the Screen Option tab over at the top right ?

  5. cressie
    Member
    Posted 12 months ago #

    Ah ha! Clicking the discussion check box opened up the comment check box below the post. You're a genius - thank you!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic