WordPress.org

Ready to get started?Download WordPress

Forums

No comments on page (9 posts)

  1. Fizzgigg
    Member
    Posted 4 years ago #

    I've got a WP installation where the default setting is that no comments are allowed. However, I thought I should create a page and allow comments only on that page, using it as a guestbook.

    The default setting for the installation is no comments allowed, but on this page I mark the setting allowing comments. But no matter what I do, I can't get the comment box to show.

    Does anyone have an idea, and how can I solve the issue?

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    It could well be that your theme's page template (page.php) does not include the comment template. Try editing page.php and looking for <?php comments_template();?>. If you can't find that template tag, try adding it just before <?php endif;?>.

  3. Fizzgigg
    Member
    Posted 4 years ago #

    I am using the theme Thematic, and looking at page.php it look slike this:

    <?php get_header() ?>
    
    	<div id="container">
    		<div id="content">
    
    <?php get_sidebar('page-top') ?>
    
    <?php the_post() ?>
    			<div id="post-<?php the_ID(); ?>" class="<?php thematic_post_class() ?>">
        			<?php thematic_postheader(); ?>
    				<div class="entry-content">
    <?php the_content() ?>
    
    <?php wp_link_pages("\t\t\t\t\t<div class='page-link'>".__('Pages: ', 'thematic'), "</div>\n", 'number'); ?>
    
    <?php edit_post_link(__('Edit', 'thematic'),'<span class="edit-link">','</span>') ?>
    
    				</div>
    			</div><!-- .post -->
    
    <?php if ( get_post_custom_values('comments') ) thematic_comments_template() // Add a key+value of "comments" to enable comments on this page ?>
    
    <?php get_sidebar('page-bottom') ?>
    
    		</div><!-- #content -->
    	</div><!-- #container -->
    
    <?php thematic_sidebar() ?>
    <?php get_footer() ?>

    I can't find either <?php comments_template();?> nor <?php endif;?>.

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    In Thematic, if you want to enable comments on a page, you need to enter a custom field.

    1. In Edit Page, expand the Custom Fields box
    2. In the Custom Fields box, add a new key with the exact text comments
    3. Add any text for a value (some text must be included for the key to save)
    4. Click Add Custom Field to save the key/value
    5. Comments should now be enabled on that page

  5. Fizzgigg
    Member
    Posted 4 years ago #

    Wow, it's starting to work! You're a genius.

    The background color is white and not the same color as the rest of the site. Do you know where I can change it (either remove the white color or change to the same color as the bakground)?

    Does this change with the custom fields change anything with the overall settings for the page, or does it still use the default settings (if you have to be logged in, registered and so on in the Settings/Discussion settings page). Not actually sure what the settings page is called since I don't use the English version.

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    Do you know where I can change it

    A link to your site would help.

    Does this change with the custom fields change anything with the overall settings for the page

    No. It literally just enables the comment template. All other settings should be inherited from Admin/Settings/Discussion.

  7. Fizzgigg
    Member
    Posted 4 years ago #

    Unfortunatelly (in this case), I'm working with the site on a local test machine and it's not reachable from "the outside".

  8. esmi
    Forum Moderator
    Posted 4 years ago #

    If you use Firefox, install the Firebug add on. It will help you to pinpoint what CSS you need to change/override.

  9. Fizzgigg
    Member
    Posted 4 years ago #

    I'm not usually using FF, but since I-ve got it installed I've give it a try.

    Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Topic