WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] No Comments links to Archive Page? (12 posts)

  1. ttague
    Member
    Posted 8 years ago #

    Rank Newbie here: My site is lovely - but I have one problem. Clicking on the "no comments" link (in order to test posting a comment) simply takes me to the Archive page - no text box, no nothing. This occurs in all five themes I have tried.

    Any ideas would be appreciated.

    TT

  2. moshu
    Member
    Posted 8 years ago #

    Let us see it...

  3. ttague
    Member
    Posted 8 years ago #

  4. moshu
    Member
    Posted 8 years ago #

    Either change the slug of your Archives page from "archives" to something else... or change the word "archives" in your permalink structure to something else.

  5. ttague
    Member
    Posted 8 years ago #

    Presto! Changed the permalinks structure and all is good.

    Thanks for the (incredibly) fast response and help.

    TT

  6. saysay
    Member
    Posted 7 years ago #

    I am having the same problem. When it goes to a single page there is no option for comments and on the main page the "Comment" link takes me to the archive.

    S

  7. moshu
    Member
    Posted 7 years ago #

    If you have the "same" problem - apply the same fix. Read before posting...

  8. saysay
    Member
    Posted 7 years ago #

    OK? Thanks for your quick response. I will try to be more clear. I am new to WordPress, forgive me.

    1.) I have been searching/reading for quite some time now.
    2.) I tried to apply the above fix but have not been successful.
    a.)I do not know what a slug is. (Can't find any good doc on it.)
    b.)My permalinks structure does not contain the word "archives".

  9. moshu
    Member
    Posted 7 years ago #

    Then post a link to your blog.

    And this is for slug:
    http://codex.wordpress.org/Introduction_to_Blogging

  10. saysay
    Member
    Posted 7 years ago #

    Hello again, thank you.

    http://codex.wordpress.org/Glossary#Post_Slug

    I do not have a %posttitle%

    My Permalink structure looks like this: /%year%/%monthnum%/%day%/

    The link to my comments looks as such: http://mysite.com/WPfolder/2006/09/25/#respond

    Which takes me to that destination, sans a comment form, option or box.

  11. moshu
    Member
    Posted 7 years ago #

    Then read about it in the Codex
    http://codex.wordpress.org/Using_Permalinks
    Pay special attention to warnings when NOT using any post identifier (ID or name).

    If you reset the permalinks to default does it work?

    P.S. And that's why I doubted you have the "same" problem... Next time write ALL the important details/info in your first post. Don't wait until somebody asks them. They might get bored and leave you without a solution.

  12. saysay
    Member
    Posted 7 years ago #

    I did read the page you specified, hours ago earlier today. The part I see now that seems to pertain to the problem (just to leave a breadcrumb for anyone else having the same issue and is not ultra familiar with WordPress) is stated here:

    ----- It's important to guarantee permalinks lead to individual posts within your custom URI, so make sure to end a virtual site structure with either %post_id% or %postname% -----

    P.S. I was having the same *symptoms* as the prior poster. The solution was different. Thank you for not "getting bored" and moving on. Although I would think that would not be a desirable quality in moderator of a helper forum :)

    Resetting to default worked, yes.

Topic Closed

This topic has been closed to new replies.

About this Topic