WordPress.org

Ready to get started?Download WordPress

Forums

No comment/leave a reply form for single posts (8 posts)

  1. JAP198
    Member
    Posted 2 years ago #

    After two days of research I have to ask now. Sigh.

    I use the free version of pagelines/platform. I deactivated plugins before and switched to another theme as well. I also made sure that in "discussion" all necessary boxes are ticked, eg allow comments and so forth but still: there is no leave a comment/leave a reply link or form on the bottom of my post page or the single post. I have three pages: About, Shots, Contact and on About and Contact I can at least see the social media icons for Twitter and Facebook. On my Shots (post page/blog page) there is nothing! When I activate another theme I could leave a comment on the About and Contact page but not on Shots - the only page where it´s necessary! I am not sure but I assume that it has something the do with wordpress as well as with the pagelines theme? I am getting really desperate :((((

    Thanks for all your help!

    http://www.seensomething.com

  2. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

  3. JAP198
    Member
    Posted 2 years ago #

    Still not working :(

    Thank you!

  4. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    When I activate another theme I could leave a comment on the About and Contact page

    Which shows it is a theme setting.

    There are other posts on that forum also. Do a search on their forum for "comments do not show."

    Google "comments do not show pagelines wordpress."

    Better than waiting for someone who might come along.

    And just a thought, I know they are your initials but for some the term JAP would be very offensive. Not that I am PC - just wanted to point it out. :^)

  5. JAP198
    Member
    Posted 2 years ago #

    Ok, theme setting. I googled and I tried to find something out on their forum for the last two days...and I just tried to find some help here. Frustrating...

    Uuuum, yeah. JAP are my initials....well, I don´t know what to say. Thanks for your help anyway...

  6. Simon Prosser
    Theme Review Admin
    Posted 2 years ago #

    You have to have the comments section active http://screencast.com/t/6swDOhkoLD

    If you have that, and comments are enabled for the post it will appear.

  7. JAP198
    Member
    Posted 2 years ago #

    When I activate another theme, I could only leave a comment on the About and Contact page but not on the Shots page which is my actual post page....so I think it's not a theme setting?!

    What I would love to have in the end:

    About & Contact page - NO comment/leave a reply
    Shots page - YES comment/leave a reply link (and social icons)after each post or when I open the post.
    At the same time I would love to have the Shots page as my Front Page - is this possible? Maybe I deleted some important code....argh! Going crazy :D

    Well, I have activated the comment section in pagelines and also the Social Sharing Icons....I also enabled them in the Screen Options....

    Pleaseeee help me! :) I will change my initials in JP as well! ;-)

    Many thanks!

  8. sagdude2002
    Member
    Posted 1 year ago #

    Hi JAP198,

    To keep comments off your pages, open the Page Template in Appearance - Editor, find a code similar to <?php comments_template( '', true ); ?> and delete it...or just try taking out the word true.

    To show a comment form on your Posts, try checking

    Settings
    Discussion
    "Automatically close comments on articles older than __ days."

    If you posts are older than the setting, a comment form won't show.

    Hope this helps. Good luck!

Topic Closed

This topic has been closed to new replies.

About this Topic