WordPress.org

Ready to get started?Download WordPress

Forums

no comment entry ability? (12 posts)

  1. carla
    Member
    Posted 9 years ago #

    I know this problem is probably due to an error of mine :) --
    when you click on the "leave a comment" link, you get taken to the entry's page, but with no comment form. Here's an example:
    http://www.hauntedpalace.net/library/index.php/archives/2004/07/20/15.37.13/#comments
    I bet I've zigged when I should've zagged. Any suggestions? Thanks!

  2. Anonymous
    Unregistered
    Posted 9 years ago #

    well, the form isn't in the html. do you have comments off or something? hmm

  3. pamela
    Member
    Posted 9 years ago #

    I'm having this same problem. I detailed my issue in another thread, but I haven't gotten any responses yet. :(
    http://wordpress.org/support/index.php?action=vthread&forum=3&topic=8996&page=0
    And, I do have comments turned on under Options.

  4. carla
    Member
    Posted 9 years ago #

    I double-checked--I do have comments enabled.
    I see that the code for leaving a comment appears to be pointing to the pop-up comments, even though I don't have them enabled. How should I edit this code, then? Thanks!
    <div class="feedback">
    <?php wp_link_pages(); ?>
    <?php comments_popup_link(__('leave a comment/tb'), __('Comments (1)'), __('Comments (%)')); ?>
    </div>
    <!--
    <?php trackback_rdf(); ?>
    -->
    <?php include(ABSPATH . 'wp-comments.php'); ?>
    </div>

  5. pamela
    Member
    Posted 9 years ago #

    I just reverted to the default index template (pulled from the zip file) and inline comments still don't work. I uncommented the code in the header and the pop-up comments worked fine, displaying comments and the submit box, but I don't want pop-up comments. I want inline comments.

  6. pamela
    Member
    Posted 9 years ago #

    I think we're just talking to each other, Carla.

  7. Carrie
    Member
    Posted 9 years ago #

    I think I might have figured it out. I was having the same problem. I added /index.php/ to the front of my permalink line, saved the permalinks, copied the text that appears at the bottom of the permalink page into my .htaccess file, refreshed everything and it worked.
    So for instance, instead of :
    /archives/%year%/%monthnum%/%day%/%postname%/
    I am now using :
    /index.php/archives/%year%/%monthnum%/%day%/%postname%/

  8. pamela
    Member
    Posted 9 years ago #

    Indigohat, thanks for the suggestion. I messed around with the permalink settings and .htaccess file and discovered the problem.
    My .htaccess file was just in the wrong directory. I have WordPress installed to /wp but my blog index appears in the root. I copied .htaccess to / and left my archive format as /archives/%year%/%monthnum%/%day%/%post_id% and now the comments and submit form work properly.
    I had been unsure of which directory .htaccess needed to be in, but I thought it was /wp since it needed to be there for the template editor in the control panel to access it. It just didn't occur to me that after changes, I needed to copy it to root just as I did with index.php. To save me a little trouble, my husband set up some symlinks for me, so I can skip copying those files from /wp to / .
    In summary, your .htaccess file needs to be in the same directory that you list for your blog homepage.

  9. carla
    Member
    Posted 9 years ago #

    I made certain that my .htaccess information was correct, and it's in the same folder as my index.php (and my index.php is in my permalinks). Still the same result. :(

  10. mawi
    Member
    Posted 8 years ago #

    I have just the same problem as you carla. I think I've done everything to try to find the problem but it's still there. I don't know what to do.

  11. moshu
    Member
    Posted 8 years ago #

    1. I checked and there is comment form on your single post view. So what is the "same problem"?
    2. This thread was started 1 (one) year ago - since then several new versions of WP were released, so it's not a healthy thing to continue the discussion here, because a lot of things have been changed since.

  12. mawi
    Member
    Posted 8 years ago #

    I'm really sorry but that's another news posting system - Fusion.
    My WordPress is here: http://aishiteru.ummu.org/blog

    Sorry for posting here. I made another post on the forum. Thanks for the help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.