WordPress.org

Ready to get started?Download WordPress

Forums

Admin Management Xtended
[resolved] No Column Resizing for Pages List (10 posts)

  1. Susan Warren
    Member
    Posted 1 year ago #

    Hi,

    I'm trying out Admin Management Xtended, v2.3.7, on WP 3.5, and I've encountered a problem:

    If I view "all pages" on a monitor running at 1152px wide, the columns on the "all pages" page don't resize properly. This results in the page titles and everything else being displayed in long vertical lists that are impossible to read. If I move my browser to my other monitor, which is running at 1680px wide, the pages columns all display properly.

    This is only happening for pages: for posts, the "all posts" display is correct on both monitors-- the columns resize for the narrower display and the longer column headers (eg "Categories") wrap and hyphenate properly to accommodate the narrower column widths.

    Why would this be happening, and why only for pages and not for posts? Is there a fix or work-around?

    Thanks....

    http://wordpress.org/extend/plugins/admin-management-xtended/

  2. Alphawolf
    Member
    Plugin Author

    Posted 1 year ago #

    It does work fine for me on any narrow display, see: http://screens.schloebe.biz/image_2013-01-25_14_49_27_001.png

  3. Susan Warren
    Member
    Posted 1 year ago #

    What happens if you turn on "categories", "tags", and the rest of the "show on screen" column options for pages?

  4. Alphawolf
    Member
    Plugin Author

    Posted 1 year ago #

    You can't turn on "categories" and "tags" on the pages screen. Only posts do have categories and tags.

  5. Susan Warren
    Member
    Posted 1 year ago #

    If I run plugins that allow me to assign categories and tags to pages, I can.

    Here's a screenshot of part of the page list with AM Xtended plugin enabled: https://dl.dropbox.com/u/1377596/pages-with.jpg

    Here's one with it disabled: https://dl.dropbox.com/u/1377596/pages-without.jpg

    And here's one of the posts with the plugin disabled: https://dl.dropbox.com/u/1377596/posts-without.jpg

    And one with of the posts with the plugin enabled: https://dl.dropbox.com/u/1377596/posts-with.jpg

  6. missmedia7
    Member
    Posted 1 year ago #

    I was able to solve this by clicking All Pages on the Dashboard > Click on the Screen Options tab at the top of the window > Uncheck the column items that you don't need to see (i.e. tags, categories, etc) > Click Apply. My titles then displayed properly. Hope this helps.

  7. Alphawolf
    Member
    Plugin Author

    Posted 1 year ago #

    Susan Warren,

    missmedia7's way is the only solution here. You seem to have a lot of extra columns activated. If your screen's width is limited, that means that space for content/columns is limited too.

  8. Susan Warren
    Member
    Posted 1 year ago #

    I'm well aware that I can turn columns off and on, that's how they got there in the first place. And I know that I can turn off some columns and get the text to flow properly.

    My point is that the columns don't resize for pages but they do resize for posts. For example, the word "categories" doesn't wrap (and the column resize) for pages but it does wrap for posts.

    It may be that the categories column doesn't wrap for pages because I'm running a plugin that maps categories to pages, and that plugin may be affecting the column wrap. (Of course if I disable the plugin, that also removes the categories column and solves the problem, but that doesn't demonstrate how the plugin might be affecting the column wrap)

  9. Alphawolf
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin that maps categories to pages is the culprit here.

    Columns enhanced by my plugin are marked with a dotted underline. You can see it here: https://dl.dropbox.com/u/1377596/posts-with.jpg If you hover the column header, you see it in a title.

    The Categories columns here: https://dl.dropbox.com/u/1377596/pages-with.jpg don't have a dotted underline, so the columns were altered by the other plugin you're using. The plugin's obviously missing some styles for the columns.

  10. Susan Warren
    Member
    Posted 1 year ago #

    Your reply gave me some clues for further detective work, and I think I've got the thing figured out and hacked into shape. The map-categories-to-pages plugin doesn't have a css, but with the help of Firebug I managed to track down and play with the css that controls the edit page columns. I discovered that the culprit is the 15% fixed column width in wp-admin\css\wp-admin.min.css; by changing that to 8% I got a decent layout with all the edit page columns visible and the text fitting the columns. It also works if you just use a wildcard width and let the columns sort it out for themselves.

    I'm not keen on hacking a core file like this, but sometimes you've gotta do what you've gotta do.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags