WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
No available shipping methods (29 posts)

  1. floydrose5150
    Member
    Posted 1 year ago #

    I am getting the following error upon checkout:

    "Sorry, it seems that there are no available shipping methods for your location"

    Using latest version of Woocommerce. Also, have the Purolator extension enabled. However this error happens with or without Purolator.

    Really need assistance with this.

    Thanks!

    http://wordpress.org/extend/plugins/woocommerce/

  2. Daniel Espinoza
    Member
    Posted 1 year ago #

    Hi floydrose5150,

    You'll want to enable debug in Purolator's setup and see if any errors are output: http://cld.wthms.co/PorV

    Purolator is a calculator, and normally this message is due to the plugin not being able to calculate because the product does not have weight and dimensions defined for it. Make sure you've got weight and dimensions set on all products.

    Since you have purchased an extension you can go here to open a support ticket:
    http://www.woothemes.com/support

    You will need to login with the account that your client purchased the extension under.

  3. floydrose5150
    Member
    Posted 1 year ago #

    I appreciate your reply, woo's support has been way less than helpful.

    Also, that was one of the first things I tried was to make sure the product's weight and dimensions were specified in the applicable fields.

    Any other ideas? I feel I'll get better assistance here than with Woo.

    thanks

  4. Daniel Espinoza
    Member
    Posted 1 year ago #

    Was there any output in the debug options?

    The 2nd most prevalent issue is wrong credentials. Verify the API credentials are correct.

    And I work for Woo, so will try not to take that personally :)
    Open a ticket on the support desk and we can take a look.

  5. floydrose5150
    Member
    Posted 1 year ago #

    I have opened a support ticket at Woo. Output is as follows. All good except for:

    Purolator returned no rates - ensure you have defined product dimensions and weights.
    Array ( [ResponseInformation] => Array ( [Errors] => Array ( [Error] => Array ( [Code] => 1100491 [Description] => Product is invalid. [AdditionalInformation] => Shipping Error ) ) [InformationalMessages] => ) [ShipmentEstimates] => [ReturnShipmentEstimates] => )

    First things first, all product dimensions and weight are entered correct and all API credentials are correct.

    Woo support told me to upgrade to Woocommerce 2.0X which was an initial mess, but I managed to put things back together.

    So I am at a standstill trying to get my clients site to accept shipping.

    Any help is greatly appreciated. Thank you

  6. kfallis
    Member
    Posted 1 year ago #

    this has nothign to do with purolator -i have the same problem and no shipping method attached. Worked before upgrading to woo 2.0.5. beautifully with a few flat rate options ....i have canada and usa selected as countries in my backend and get same message on front end

    "Sorry, it seems that there are no available shipping methods for your location (United States). If you require assistance or wish to make alternate arrangements please contact us"

    https://www.remotestylist.com/checkout/

    anyone?

  7. Daniel Espinoza
    Member
    Posted 1 year ago #

    floydrose5150, I've asked the extension developer.

    What's your ticket # on woo.com?

  8. floydrose5150
    Member
    Posted 1 year ago #

    Ticket numbers: #33186 and #33525

    Thank you

  9. Daniel Espinoza
    Member
    Posted 1 year ago #

    I've grabbed those tickets and responded.

  10. floydrose5150
    Member
    Posted 1 year ago #

    Fantastic I just posted the credentials as you requested as well.

  11. floydrose5150
    Member
    Posted 1 year ago #

    still waiting for a solution on this.

  12. Daniel Espinoza
    Member
    Posted 1 year ago #

    I've responded on the ticket.

  13. yourdigitaldave
    Member
    Posted 1 year ago #

    What was the resolution to this issue, if there was one? I am attempting to launch my eCommerce site, but this "Sorry, it seems that there are no available shipping methods for your location (Canada). If you require assistance or wish to make alternate arrangements please contact us" issue is delaying going live.

    I have tried both the Canada Post plugin and Flat Rate options separately and I still get the same error (so it's likely not a Canada Post API issue). I've got both Canada and US chosen as shipping locations as well. Very, very strange (and frustrating...)

    Is there a cache that needs to be flushed somewhere?

    Any assistance would be greatly appreciated. Thanks!

  14. MrPerrel
    Member
    Posted 9 months ago #

    I was working on this for a long time and finally got it. I was using the development web services key, they email me the new keys for production besides a couple that are only on the completion page after your production key process. The NEW WEB SERVICES KEY is actually called the AUTHENTICATION KEY.

  15. CrowderHouse
    Member
    Posted 8 months ago #

    What is the fix on this? I am getting the same error message for Canada, and can't figure out where to change it. Frustrating.

  16. lotusms
    Member
    Posted 7 months ago #

    Not sure if you guys have found the solution yet but I found mine. Make sure your products have a weight. And to make it even more accurate, make sure you add the products dimensions.

  17. CrowderHouse
    Member
    Posted 7 months ago #

    No, I still can't get it to work. Have added weights, measurements. I don't have the Canada Post plug in, just using the basic WooCommerce setting.

  18. danwakeweb
    Member
    Posted 7 months ago #

    Ive had this problem too, I was trying to change from flat rate of 15 to free shipping.
    It works now after I enabled flat rate and changed the price to 0 and enabled free shipping too.
    Hope this helps.

  19. apolidor
    Member
    Posted 7 months ago #

    I'm having the same issue!! "Sorry, it seems that there are no available shipping methods for your location" Has anyone figured out what the heck is causing this? I have a product that I need to market,and I cannot do this if this feature does not work. Please help if you can. Thanks!

  20. Gary Eckstein
    Member
    Posted 7 months ago #

    I have the same problem "Sorry, it seems that there are no available shipping methods for your location".
    Using the Table Rate Shipping V2.
    Any assistance appreciated :)

  21. hillaryharris1635
    Member
    Posted 7 months ago #

    I am having the same problem with the "Sorry, it seems there are no available shipping methods..." message. It was working fine until a couple of days ago. I have tried all of the suggestions but this really seems like a WooCommerce bug and would be great if it could be acknowledged and dealt with. My client's site just went live last week and now this is happening... very frustrating and so many people seem to have the same problem. Please help!

  22. trevor67
    Member
    Posted 6 months ago #

    I'm posting this with the hope that it will help some of you who are suffering from this crazily frustrating situation. Here's how I made my problem go away:

    What I wanted configured for shipping was a $5 per item flat rate, with free shipping for purchases of $100+. I'd also set Flat Rate as my default shipping option, and yes, no matter what I kept getting that stupid error. That is, until I named the flat rate. It seems that until you actually define the flat rate with a name it won't acknowledge it, no matter if you've set up how many dollars per item or dollars per order the flat rate is going to be. On the Flat Rate page, underneath the checkbox to enable the Flat Rate, put some text in the box beside "Method Title". For instance, in a fit of creativity I named my flat rate "Flat Rate". And there it was--no more error. The name for your flat rate now shows up on the cart page and the checkout page with the shipping total beside it.

    Like I said, I hope this helps someone.

  23. inspiredwp2013
    Member
    Posted 5 months ago #

    same problem to me as well, 5 hours on trying.. and i have it SOLVED.
    hope will this will help.

    >>hover on products and click the shipping classes
    >>in shipping classes add new shipping classes. at least one
    >>click on products, edit product, under the product data
    click on shipping
    >>no need to specify weight or dimensions just click on shipping classes
    and select one

    FLAT RATE PAGE
    >>on flat rate page specify your country
    >>click on cost added dropdown and select "Per class - charge shipping for each shipping class in an order".
    >>under'cost' click on add cost and specify the amount fields on every class you made.

    THATS IT. hope it will solve some headaches

  24. Jason Judge
    Member
    Posted 4 months ago #

    @inspiredwp2013 Thanks! This helped me immensely. I just wanted a simple "free shipping" option and had always used "Free Shipping". Since the last release, that did not work. Then I tried "Flat Rate" with a zero cost - again the same "no shipping for your country".

    Then I added the "Free Shipping" class, gave it a zero cost in the Flat Rate Shipping page and linked it to the products. Bingo! That is what got it working.

    This bug has been around for a while, so I guess it is an edge-case that has slipped through the WooCommerce testing. My shop is enabled just for one country, so I don't know if that is something in common with others having this problem.

  25. Jason Judge
    Member
    Posted 4 months ago #

    This has now highlighted another bug with this release: I tested placing an order and went as far as the PayPal screen, but did not log in to PayPal. Instead I pushed the back button. Checking the orders, there is now an order listed for that test. That's pretty bad - it appears like an order has been taken, but no payment has been made. I'll need to raise this as a separate issue. I've certainly never seen this happen on previous versions to the one that the shipping country stopped working for :-/ This is the built-in PayPal payment method.

  26. inspiredwp2013
    Member
    Posted 3 months ago #

    @Jason Judge, Glad i had helped a little. Anyway i just started learning how to code 3 months ago. it's a lot of headache for me as a beginner. I started loving wordpress. i'm gonna marry her.

  27. soulstacks
    Member
    Posted 3 months ago #

    Having strange issues with the Royal Mail plugin which is also returning the following message

    "Sorry, it seems that there are no available shipping methods for your location (United States). If you require assistance or wish to make alternate arrangements please contact us"

    I sell 45s, 12 Inch singles and vinyl LPs. Bearing in mind all items have weights and dimensions as well as shipping classes it's bemusing how the 45s work fine but the LPs and 12s get rejected. It must be something ultra simple that I'm overlooking but every time I try to do a test order for a 12" going to the USA it comes up with that message. Assuming there's no need to set up different postage/shipping rules (because the Royal Mail plugin should just do that based on the weight, dimensions and location, right?) this must be a bug in the programme? A 12" record is classed as a small parcel by Royal Mail so maybe it can't deal with anything that isn't a letter or large letter. Frustrating!

  28. movllc
    Member
    Posted 2 months ago #

    ok I have a customer site that sells bullets, they weigh a ton. He wants to do flate rate box 11.30 and anything over 30lbs add another shipping of 11.30.

    HELP

  29. Mr Crom
    Member
    Posted 1 month ago #

    Greetings,
    although this may not work for some people and probably comes too late for others...

    RE: the error "Sorry, it seems that there are no available shipping methods for your location".

    For people using mail plugins (e.g. Australia Post /NZ/Canada Shipping Method plugin)

    I came across this problem some time ago.
    Try deselecting `envelope' - that might solve the problem. (It did for me)

    @movllc
    RE: if you have not solved the problem; perhaps this plugin would work WooCommerce E-Commerce Bundle Rate Shipping

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic