WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] No automatic subdirectory access (10 posts)

  1. msedminster
    Member
    Posted 5 years ago #

    I've searched the forums and I've seen similar things but nothing that addresses this problem. Please take a look at the following facts and let me know what you think.

      Initial Problems:

    • I have WP installed in a subdirectory with index.php in the root. This setup has worked great until recently.
    • I upgraded to 2.6 last week and it worked well with no hitches.
    • Dowloaded the new Elgg 1.0 and set it up in another subdirectory. Based on errors there and advice on the Elgg.org site, I upgraded my server to php5 and started having problems.
      Attempts/Mistakes?:

    • Tried to hand edit the .htaccess file to help the Elgg installation. This broke WP and didn't fix Elgg.
    • Thought the subdirectory rewrite for WP might be affecting Elgg's subdirectory as well and so manually went back to WP's index and .htaccess info in the subdirectory. This included file moves and database changes.
      At the moment:

    • I can pull up my blog front page in a text only version of the theme. The layout and content indicates that WP is drawing on my chosen theme (Amazing Grace) but there are no images. My debugger indicates /news/ (my subdirectory) is not included in php generated links. When I manually insert this in the link to the stylesheet, the page loads correctly.
    • Because of this same issue, I can't login to make any adjustments or corrections via the WP system. I can manually pull up the login page but clicking on the submit button fails to send me to root/news/wp-login.php and instead informs me that root/wp-login.php does not exist
    • Wp_options table has http://www.edminsters.com/news/ for both "home" and "site_url" rows.
    • Cache has been cleared/deleted.
    • Permissions have been set to 755.
    • .htaccess file in /news subdirectory reads:
      <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteBase /news/
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule . /index.php [L]
      </IfModule>

    Please help! Keep in mind, I'm looking for changes I can make manually since I don't have access to admin.php.

  2. msedminster
    Member
    Posted 5 years ago #

    By the way, my WP site is at http://www.edminsters.com/news.

  3. mrmist
    Forum Janitor
    Posted 5 years ago #

    Have you still got a .htaccess in your / directory?

  4. msedminster
    Member
    Posted 5 years ago #

    You mean in the root? If so, no. I do have a backup though in case I need the original one. The only addition to the standard wp rewrite info was selecting for php5.

  5. msedminster
    Member
    Posted 5 years ago #

    Wanna make sure this doesn't just slip away into the nether regions of wp forums like my other attempts have.

    I've tried to make the situation clear and to do enough research to avoid duplicating old requests. If I could get some help it would be very much appreciated.

  6. mrmist
    Forum Janitor
    Posted 5 years ago #

    Visiting your site's wp-login.php shows that it's redirecting to

    <input type="hidden" name="redirect_to" value="http://www.edminsters.com/wp-admin/" />

    Which means that the site_url must be defined as http://www.edminsters.com and not http://www.edminsters.com/news, 'cos that redirect is based upon the site_url option.

    You say you've got it set to yoursite/news in the database, but the evidence suggests not. You could try defining it in wp_config temporarily, I think that works.

  7. msedminster
    Member
    Posted 5 years ago #

    Is there any way that this old setting would be being "cached" in some way on my server?

    I just came out of MySQL and from everything I see there, the settings are as I've said they are. However, I'm seeing the same evidence you are on another site I'm running where a database change doesn't seem to have an immediate effect ... as if there is some kind of caching going on.

    I'll check the wp_config option you've suggested in a bit and get back.

  8. msedminster
    Member
    Posted 5 years ago #

    By the way, how would I do this in the wp-config file? I don't see a line here that could be edited.

  9. msedminster
    Member
    Posted 5 years ago #

    Based on the caching behavior, I had a sneaking suspicion this was a server error. I checked the DNS Name Servers and guess what? Yep, they hadn't yet been updated automatically as I understood they would be. I've made the appropriate changes but I need to wait a bit to see if this affects anything. I'll let you know what I find in a day or two.

  10. msedminster
    Member
    Posted 5 years ago #

    Nameserver updates were in fact the culprit. Thanks for your help in getting this sorted out.

Topic Closed

This topic has been closed to new replies.

About this Topic