WordPress.org

Ready to get started?Download WordPress

Forums

No admin panel after login (14 posts)

  1. Beeeater
    Member
    Posted 2 years ago #

    WordPress intalled just fine (gave me a Success message, I received my password by mail, but when I enter my details in the login screen, I simply am directed to a file listing of the WordPress folder headed "Index of /blog/wp-admin"
    I'm stuck, can't get further than this. What next?

  2. ChristiNi
    Member
    Posted 2 years ago #

    Hi Beeeater,

    Sounds like your WordPress site didn't install quite correctly. Do you see your WordPress site when you go to your domain name? Double check the folder where you installed WordPress and check your Site URL as well:

    http://codex.wordpress.org/Changing_The_Site_URL

    Feel free to provide a link to where you installed WordPress.

    Hope this helps!

  3. Beeeater
    Member
    Posted 2 years ago #

    Reading the installation instructions carefully, I realised that I had not placed the wordpress folder in the ROOT of my website, but in a subfolder - so i moved it to the root. Now when I log in I get this: The requested URL /blog/wp-login.php was not found on this server.

  4. ChristiNi
    Member
    Posted 2 years ago #

    Hi Beeeater,

    Did you update your Site URL after moving your files?

    http://codex.wordpress.org/Changing_The_Site_URL

    Thanks!

  5. ravimallya
    Member
    Posted 2 years ago #

    Please provide us with the URL of blog where you installed WordPress and the exact dashboard URL where you're receiving error. However, please try adding the following in the .htaccess file within the wp-admin directory:

    Options -Indexes
    DirectoryIndex index.php index.html index.htm

    Hope this will fix the problem.

  6. Beeeater
    Member
    Posted 2 years ago #

    I have tried to remedy the issue by the use of the define('RELOCATE',true); statement in the wp-login.php file. However I still just get a page with a directory listing after login. The page title is Index of /blog/wp-admin and the URL is http://www.synergies.co.za/blog/wp-admin/ -the WordPress files ARE located at this location. It is almost like instead of loading the correct page, it just gives a directory listing.

    I have noticed that if I click on the 'Back to blog' link on the login page, it takes me to http://blog.synergies.co.za/blog/, a different URL - Where is WordPress getting this URL from?

    This is becoming very frustrating. Surely there is a simple fix, or else a way to uninstall and start over?

  7. Beeeater
    Member
    Posted 2 years ago #

    Additionally, there is no .htaccess file within the wp-admin directory.

  8. Beeeater
    Member
    Posted 2 years ago #

    Also, when I use PHPMyAdmin the site URL is listed as http://www.synergies.co.za/blog which is the correct location.

  9. ChristiNi
    Member
    Posted 2 years ago #

    Hi Beeeater,

    It looks like something is not set up correctly on your server or at least in that directory. I see index.php files in both synergies.co.za/blog/ and synergies.co.za/blog/wp-admin/.

    Using either your hosts File Manager or an FTP program, double check for the .htaccess file. It's a hidden file, so you will need to make sure you have selected the option to view hidden files. If you do have an .htaccess file, open the file and see if you see any reference to DirectoryIndex (followed by a filename). If you do see that, and the file name after it is anything other than index.php, remove that line.

    It really looks like something is going on with that site URL. You should double check your wp-config.php file and functions.php to see if the site url has been changed in either of those files. Additionally, if you have set the site url correctly in the database:

    Also, when I use PHPMyAdmin the site URL is listed as http://www.synergies.co.za/blog which is the correct location.

    You do NOT need to use any of the other methods for changing the site URL. The Relocate Method is not needed so you will want to remove that. Have you confirmed that both the siteurl and home fields in your database are set to http://www.synergies.co.za/blog?

    Hope this helps!

  10. Beeeater
    Member
    Posted 2 years ago #

    Hi ChristiNi,

    This is really getting frustrating! I decided to start again from scratch - I dropped all the tables from the MySQL database, in fact I created a NEW database, deleted all the existing wordpress files from the 'blog' folder on my website, edited a brand new wp-config.php with all the new database values, uploaded the wordpress folder after renaming it 'wordpressblog', ran install.php successfully and then tried to log in. Guess what? Exactly the same issue! Now I get a directory listing titled 'Index of /wordpressblog/wp-admin' and the page URL is 'http://www.synergies.co.za/wordpressblog/wp-admin/'
    There is an .htaccess file in the root of my webserver, the contents of which look something like this:

    # -FrontPage-
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName synergies.co.za
    AuthUserFile /usr/www/users/synergv/_vti_pvt/service.pwd
    AuthGroupFile /usr/www/users/synergv/_vti_pvt/service.grp
    DirectoryIndex index.html

    I have a feeling this could be causing the problem, but I have no idea how to change it.

    Any ideas?

  11. ChristiNi
    Member
    Posted 2 years ago #

    Hi Beeeater,

    I suspect the issue is that last line:

    DirectoryIndex index.html

    .htaccess files are recursive, which means it can affect child subfolders. WordPress doesn't create .htaccess in it's folder until you add or change permalinks.

    To fix this, change that last line in that .htaccess file to:

    DirectoryIndex index.html index.php

    Let me know if that works!

  12. Avi Chitranshu
    Member
    Posted 1 year ago #

    when i login our admin panel ,it did not show anything and no any error message give.
    but my site working properly
    sir/madam ... please help me ...i am frustrated.

  13. wpadvices
    Member
    Posted 1 year ago #

    @avi123 First check the file permission of the folder wp-admin and if the issue still persist try by re-uploading the wordpress files...

  14. ThinkNCode.com
    Member
    Posted 1 year ago #

    format the root folder and then drop the tables, and then install fresh wordpress, it will definitely solve your problem.

    [sig moderated as per the Forum Rules. Also please do not use your username to try and promote your own commercial services. That is not tolerated on these forums.]

Topic Closed

This topic has been closed to new replies.

About this Topic