WordPress.org

Ready to get started?Download WordPress

Forums

No admin page! (11 posts)

  1. 4thelittleguy
    Member
    Posted 8 years ago #

    I have WordPress installed in the root directory of my site and an osCommerce store installed in the /store directory.

    The admin section for the store is found at /store/admin.

    Whenever I try to go to that page, I don’t get a log in to my store, all I get is my WordPress Themed 404 error page.

    One possible cause of the problem is that I recently upgraded the site from 1.5.2 to 2.0 and later from 2.0 to 2.0.1.

    Does anyone know how I can regain access to my admin page?

  2. GlennCoco
    Member
    Posted 8 years ago #

    Do you mean that you cannot access your osCommerce admin page, as in, when you try to go to your osCommerce admin page, you get a WordPress 404 error?

  3. 4thelittleguy
    Member
    Posted 8 years ago #

    That's exactly what happens.

  4. Is /store/admin/ a real directory? I mean, does it really exist or is it being created by the store software?

    WordPress 2.x assumes that any URL under it that doesn't belong to a real folder is meant for it.

    If this is the case, that /store/admin/ isn't a real directory, open up the .htaccess file that must exist in /store/ and copy the lines that create /admin/ and paste them here. We'll help you modify them so that they'll work and then you'll place those modified rules above the WordPress rules in your root .htaccess file.

  5. GlennCoco
    Member
    Posted 8 years ago #

    OK, I talked to him a bit and here is the deal.

    He has a store set up in the directory /store and the admin is in the directory /store/admin. They are really there, I checked on the server and they actually exist. One weird thing is that if you go to the store (www.4thelittleguy.com/store) it actually brings up the store, just like it is supposed to. Only if you go to the store admin page (www.4thelittleguy.com/store/admin) does it give you the WordPress 404. So for some reason WP thinks the store admin page belongs to it, but not the actual store.

  6. geoffe
    Member
    Posted 8 years ago #

    2 questions: what directory is WordPress installed in and what is found in .htaccess files?

  7. GlennCoco
    Member
    Posted 8 years ago #

    WordPress is installed in the root directory.

    WordPress .htaccess (found in root directory)

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    <Files 403.shtml>
    order allow,deny
    allow from all
    </Files>

    deny from 68.166.120.50

    osCommerce .htaccess (/store)

    # $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
    #
    # This is used with Apache WebServers
    #
    # For this to work, you must include the parameter 'Options' to
    # the AllowOverride configuration
    #
    # Example:
    #
    # <Directory "/usr/local/apache/htdocs">
    # AllowOverride Options
    # </Directory>
    #
    # 'All' with also work. (This configuration is in the
    # apache/conf/httpd.conf file)

    # The following makes adjustments to the SSL protocol for Internet
    # Explorer browsers

    <IfModule mod_setenvif.c>
    <IfDefine SSL>
    SetEnvIf User-Agent ".*MSIE.*"
    nokeepalive ssl-unclean-shutdown
    downgrade-1.0 force-response-1.0
    </IfDefine>
    </IfModule>

    # Fix certain PHP values
    # (commented out by default to prevent errors occuring on certain
    # servers)

    #<IfModule mod_php4.c>
    # php_value session.use_trans_sid 0
    # php_value register_globals 1
    #</IfModule>

    osCommerce admin .htaccess (/store/admin)

    # $Id: .htaccess,v 1.1 2003/06/20 00:18:30 hpdl Exp $
    #
    # This is used with Apache WebServers
    #
    # For this to work, you must include the parameter 'Options' to
    # the AllowOverride configuration
    #
    # Example:
    #
    # <Directory "/usr/local/apache/htdocs">
    # AllowOverride Options
    # </Directory>
    #
    # 'All' with also work. (This configuration is in the
    # apache/conf/httpd.conf file)

    # The following makes adjustments to the SSL protocol for Internet
    # Explorer browsers

    <IfModule mod_setenvif.c>
    <IfDefine SSL>
    SetEnvIf User-Agent ".*MSIE.*"
    nokeepalive ssl-unclean-shutdown
    downgrade-1.0 force-response-1.0
    </IfDefine>
    </IfModule>

    # Fix certain PHP values

    #<IfModule mod_php4.c>
    # php_value session.use_trans_sid 0
    # php_value register_globals 1
    #</IfModule>

    AuthType Basic

    AuthName "storeadmin"

    AuthUserFile "/home/thelittl/.htpasswds/store/admin/passwd"

    require valid-user

  8. CreationNation
    Member
    Posted 8 years ago #

    Was there ever any fix for this? I am experiencing this same exact problem. I can not access my OsCommerce admin directory, and my WordPress is installed in the root. Any help appreciated I am going nuts searching google/this site for a fix.

    EDIT: FYI I tried to add this RSS to my Thunderbird RSS reader and it says it is not a valid feed.

  9. ladydelaluna
    Member
    Posted 8 years ago #

    I actually had this happen just between two wordpress blogs... one in the root and one under a subdirectory... I'd be interested in how to solve this problem as well...

  10. CreationNation
    Member
    Posted 8 years ago #

    FYI to temporarily get around this I disabled having to use a user/pass (edit the .htaccess by adding # to the beginning of the line) to get into the admin (which is what is throwing WordPress off) - so I can get in, do what I have to do real quick, then reset it.

    I would love a proper fix though of course.

  11. omokage
    Member
    Posted 7 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic