WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] No admin access, wp-login.php cannot be downloaded (4 posts)

  1. amodoke
    Member
    Posted 8 months ago #

    Hi,
    Read ALL the threads on login problems, but none have the solution.

    Problem:
    1) New installation at > mediweightlossreviews.org

    2) If you go to /wp-admin or /wp-login.php, there's a "not found" error.

    3) No plugins installed yet, and there's NO htaccess file in root.

    4) Site url, home in database is same = mediweightlossreviews.org

    5) Though I can 'see' the wp-login.php through ftp, if I try downloading the wp-login.php, it gets redirected to some index.htm file. Try it yourself.

    6) Also, I tried replacing the wp-login.php file with a clean new file and renamed the old file as wp-login-old.php, now you can access the old file, but not the new one!! Try it > mediweightlossreviews.org/wp-login-old.php

    7) The permissions to the login file are 644

    So what's happening here?? Any help welcome please...
    Regards

  2. 2) If you go to /wp-admin or /wp-login.php, there's a "not found" error.

    Looks like something is intercepting all URL requests.

    This should always work.

    http://www.mediweightlossreviews.org/readme.html

    But it's getting redirected via a 301.

    5) Though I can 'see' the wp-login.php through ftp, if I try downloading the wp-login.php, it gets redirected to some index.htm file. Try it yourself.

    FTP would not work for any of us. Or more correctly: it better not! That would be a HUGE security breakdown.

    Speak with your host. Something is intercepting those requests and if it is not in your .htaccess file then it may be your host.

    Also try re-uploading all the WordPress files. No exceptions.

  3. amodoke
    Member
    Posted 8 months ago #

    FTP would not work for any of us. Or more correctly: it better not!

    What I meant for you guys was to try and download wp-login.php

    You are spot on about the readme file getting redirected. I opened a ticket with the host, will give them 24 hours before starting from scratch.

    Will update accordingly.

  4. amodoke
    Member
    Posted 8 months ago #

    Problem solved.

    Issue was my root domain's htaccess made the addon domains go bonkers.

    For anyone still banging their heads, check the htaccess of your original domain on the ip or contact your host.

Reply

You must log in to post.

About this Topic