WordPress.org

Ready to get started?Download WordPress

Forums

124

WooCommerce - excelling eCommerce
[resolved] No Add to Cart Button on Variable Products (117 posts)

  1. berrytanglefarm
    Member
    Posted 8 months ago #

    http://www.berrytanglefarm.com/product/juvenile-trio

    Some customers are not seeing the Add to Cart button on variable products.

    I see it in Safari, Firefox, and Chrome (can't check IE).

    Some background on this thread -- http://wordpress.org/support/topic/variable-product-add-to-cart-button?replies=9

    Once I removed the radio button plugin, the error on Firebug resolved, but customers still can't see the button.

    All plugins and themes are up-to-date. It happens with Twenty Ten & Twenty Twelve themes.

    No idea where to go from here. I'm not a code person, but I really need to fix this!

    http://wordpress.org/plugins/woocommerce/

  2. Andrew
    Forum Moderator
    Posted 8 months ago #

    Can you deactivate all other plugins and then let us know when you have?

  3. berrytanglefarm
    Member
    Posted 8 months ago #

    All off except Woocommerce.

    I can still see the button like I always can.

    Can anyone else?

  4. Andrew
    Forum Moderator
    Posted 8 months ago #

    There was another issue with a plugin, but we'll get to that later.

    There is a permission issue with everything in WooCommerce's "assets" folder, for example try accessing this file:
    http://www.berrytanglefarm.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart-variation.js?ver=1.0 - It says, "403 Permission Denied".

    In particular WooCommerce cannot access its JS files that it uses to operate the add-to-cart functionality.

    Talk to your hosting providers about this permission issue.

  5. berrytanglefarm
    Member
    Posted 8 months ago #

    I'll talk to Bluehost about it.

    I don't even know where that folder is and what it means :/

    What about another plugin issue? Is there any way to know which one it is? Should I turn them back on now? Doing it one-by-one doesn't really help because I can always see the button and have no way of knowing what plugin is the problem.

    Why can I see it and others can't?

  6. Andrew
    Forum Moderator
    Posted 8 months ago #

    You can turn all your plugins back on.

    When your hosts resolve the permission issue you can try deactivating all plugins and your issues should disappear - Then you have a starting point for narrowing down the problem plugin. You can activate them one-by-one until the issue reoccurs.

    Btw you can link your hosts to this forum thread if you need help explaining what's wrong.

  7. berrytanglefarm
    Member
    Posted 8 months ago #

    I'll do that, thanks.

    It would help if I could recreate the problem for myself and see what's happening, but my browsers all show the add to cart button while customers report they're not there and even send me screen shots without it.

    How can i recreate the problem for myself?

  8. Andrew
    Forum Moderator
    Posted 8 months ago #

    Clear your browser's cache to check if you're looking at an old version of the site.

  9. berrytanglefarm
    Member
    Posted 8 months ago #

    Done. Still works for me in all browsers.

    So strange!

  10. Andrew
    Forum Moderator
    Posted 8 months ago #

    Your hosting providers might have more insight on this.

  11. berrytanglefarm
    Member
    Posted 8 months ago #

    On hold for them now.

    I'll post when I get some feedback from them.

    Thank you.

  12. berrytanglefarm
    Member
    Posted 8 months ago #

    When I click on that file that you said returns a 403 error, I don't get an error, I get a lot of code.

    I wonder why?

    Talking to Blue host now.

  13. berrytanglefarm
    Member
    Posted 8 months ago #

    Bluehost says it's not a permission issue.

  14. Andrew
    Forum Moderator
    Posted 8 months ago #

    Did they detect that there is an issue there?

  15. Andrew
    Forum Moderator
    Posted 8 months ago #

    If you haven't already it would be worth addressing to them that YOU can access the files and everyone else can't: http://snag.gy/YIVQ6.jpg

  16. berrytanglefarm
    Member
    Posted 8 months ago #

    No permission issue detected. There was an error, but it wasn't related.

  17. berrytanglefarm
    Member
    Posted 8 months ago #

    I can sometimes recreate the problem if I sign off our wifi on the iPhone, but the problem resolves when I sign back onto our wifi.

  18. berrytanglefarm
    Member
    Posted 8 months ago #

    They can't figure out why I can see it on the wifi and no one else can. At least they can recreate the problem.

  19. berrytanglefarm
    Member
    Posted 8 months ago #

    STILL no solution.

    Woocommerce System Status says the memory is 40MB, but I've already checked and it's 128MB.

    I wonder if this is related at all?

  20. Andrew
    Forum Moderator
    Posted 8 months ago #

    Are your hosting providers working on the issue?

  21. berrytanglefarm
    Member
    Posted 8 months ago #

    Bluehost has given up. They can't pinpoint the problem.

  22. berrytanglefarm
    Member
    Posted 8 months ago #

    Can't get Woocommerce's attention.

    The only other thing I can think of is to complete delete Woocommerce and start over.

    But I don't know if that will even work, and it will be a BIG undertaking. Not to mention the fact that I won't even know if it works or not since I can see the button from my end!

  23. Andrew
    Forum Moderator
    Posted 8 months ago #

    It may be worth considering to hire someone about this:
    - http://jobs.wordpress.net
    - http://directory.codepoet.com

  24. berrytanglefarm
    Member
    Posted 8 months ago #

    Before or after I scrub Woocommerce and start again?

  25. Andrew
    Forum Moderator
    Posted 8 months ago #

    Before if as you say it will be a big undertaking, or after if the issue persists.

  26. berrytanglefarm
    Member
    Posted 8 months ago #

    I'm willing to try it if it would work. But if I delete Woocommerce, would it really scrub everything or would I need to delete something else?

    I can get the paid add-ons back, but I'm not sure how to completely scrub it.

  27. berrytanglefarm
    Member
    Posted 8 months ago #

    By the way, I've downgraded to an earlier version of Woocommerce. Are you still seeing the problem?

  28. berrytanglefarm
    Member
    Posted 8 months ago #

    Well, that downgrade has just completely erased the site ??????????

    Even I can't access it now. None of it.

  29. Andrew
    Forum Moderator
    Posted 8 months ago #

    Yes and I've cleared my cache - btw earlier versions are not safe, since then WooCommerce continually add security fixes.

  30. berrytanglefarm
    Member
    Posted 8 months ago #

    So how do I get back into the site to fix it??

    I can't pull ANYTHING up.

124

Reply »

You must log in to post.

About this Plugin

About this Topic