WordPress.org

Ready to get started?Download WordPress

Forums

No access to wp-admin (26 posts)

  1. clovec
    Member
    Posted 1 year ago #

    Hi!

    I have a website using woocommerce + some other plugins, today when I was cleaning up from plugins that I don't use, I lost access to the admin dashboard. I have checked the database and user level is 10 and everything looks allright, I have disable all my plugins, tried to change theme, and so on. This guide is the one that I followed http://codex.wordpress.org/Login_Trouble.

    Do you guys have any other hint that I can try?

  2. clovec
    Member
    Posted 1 year ago #

    I have copyed the database and inserted it to a local server with some old files, it did not work, so I think the problem lies somewhere in the database, some pointers perhaps?

  3. esmi
    Forum Moderator
    Posted 1 year ago #

    Using Phpmyadmin (or another MySQL management tool), first backup your database. Then navigate to your wp_usermeta table and locate the meta_key called "wp_capabilities" for your user_id. Change the meta-value for this record to:

    a:1:{s:13:"administrator";b:1;}

  4. clovec
    Member
    Posted 1 year ago #

    Thanks for the reply but that didn't fix it im afraid

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    What was the value in that field?

  6. clovec
    Member
    Posted 1 year ago #

    a:1:{s:13:"administrator";s:1:"1";}

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:
    - switching to the Twenty Eleven theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  8. clovec
    Member
    Posted 1 year ago #

    Hey,

    when I switch to default theme the screen turns white and no luck accessing dashboard.

    Resetting the plugins folder, same there no luck.

    And did the re-uploading and went trhough the installation proccess but still no access? Strange any more ideas :)

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    No one suggested that you go through any installation process. In fact, WordPress should have stopped you re-installing and wiping out your database. Re-upload a fresh, unpacked, copy of the Twenty Eleven folder to wp-content/themes using FTP or whatever file management application your host provides.
    http://wordpress.org/extend/themes/twentyeleven

  10. clovec
    Member
    Posted 1 year ago #

    When I uploaded all files wordpress wanted me to config the wp-config file and to upgrade the database so I did that, the database stood all intact, no damage done there.

    I have deleted and uploaded a fresh copy of twenty eleven but the page is still white. and still no access

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    and to upgrade the database

    So you obviously were not using WordPress 3.4.2 previously. Do you have a recent database backup?

  12. clovec
    Member
    Posted 1 year ago #

    Do I need to change template and stylesheet in wp_options for twentyeleven to work`?

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    No. You just need to rename your old theme as I suggested above. The default theme will then automatically activate.

  14. clovec
    Member
    Posted 1 year ago #

    I think I choose the wrong zip, I think a uploaded 3.4.1_Sv instead of 3.4.2, will try to do that again, I am sure that I have upgraded wordpress in the dashboard earlier

  15. clovec
    Member
    Posted 1 year ago #

    I uploaded a fresh copy of 3.4.2 now in english but still no access so I don't know what to do else

  16. clovec
    Member
    Posted 1 year ago #

    No. You just need to rename your old theme as I suggested above. The default theme will then automatically activate.

    Ok but the startpage is still just white when I deactivated my main theme

  17. esmi
    Forum Moderator
    Posted 1 year ago #

    Check your site's error logs. If you do not know where these are, ask your hosts for assistance.

  18. clovec
    Member
    Posted 1 year ago #

    have no errors in the logs that could have something with this issue, just some css files when I changed my theme. No error in php error log

  19. clovec
    Member
    Posted 1 year ago #

    I really appreciate that you are trying to help me, very much getting frustrated at this

  20. clovec
    Member
    Posted 1 year ago #

    I will ask the host if they have a backup of the database the problem lies there, found a old sql file which I tried with and it worked, but the question is how could this happen?

  21. esmi
    Forum Moderator
    Posted 1 year ago #

    It sounds like the database was damaged but there are 1001 reason as to why this could have happened. Try asking your hosts if they have had any issues at their end

  22. clovec
    Member
    Posted 1 year ago #

    Don't think they have i think something went wrong when i deactivated some plugins, either way i think the problem lies in wp_options table, when I import that table from my "live" site to my test site on my own computer with the old database it stop working

  23. clovec
    Member
    Posted 1 year ago #

    One more question about that, how important are all of the entries in wp_options are they all necessary?

  24. mjerome9
    Member
    Posted 1 year ago #

  25. esmi
    Forum Moderator
    Posted 1 year ago #

    are they all necessary?

    Yes - they are.

  26. esmi
    Forum Moderator
    Posted 1 year ago #

    @mjerome9: It is impolite to interrupt another poster's ongoing thread with a question of your own and it causes significant problems for the forum's volunteers. Please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Topic