WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
No access to site Admin page after troubledshooting 404 Error (4 posts)

  1. mnm82
    Member
    Posted 10 months ago #

    I have a question that I can't seem to find (or understand) the answer to :( I installed WordPress SEO by YOAST and had trouble with Google reading the Sitemap and received a "General HTTP error: 404 not found. I tried to fix this by following this online tutorial

    (http://www.wpbeginner.com/wp-tu...¬)
    that suggest inserting the following code to fix the issue:

    # WordPress SEO - XML Sitemap Rewrite Fix
    2
    <IfModule mod_rewrite.c>
    3
    RewriteEngine On
    4
    RewriteBase /
    5
    RewriteRule ^sitemap_index\.xml$ /index.php?sitemap=1 [L]
    6
    RewriteRule ^([^/]+?)-sitemap([0-9]+)?\.xml$ /index.php?sitemap=$1&sitemap_¬n=$2 [L]
    7
    </IfModule>
    8
    # END WordPress SEO - XML Sitemap Rewrite Fix

    AFTER doing so I am now completely locked out my account with this messege:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@artattackfx.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at artattackfx.com Port 80

    Can anyone please help or guide me in the right direction?

    Thank You!

    http://wordpress.org/plugins/wordpress-seo/

  2. jrf
    Member
    Posted 10 months ago #

    Remove the code from your .htaccess file and you should be able to log in again.

    Oh.. and if what you pasted is literally what's in your .htaccess file, the problem is the numbers being there - which makes that the server doesn't understand your rules.

    Try this instead:

    # WordPress SEO - XML Sitemap Rewrite Fix
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^sitemap_index\.xml$ /index.php?sitemap=1 [L]
    RewriteRule ^([^/]+?)-sitemap([0-9]+)?\.xml$ /index.php?sitemap=$1&sitemap_¬n=$2 [L]
    </IfModule>
    # END WordPress SEO - XML Sitemap Rewrite Fix
  3. mnm82
    Member
    Posted 10 months ago #

    Thank you so much for your reply. I got the issue resolved and the solution was what you mentioned above with the numbers.

  4. jrf
    Member
    Posted 10 months ago #

    Glad to be of help. Please mark this topic as resolved.

Reply

You must log in to post.

About this Plugin

About this Topic