WordPress.org

Ready to get started?Download WordPress

Forums

No access to admin after theme update (20 posts)

  1. OscarAndCie
    Member
    Posted 1 year ago #

    I have updated the theme this morning, and since the admin page is not accessible. I need to know if I can fix this without removing the actual theme from the FTP. I can't have the site showing the wrong theme, even for few minutes.

    I already clean extra space at the end of function.php and wp-config.php has suggested in post about similar issue.

    Thanks for your help.

  2. wprock
    Member
    Posted 1 year ago #

    site url?

  3. OscarAndCie
    Member
    Posted 1 year ago #

  4. wprock
    Member
    Posted 1 year ago #

    ok... Login via FTP and you will get a error log file. Download the file in your local machine and open it on any editor. See the latest error from there and try to resolve that error.

    May be you will use the WP 3.5.1 (if you are using older version)

  5. Rajesh Soni
    Member
    Posted 1 year ago #

    Try temporarily renaming wp-content/plugins, then try to login.

  6. OscarAndCie
    Member
    Posted 1 year ago #

    @wprock
    I did look for an error_log file both in _root and wp-includes. Nothing found.

  7. OscarAndCie
    Member
    Posted 1 year ago #

    @Rajesh.
    What are the risk? If I rename the plugins folder, and put back the original name. It's 100% sure everything will be running normal? Or it's a risk to create more issue?

  8. Rajesh Soni
    Member
    Posted 1 year ago #

    No risk involved. As long as you do not visit yoursite.com/wp-admin/plugins.php (while the plugins folder is renamed to something else).

    In which case, all your plugins would get de-activated (as they'd be found missing).

    To troubleshoot your issue, just rename plugins to something else, and see if you can access the admin dashboard. Once you can access dashboard, quickly rename the plugins folder back.

  9. Krishna
    Volunteer Moderator
    Posted 1 year ago #

  10. Rajesh Soni
    Member
    Posted 1 year ago #

    I notice that you're using http://www.drivebranding.com/ as well as http://drivebranding.com/ ... Please make the URLs consistent.

  11. OscarAndCie
    Member
    Posted 1 year ago #

    this is an issue partially cause by the theme update.
    once the theme was change, we notice that the website wasn't accessible anymore with the 'www'. Since it wasn't possible to see why via the admin, I was left with no choice to add this:

    define('WP_HOME','drivebranding.com');
    define('WP_SITEURL','drivebranding.com');

    in the wp-config.php, the solution is not perfect, because it create issue with the menu, but until I have access again to the admin it my best option.

  12. OscarAndCie
    Member
    Posted 1 year ago #

    @wprock
    I downloaded the complete website, and found no error_log file.
    I will try the others option now, and keep you posted.

  13. wprock
    Member
    Posted 1 year ago #

    may be theme's functions.php file is creating problem. Please rename the files like functions.php.bkp and try to check wp-admin URL once. If it work then you will check the functions.php file.

  14. OscarAndCie
    Member
    Posted 1 year ago #

    Ok, I renamed the plugins folder, and the login still not work.

    Plus once the plugins folder is renamed, I got on the login page and the website several error message.

    So, I suppose that left me only with the option of removing the actual theme from the FTP? It's possible to make my previous theme to be selected as default, instead of the TwentyTwelve ? Keeping only my previous template will do the trick?

    Thanks.

  15. Rajesh Soni
    Member
    Posted 1 year ago #

    You do NOT have to remove / delete the theme folder. Just rename the theme folder / directory to something else and that wordpress would fallback to the default theme.

  16. wprock
    Member
    Posted 1 year ago #

    Enable the error log. Put the code in wp_config.php file

    @ini_set('log_errors','Off');
    @ini_set('display_errors','On');
    @ini_set('error_reporting', E_ALL );
    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', false);
    define('WP_DEBUG_DISPLAY', true);

  17. wprock
    Member
    Posted 1 year ago #

    Sorry! use this

    @ini_set('log_errors','On');
    @ini_set('display_errors','Off');
    @ini_set('error_log','/home/example.com/logs/php_error.log');

  18. wprock
    Member
    Posted 1 year ago #

  19. OscarAndCie
    Member
    Posted 1 year ago #

    [Problem Solved]

    I was able to connect to my admin by doing either :

    renaming the function.php in my actual theme
    or
    renaming the plugins folder

    But this was not fixing my problems, thanks to you Rajesh and Wprock, and with reading of others forum post, I realised that some comments I put in php files might creating the issue.

    I added comment in beginning of the .php files such <!-- test.php -->
    This was not an issue in development, and was in place for several days prior of the launch. But, removing all of them, and now I can connect to my admin again.

    Thanks again!

  20. Rajesh Soni
    Member
    Posted 1 year ago #

    Sounds great! Glad you got it figured out.

    Cheers!

Topic Closed

This topic has been closed to new replies.

About this Topic