WordPress.org

Ready to get started?Download WordPress

Forums

Transposh WordPress Translation
[resolved] No 404 when not using a language (2 posts)

  1. tarkin79
    Member
    Posted 1 year ago #

    When I activate and then de-activate a language, transposh continues to serve the deactivated pages for that language with a standard 200, but not translated. This is leading to lots of duplicate content. Please set it so that any non-selected languages return a 404 when trying to access them.

    http://wordpress.org/extend/plugins/transposh-translation-filter-for-wordpress/

  2. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    This plugin is not about SEO but rather about offering better experience to your end users, so things such as your request are out of the scope of what we do.

    I really don't see the why you will need to disable a language previously enabled, and remember that there are canonicals that you can use and the rel alternates are served.

    You can add the rules in your .htaccess to return a 404 when a specific url matches.

    Good luck

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags