WordPress.org

Ready to get started?Download WordPress

Forums

Nicer archives for 1.5; Statistics for 1.5 (33 posts)

  1. Despach0
    Member
    Posted 9 years ago #

    where can i get this?!

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Where have you looked ??

    Remember, this is BETA software.
    BETA = not finished, not complete.

  3. Despach0
    Member
    Posted 9 years ago #

    i know what beta means but there can be nicer archives FOR beta 1.5. lokked everywhere, couldn't find so i came here

  4. John
    Member
    Posted 9 years ago #

    http://blog.noontide.ca/?p=9

    I'm using it with 1.5 (I wrote it as well :P so any problems bitch at me about them)

  5. XeroCool
    Member
    Posted 9 years ago #

    K. I'll be the 1st one to bitch.

    Error when installing:

    Fatal error: Cannot instantiate non-existent class: stats in /home/xerocool/domains/r0x0rz.info/public_html/wp-advanced-stats-install.php on line 5

    The style doesn't show. Only the navigation bar from my header so....

  6. John
    Member
    Posted 9 years ago #

    Have you activate the plugin before you tried to install?

  7. XeroCool
    Member
    Posted 9 years ago #

    tried both. don't work.

  8. John
    Member
    Posted 9 years ago #

    Copy it over with this one (http://blog.noontide.ca/files/wp-advanced-stats-install.phps) it's got the class hardcoded in. Your on a linux host right?

  9. Despach0
    Member
    Posted 9 years ago #

    doesn't work for me too...

  10. John
    Member
    Posted 9 years ago #

    The install file?

  11. Despach0
    Member
    Posted 9 years ago #

    P.s. it shows Fatal error: Cannot instantiate non-existent class: stats in /usr/data/wwwroot_com/archijs.ema.lv/html/wp-advanced-stats-install.php on line 6

  12. Despach0
    Member
    Posted 9 years ago #

    or something like this too:

    Warning: main(wp-content\plugins\stats\class\Stats.php): failed to open stream: No such file or directory in /usr/data/wwwroot_com/archijs.ema.lv/html/wp-advanced-stats-install.php on line 4

    Fatal error: main(): Failed opening required 'wp-content\plugins\stats\class\Stats.php' (include_path='.:/usr/local/lib/php:/usr/local/share/pear') in /usr/data/wwwroot_com/archijs.ema.lv/html/wp-advanced-stats-install.php on line 4

  13. John
    Member
    Posted 9 years ago #

    If either you is up to it it's just making a table where table is your prefix + stats (For example "wp_stats"). I'm going to try and fix it right now though if you not so give me a moment.
    CREATE TABLE ".Table." (id int(11) unsigned NOT NULL auto_increment,username varchar(100) NOT NULL default '',ip varchar(15) NOT NULL default '127.0.0.1',time datetime NOT NULL default '0000-00-00 00:00:00',referrer varchar(255) default NULL,keyword varchar(255) default NULL,location varchar(100) NOT NULL default '',url varchar(100) NOT NULL default '',page int(11) unsigned NOT NULL default '0',version double default '0',browser varchar(255) NOT NULL default '',referrercomplete text NOT NULL,OS varchar(255) NOT NULL default 'Unknown',PRIMARY KEY (id)) TYPE=MyISAM;";

  14. Despach0
    Member
    Posted 9 years ago #

    ok, ill wait for you ;)

  15. John
    Member
    Posted 9 years ago #

    Thanks for the error message. I had some of my slashes the wrong way. Works in windows but not in unix. This one should now work http://blog.noontide.ca/files/wp-advanced-stats%20(Unix%20Safe).zip

  16. Despach0
    Member
    Posted 9 years ago #

    file not found on server ;)
    change the link for others, but i works for me, found it myself....
    but still.. Fatal error: Call to undefined function: error() in /usr/data/wwwroot_com/archijs.ema.lv/html/wp-advanced-stats-install.php on line 8

  17. John
    Member
    Posted 9 years ago #

    <?php
    /* Don't remove this lines. */
    require('./wp-blog-header.php');
    require_once("wp-content/plugins/stats/class/Stats.php");
    get_header();
    $Stats = new Stats();
    $Stats->install();
    ?>
    <?php get_sidebar(); ?>

    <?php get_footer(); ?>

    Try that for install, or try new link http://blog.noontide.ca/files/wp-advanced-stats.zip lol this is not my day. Sorry about it being so hard to install.

  18. Despach0
    Member
    Posted 9 years ago #

    WordPress database error: [Table 'Table' already exists]
    CREATE TABLE Table (id int(11) unsigned NOT NULL auto_increment,username varchar(100) NOT NULL default '',ip varchar(15) NOT NULL default '127.0.0.1',time datetime NOT NULL default '0000-00-00 00:00:00',referrer varchar(255) default NULL,keyword varchar(255) default NULL,location varchar(100) NOT NULL default '',url varchar(100) NOT NULL default '',page int(11) unsigned NOT NULL default '0',version double default '0',browser varchar(255) NOT NULL default '',referrercomplete text NOT NULL,OS varchar(255) NOT NULL default 'Unknown',PRIMARY KEY (id)) TYPE=MyISAM;

  19. John
    Member
    Posted 9 years ago #

    You have it activated when you try and install?

  20. Despach0
    Member
    Posted 9 years ago #

    tried both ways...

  21. XeroCool
    Member
    Posted 9 years ago #

    I recommend you re-do this whole thing. I ran the installation but my layout was still missing and It didnt say If It installed sucessfully or not and when I put in the php code to my sidebar, I still get this:

    Warning: record(stats\class\Stats.php): failed to open stream: No such file or directory in /home/xerocool/domains/r0x0rz.info/public_html/wp-content/plugins/wp-advanced-stats.php on line 52

    Fatal error: record(): Failed opening required 'stats\class\Stats.php' (include_path='.:/usr/local/lib/php') in /home/xerocool/domains/r0x0rz.info/public_html/wp-content/plugins/wp-advanced-stats.php on line 52

  22. John
    Member
    Posted 9 years ago #

    Copy the error from when it's activatied

  23. XeroCool
    Member
    Posted 9 years ago #

    Hmm, Still wondering what the problem is.

    ja2000, there is no error when activating it. The error is shown when the plugin is activated and the code is in my sidebar..

  24. John
    Member
    Posted 9 years ago #

    Did you download the new copy? I have that problem fixed. I had my slashes the wrong way.

  25. John
    Member
    Posted 9 years ago #

    or if you want to do it yourself open the wp-advanced-stats in your plugin folder and change all the \ in the require or includes to / specifically in the record function

  26. XeroCool
    Member
    Posted 9 years ago #

    <<removed>..

    1 sec. Think I got it.

  27. XeroCool
    Member
    Posted 9 years ago #

    Blah, <?php record();?> isnt showing nothing and the plugin is activated..

    So I tried <?php userOnline(); ?> and It says:

    WordPress database error: [Table 'xerocool_home.stats' doesn't exist]
    SELECT count(DISTINCT ip) FROM stats WHERE time > Now() - INTERVAL 300 SECOND

    I ran the install but the layout is still empty but says the table is already created

  28. John
    Member
    Posted 9 years ago #

    Got an instant message service? I think from looking at your server you have it properly install. MSN: J2000_ca@hotmail.com AIM: DarkPaldin23

  29. Despach0
    Member
    Posted 9 years ago #

    having the same problem as XeroCool

  30. XeroCool
    Member
    Posted 9 years ago #

    Added

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.