WordPress.org

Ready to get started?Download WordPress

Forums

Nice permalinks not working (25 posts)

  1. jonthejester
    Member
    Posted 9 years ago #

    Hey.
    I'm trying to get nice permalinks, like /archives/jon/my-love-article working for 1.3, but for some reason it's not outputting htaccess rules like it should. I'm right now using the structure /index.php/archives/%author%/%postname%/, but it'd be nice to do just /archives/%author%/%postname%/ with htaccess.
    The htaccess rules have been outputted for nice permalinks for 1.2, in the past.
    Any idea why that's happening?

  2. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

    1.3 doesn't display the rules if your .htaccess is writable. Instead, it writes them for you.

  3. jonthejester
    Member
    Posted 9 years ago #

    Tried to make a new, empty file, named it .htaccess. Set it to read/write/execute for all/world. The directory is also 777 (same as file). Apparently that didn't work. It should work, but I don't know why it's not doing it.

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Did you set no permalinks, then upload and chmod the .htacess, then set the permalinks ? (Sort of undo then redo ?)

  5. Joshua Sigar
    Member
    Posted 9 years ago #

    I thought WP will automatically create .htaccess if does not exist? I'm not sure as I wasn't paying attention. But I remember that I put WP in a new folder so .htaccess was not there before. So I went to permalink page to set it up and I got nothing to copy-paste. Hmm? I went to manage my files, click on .htaccess link and HOLY CRAP!? This is TOO good to be true. So am I wrong or right that WP will create .htaccess if it does not exist already?
    I know I could always look up the code, but, yeah...?

  6. Beel
    Member
    Posted 9 years ago #

    1.3a will create the file if it can write to the directory.

  7. jonthejester
    Member
    Posted 9 years ago #

    Neither suggestion worked, oddly... Why me, why now?
    It could also be I need to upgrade my CVS version to the more recent revisions. I'll post back if there's anything on that.

  8. jonthejester
    Member
    Posted 9 years ago #

    Yeah, updated to the more recent CVS version last night, and oddly that didn't work also. If the thing's working for everyone else (there must be something wrong with me or my server then), is there like a debug mode or something so I can diagnose what's not kicking? This is such a weird phantom problem... Death to phantoms...
    And yeah, so far I'm sticking with /index.php/* until I have a solution. Otherwise WP is working out well, for the most part.

  9. jonthejester
    Member
    Posted 9 years ago #

    Btw, does anyone know where the file-writing code is, like which file it's in? I'm curious to see how it works for .htaccess.

  10. jonthejester
    Member
    Posted 9 years ago #

    Just to make sure, is anyone else having this problem or is this a remote case and my server could have a random bug?
    Btw, I'm going to test WP 1.3 on my comp (it's apache2+mysql+linux), and I'm going to move to a new host. I guess this means I have a remote case, darn it... :-\

  11. davincim
    Member
    Posted 9 years ago #

    Interesting...I never had a .htaccess file in my blog directory before. Sounds like I should though. However, I'm a little unclear as to how to create one.

    Earlier it was mentioned to create an empty file, call it .htaccess, and chmod it (to what? 777?). So in the codex it says, "If you leave whitespace at the end of your .htaccess file...". So it's not going to freak out about an empty file, I take it.

    And do I understand correctly that once that is created and properly placed in my blog directory, I am to go to the Options > Permalinks and copy-paste from the choices listed there? And that's it? Does it work for previous posts as well or just the ones going forward?

    Thanks for your patience with my many questions. :)

  12. NuclearMoose
    Member
    Posted 9 years ago #

    davincim,
    See this post regarding creating an .htacess file with 1.5:
    http://wordpress.org/support/topic.php?id=24336#post-137428

  13. davincim
    Member
    Posted 9 years ago #

    Does it work the same for WP v1.2.2, which I'm using? It doesn't specify versions in the post you refer to.

  14. NuclearMoose
    Member
    Posted 9 years ago #

    Sorry, it doesn't work the same in 1.2.2. You can create a text file, and call it whatever you like, say htaccess.txt and then copy/paste the rewrite rules into it. Then, upload that file to your WP directory, and then change the name to .htaccess. Note that some FTP programs will not show .htaccess files because they are "hidden." You may have to get on to your server itself via cPanel or equivalent and rename the file there.

  15. LumperDawgz
    Member
    Posted 9 years ago #

    NuclearMoose

    Thanks very much for the information! I just got my RSS, Comments, etc. working as intended.

    Jim
    Portland, Oregon

    "When the going gets weird the weird turn pro" - Hunter S. Thompson

  16. davincim
    Member
    Posted 9 years ago #

    Okay, I followed your instructions, but now I'm getting the following error:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at familywebwatch.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    I chmod it to 777 and cleared my browser's cache to be sure I was viewing the newest stuff.

    Suggestions?

  17. "More information about this error may be available in the server error log."

    We need to know what that "more information" is. A 500 error is a generic error which should be read as, "Check your server error log."

  18. davincim
    Member
    Posted 9 years ago #

    macmanx, I went to my hosts control panel to find out more information. Either the error message I got was misleading or I'm looking in the wrong place.

    I went to the Error Pages section of my control panel and I could only add an error to a document. The status said it was "OK".

    I can ftp to my logs, but honestly, I've never tried downloading and reading them. What do I need to do that?

    Sorry for being so vague. Have I hit a dead end?

  19. davincim
    Member
    Posted 9 years ago #

    I managed to create the .htaccess file, but now when I click on a permalink I get this error:

    The requested URL /blog_test/archives/2005/02/17/another-test/ was not found on this server.

    Do I need to change the permissions or something? Right now it's set to 644.

  20. davincim
    Member
    Posted 9 years ago #

    bump

  21. davincim
    Member
    Posted 9 years ago #

    bump bump bump bump bump....

    ...bump bump ;-)

  22. wrichter
    Member
    Posted 9 years ago #

    I have the exact same problem as davincim. I have a correct .htaccess in my server's root directory. I have changed the httpd.conf <Directory /> to allow all overrides and other options as suggested in other forum posts. NOTHING works. :( Any ideas? Mod_rewrite is definitely installed...

  23. wrichter
    Member
    Posted 9 years ago #

    PROBLEM SOLVED: This should definitely go into documentation, as this problem really got me pissed off for a few hours...

    OK, davincim I think this should solve your problem as well (we seem to have the exact same problem).

    Here is what needs to be changed in my (default Debian) httpd.conf:

    • Do a search for htaccess, hopefully you will find the same lines I found

      #
      # This controls which options the .htaccess files in directories can
      # override. Can also be "All", or any combination of "Options", "FileInfo",
      # "AuthConfig", and "Limit"
      #

    • Right under that comment, is a line that reads:

      AllowOverride None

    • Change that line to:

      AllowOverride Options FileInfo

      • Apparently, where I was placing the <Directory /> settings I found in other posts was being ignored because later in the configuration file (httpd.conf) there was another <Directory /var/www>.

  24. Elliott
    Member
    Posted 8 years ago #

    Is any of this working for anyone? I've tried it all and I get nothing.

    Just can't get the .htaccess file to populate no matter what I try.

  25. First, make sure that you are running the latest version of WordPress (currently v1.5.2). Then, if you are still having problems, follow the instructions here: http://codex.wordpress.org/Using_Permalinks#Fixing_.28.htaccess.29_Generation_Issues

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.