WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[resolved] Nginx Ban User Parameter doesn't work (4 posts)

  1. siprof
    Member
    Posted 3 months ago #

    for example I want to block these IP's: 111.111.111.4 ~ 111.111.111.9
    So I put on the form 111.111.111.*
    which is translated into Nginx rules: 111.111.111.[0-9]+;

    unfortunately Nginx won't accept that: ...[emerg] invalid parameter "111.111.111.[0-9]+" in ...

    I Googled a bit and found that 111.111.111.0/24; worked
    for a better rules I use these IP calculator: http://www.ipaddressguide.com/cidr#range

    https://wordpress.org/plugins/better-wp-security/

  2. iThemes Support
    Member
    Plugin Author

    Posted 3 months ago #

    Thanks for the report. Which version of NGINX are you using?

  3. siprof
    Member
    Posted 3 months ago #

    Nginx 1.6.0

  4. siprof
    Member
    Posted 3 months ago #

    fixed on v4.2.4
    Thanks

Reply

You must log in to post.

About this Plugin

About this Topic