WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] nggfunctions.php on line 553 (13 posts)

  1. trotterellone
    Member
    Posted 1 year ago #

    I've got the error in the topic title, when I put an album on a page. How can I solve it?

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. nanogod
    Member
    Posted 1 year ago #

    I have the same issue. What can i do? i cannot find an answer to this....
    Please help!!!

    Cheers nanogod

  3. DoubleSixx
    Member
    Posted 1 year ago #

    Check and make sure you have images in the gallery.

    I took a look at line 553 in the nggfunctions.php file.

    $galleries[$key]->counter = 0;

    The complete block is pasted below.

    // No images found, set counter to 0
    if (!isset($galleries[$key]->counter)){
    $galleries[$key]->counter = 0;
    $galleries[$key]->previewurl = '';
    }

    Essentially if there's no images the gallery will be assigned the value zero and an empty value for the previewrul.

    Could be the source of your current problem.

    Good luck.

  4. nanogod
    Member
    Posted 1 year ago #

    Unfortunately, this is not the problem. There are many pictures in at least 20 galleries, wich are organized in two albums.
    i get this message on top of the page, where the albums are. underneath the albums are shown and funktional. The messages disappear when i click an album to view the gallery. everything runs fine, except that i get these messages on top of the page (it is one message for each gallery...)

    By the way: i checked, and it is line 533 for me - sorry.

    Weird.
    I moved the blog from my testserver to the new domain - may this be the issue? I recreated the permalinks, everything runs smooth - but the gallery.

    Any idea?

    Thanks and greetz

    nanogod.

  5. nanogod
    Member
    Posted 1 year ago #

    oops - my mistake. Is says in line 553...
    I didn´t get much sleep last night :-/

  6. DoubleSixx
    Member
    Posted 1 year ago #

    Maybe re-install nggallery ? Don't delete or remove your images. Just re-upload.

  7. nanogod
    Member
    Posted 1 year ago #

    Maybe i will try. I there an easy way to recover all my galleries and albums? How do i do that?

  8. DoubleSixx
    Member
    Posted 1 year ago #

    Don't delete them. No way to recover.

    Sometimes I send up a few hundreds pictures at a time using the zip feature. Fastest way to upload images.

    So on occasion I delete a gallery and just made a new one. But I don't want you to lose all your images.

    Luckily this version is working fine for me, otherwise I would suggest trying to downgrade to version 1.9.0. (Just install over 1.9.7) Very little problems with that version, was the most stable for me for a very long time.

    Good luck.

  9. nanogod
    Member
    Posted 1 year ago #

    What do you mean with with re-upload? I install plugins alway from the backend... When i delete the Plugin (uninstall), will the gallery folder be deleted?

    if i install NGG from scratch, can i upload the galleryfolder again and somehow import them in the plugin?

    Thanks in advance!

  10. nanogod
    Member
    Posted 1 year ago #

    Okay, i made a backup from my images and uninstalled the plugin.
    The images in the galleryfolder where still there.
    i reinstalles the plugin over the backend.
    I imported a few pictures from the galleryfolder (via new gallery/import from folder).
    I put this gallery in an album (ID:1) and put this Tag in the acording page: [album id=1 template=compact]

    On the website this Text appears:
    Warning: Creating default object from empty value in /homepages/21/d24285673/htdocs/wordpress/wp-content/plugins/nextgen-gallery/nggfunctions.php on line 553

    Underneath the regular content inkluding the Album/Gallery...

    I´m getting mad! If reinstalling doesnt work... i will try to install the suggested older version...

  11. nanogod
    Member
    Posted 1 year ago #

    Okay, problems never end...
    I installed version 1.9.
    Now i have an error in the backend (add new gallery):

    Strict Standards: Non-static method nggGallery::check_memory_limit() should not be called statically, assuming $this from incompatible context in /homepages/21/d24285673/htdocs/wordpress/wp-content/plugins/nextgen-gallery/admin/addgallery.php on line 126

    Strict Standards: Non-static method nggGallery::current_user_can() should not be called statically, assuming $this from incompatible context in /homepages/21/d24285673/htdocs/wordpress/wp-content/plugins/nextgen-gallery/admin/addgallery.php on line 378

    Strict Standards: Non-static method nggGallery::current_user_can() should not be called statically, assuming $this from incompatible context in /homepages/21/d24285673/htdocs/wordpress/wp-content/plugins/nextgen-gallery/admin/addgallery.php on line 381

    Strict Standards: Non-static method nggGallery::current_user_can() should not be called statically, assuming $this from incompatible context in /homepages/21/d24285673/htdocs/wordpress/wp-content/plugins/nextgen-gallery/admin/addgallery.php on line 384

    I´m getting to the point, where i believe, that this isn´t a NGG problem, but more a problem, regarding the transfer of the website from my testserver to the "Home Server". Could this be the problem?
    I have my wordpress install under \wordpress and on the root the index.php and the htaccess.

  12. nanogod
    Member
    Posted 1 year ago #

    HeyHo! i found a sollution for this problem, well a workaround, but better than nothing :-)

    http://wordpress.org/support/topic/plugin-nextgen-gallery-warning-on-album-page-after-upgrade-to-php-540?replies=8

    this solves the problem for me, the warning message is gone, and everything is woking fine :)

    Thanks a lot!

  13. DoubleSixx
    Member
    Posted 1 year ago #

    Glad you got it working, sorry I wasn't clear.

    I didn't mean for you to uninstall or remove.

    I just meant to upload the file into the same directories. Just run over the old.

    I use an FTP program to upload, so it's a matter of just copying over the directories to the same location.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic