WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
NGG 2.0 >200 Support Threads in 2 days (8 posts)

  1. reinhardf
    Member
    Posted 8 months ago #

    Respect. NGG 2.0 is the worst WP plugin upgrade of all time. I guess we'll have 1000 NGG2.0-threads next week. :-)
    I'm still really pissed. Tens of thousands of admins have tons of work with this massive incompatible upgrade. (Ok - good admins just in the test environment...)

    It is simply unacceptable that photocrati breaks thousands of pages with an massive incompatibel upgrade.

    PLEASE make NGG 2.1 compatible with V1.9x. Thanks

    http://wordpress.org/plugins/nextgen-gallery/

  2. bengo-matus
    Member
    Posted 8 months ago #

    I can understand how they tested it. It's not working anywhere. Yes they are doing good work, but this?

  3. buffy4837
    Member
    Posted 8 months ago #

    Yeah. I'm gonna have to agree this update is a big mess. I understand how difficult it is to test and debug a plugin since there are so many variables - hosting environment, themes, plugin compatibility, browsers. There's just no way to fully test and debug. Fortunately I dodged a bullet and by only updating the plugin on a development site before updating across all the site I run. That would have been an unmitigated disaster. Thank goodness I was able to roll it back.

    That being said, I believe an incremental upgrade path would have been better suited for such a popular plugin. Seeing "Overhaul" always makes me cringe.

  4. perryzelda
    Member
    Posted 8 months ago #

    The mess will continue, as long as 2.0 will appeear in the Plugin-Updates. Everybody who does updates automatically will run into the same problems. I dont understand, why they do not withdraw this version.

  5. samaralife
    Member
    Posted 8 months ago #

    I should have learnt by now that nobody should trust new versions of NGG right away. In 2 years of having my standalone site this is the second time that a major NGG upgrade breaks things badly. Last time I had to ask a friend to restore the site from some serious "lost-all" condition. And now again I upgraded automatically (though waited for a day, not sure) and got a number of issues that make me stop posting to the site at all since I cannot add proper galleries.

    Photocrati guys should really be cautious and slow in ruining things for so many users. And they still have 2.0 in automatic upgrades - this is unbelievable.

    WordPress guys need to make NGG guys roll back automatically (and add the automatic rollback function available to all users) instead of making us lot figure out how to deal with manual rollback (I didn't manage to FTP things).

  6. bobbyau
    Member
    Posted 8 months ago #

    I was looking forward to the update by judging by the massive amount threads regarding 2.0 there is no way i can or will update anytime soon. Looks like a lot of work still to be done.

    This 2.0 is poorly tested and executed. Reckless and irresponsible release.

  7. DR Yuill-Kirkwood
    Member
    Posted 8 months ago #

    Greetings Space Cadets, what a catastrophe this update is, it killed my entire site, and any NextGEN albums and galleries pages that did eventually load just gave me an error. The only thing that did load where the Chuck Norris photos, because Norris knows no errors.
    I'm so pleased that I had just backed up my entire server the day before, I went strait back the previous version.
    Updates in the past where a mission to start with every time I had to unlock it to use more memory to limit thumb creation issues and set the thumb dimensions so all my photos did not appear as a 1 pixel column. Then restore my templates to show photo/album descriptions and album descriptions that didn't appear as a single line of text the ran off screen.
    Doing this every update was a pain but 2.0 where to start I have thousands of images over hundreds of galleries I'm not about to spend weeks adjusting all my pages and posts or spend time working out where everything has been moved to or changed.
    As I said I was so pleased I had a backup and could simply just delete 2.0 and dump the old nextGEN plugin files back and all was well again.

  8. Chris
    Member
    Posted 8 months ago #

    Guys just roll back to 1.9.13.
    http://wordpress.org/plugins/nextgen-gallery/developers/

    This will at least get your site working as normal. Without loss of photos or functionality. We just rolled back 92 sites without issues. But it is a pain in the butt when version 2.0 doesn't work as intended.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.