WordPress.org

Ready to get started?Download WordPress

Forums

NextGen plugin missing temp folder (1 post)

  1. lenamboa
    Member
    Posted 1 year ago #

    Hello all,

    I have a WordPress install and I'am trying to use the NextGen Gallery plugin to upload my family albums.

    I'am facing the well known famous Upload Failed! Missing temporary folder on my website.

    So, I've asked my favorite friend, Google and I have read a lot of posts relating this issue, so far I've tried to solve it by running the following :

    - Ive checked that upload_tmp_dir is 'correctly' set in my php.ini : i've tried to set it to "/tmp" and to "/var/www/htdocs/tmp". Of course, both tmp and /var/www/htdocs/tmp folders exist and their permissions are set to 777 !

    - Ive tried the echo getcwd(); thing into wp-admin/include/file.php but nothing showed up at all. So, I thought that it was not the correct file to put the echo thing into. I've greped the "Upload Failed!" on all /var/www/htdocs directory and this is the output :

    #!_ROOT_!#@pegasus:/var/www/htdocs# grep -r -e "Upload failed" *
    gallery/modules/gallery/helpers/item_rest.php:          "Bad Request", 400, array("errors" => array("file" => t("Upload failed"))));
    Binary file wp-content/languages/fr_FR.mo matches
    wp-content/languages/fr_FR.po:msgid "Upload failed."
    wp-content/plugins/nextgen-gallery/admin/admin.php:             'upload_failed' => __('Upload failed.'),
    wp-content/plugins/nextgen-gallery/admin/addgallery.php:                        nggGallery::show_error( __('Upload failed!','nggallery') );
    wp-content/plugins/nextgen-gallery/admin/addgallery.php:                        nggGallery::show_error( __('Upload failed! ' . nggAdmin::decode_upload_error( $_FILES['imagefiles']['error'][0]),'nggallery') );
    wp-content/plugins/nextgen-gallery/admin/addgallery.php:                    nggGallery::show_error( __('Upload failed! ','nggallery') );
    wp-content/plugins/nextgen-gallery/lang/nggallery.pot:msgid "Upload failed!"
    wp-content/plugins/nextgen-gallery/lang/nggallery.pot:msgid "Upload failed! "
    wp-content/plugins/nextgen-gallery/lang/nggallery.pot:msgid "Upload failed."
    Binary file wp-content/plugins/nextgen-gallery/lang/nggallery-de_DE.mo matches
    Binary file wp-content/plugins/nextgen-gallery/lang/nggallery-de_DE.po matches
    wp-includes/script-loader.php:          'upload_failed' => __('Upload failed.'),

    So, I put the echo command in wp-content/plugins/nextgen-gallery/admin/addgallery.php, and it showed me the tmp folder WP is trying to use which is htdocs/wp-admin in my case !!!

    - Well, then i tried to create a tmp folder in htdocs/wp-admin and set the perms to 777.
    Still no luck.

    - So, at that point I was tired to read posts and try a lot of stuff at random. So I've set the whole /var/www/htdocs folder's permissions to 777 !!!!!! (God Forgive Me !!! ;-) )
    And guess what : exactly the same issue : temporary folder !

    So I decided to post here.

    My WP version is 3.4.1.
    System OpenBSD 4.9 kernel.
    Built in Apache HTTPD.

    If you guys would like to know anything else about my config, feel free to ask. I'am not familiar with PHP and Web developement, so I dont know exactly what parameters to post.

    [ Please do not bump, that's not permitted here. ]

Topic Closed

This topic has been closed to new replies.

About this Topic