WordPress.org

Ready to get started?Download WordPress

Forums

Nextgen memory issues with WP 2.5 (7 posts)

  1. cartpauj
    Member
    Posted 6 years ago #

    I've recently updated my wordpress version to 2.5 and then updated to the latest nexgen version 0.94 but when I try to re-create thumbnails on photos (that used to work just fine) larger than 1MegaByte I get a memory usage error:
    IMG_2734.JPG (Error : Exceed Memory limit. Require : 52.31 MByte)
    IMG_2741.JPG (Error : Exceed Memory limit. Require : 52.31 MByte)
    IMG_3007.JPG (Error : Exceed Memory limit. Require : 52.31 MByte)
    IMG_3302.JPG (Error : Exceed Memory limit. Require : 52.31 MByte)
    IMG_3484.JPG (Error : Exceed Memory limit. Require : 52.31 MByte)
    IMG_3502.JPG (Error : Exceed Memory limit. Require : 52.31 MByte)
    IMG_3503.JPG (Error : Exceed Memory limit. Require : 52.31 MByte)
    IMG_3559.JPG (Error : Exceed Memory limit. Require : 52.31 MByte)
    IMG_3672.JPG (Error : Exceed Memory limit. Require : 52.31 MByte)
    ...

    Any ideas?

  2. Alex Rabe
    Member
    Posted 6 years ago #

    Have a look at the NextGen Gallery FAQ

  3. cartpauj
    Member
    Posted 6 years ago #

    Ok I edited my php.ini file in my home dir to 64M with a 60sec timeout but for some reason on the front page of NextGen (where it displays the server settings) it still thinks my memory is set to 32M any ideas?

  4. Alex Rabe
    Member
    Posted 6 years ago #

    Some web hoster didn't allow this edit of the php.ini file or you need to restart the web server. Depend on your enviroment...

  5. cartpauj
    Member
    Posted 6 years ago #

    thanks for helping, just wondering if there is more than one php.ini file on a server? I'm a bit of a newbie at this stuff.

  6. cartpauj
    Member
    Posted 6 years ago #

    Ok I talked with my host provider and they said that the memory limit cannot be placed above 32M because it would cause problems with the server. I'm wondering why I could get thumbnails to create just fine with the old version of WP and NextGen but now I'm getting the error?

    EDIT: and is there anything I can do to make it work again aside from lowering the resolution of my photos?

    Thanks in advance,

  7. Alex Rabe
    Member
    Posted 6 years ago #

    No , GD library needs memory....

Topic Closed

This topic has been closed to new replies.

About this Topic