WordPress.org

Ready to get started?Download WordPress

Forums

NextGen Gallery Voting 'problem saving your vote' (10 posts)

  1. jamminjames
    Member
    Posted 2 years ago #

    Since the recent update for NextGen Gallery Voting, I get this whenever I try to vote: 'There was a problem saving your vote, please try again in a few moments.' After refreshing, however, I can see that the vote did get counted.

  2. shauno
    Member
    Posted 2 years ago #

    Hey James

    What version of NGG, and NGG V are you using?
    Is it image or gallery voting?
    What options are selected?

    I will try replicate once I have more info.

  3. jamminjames
    Member
    Posted 2 years ago #

    NGG 1.8.3, NGG V 1.9.1

    It's image voting, on the thumbnails (which has worked fine until now), since it won't work on the individual images.

    NGG V options are: No gallery voting options checked; Enable image voting, does not have to be logged in (problem happens whether logged in or not), one vote per image, allow users to see results, star rating.

    Here's a gallery on the site.

  4. shauno
    Member
    Posted 2 years ago #

    I can't replicate the problem on any of my installations.
    The one thing that I do notice about your site is that there seems to be hundreds of lines of JS and CSS in the response.
    I wonder if all that response is just too much for the HTTPRequest.responseText.

    Can you try with the WP default theme and see if it works then? Let me know the result.

  5. jamminjames
    Member
    Posted 2 years ago #

    I tried Default, Constructor and Ambient Glow, still does it.

  6. jamminjames
    Member
    Posted 2 years ago #

    PS Could the cache have anything to do with it? I'm using W3 Total Cache.

    Also, Firebug is reporting this error for NGG:
    "NetworkError: 404 Not Found - http://www.humortimes.com/wp-content/plugins/effects-for-nextgen-gallery/effects/highslide/lib/highslide-config.css?ver=0.8.5"

    ...could that have anything to do with it? I tried copying the highslide-config.css file it's looking for, which actually resides one level above the /lib/ folder, into the /lib/ folder, but it had no effect.

  7. shauno
    Member
    Posted 2 years ago #

    The cache may very well be the problem. I definitely haven't tested with any of the cache plugins.
    I will try make some time to test with caching and see what I come up with.

    The 404 on the highslide file shouldn't have any effect I would imagine.

  8. shauno
    Member
    Posted 2 years ago #

    I've just tested with WP Total Cache, and it seems to work fine on my test install, with the same version of NGG and NGGV, and the same image voting options as you have set.

    The caching sounded like a viable reason. If the response to the ajax request has been cached as a failed response, then it would return the error, no matter what actually happened. But it seemed to work perfectly for me no matter how much I try to trick it.

    Maybe you can try deactivating the cache plugin and trying? Failing that, deactivate all plugins and try. If it works then, reactivate 1 by 1 to see where it fails. Then there might be a conflict I can look into.

    Sorry I couldn't get this sorted quickly, but I just cannot replicate the problem

  9. jamminjames
    Member
    Posted 2 years ago #

    Ok, I finally got around to working this out. It was a cache issue. After trying a lot of things, it was disabling the HTML & XML minify that fixed it.

    I'm using W3 Total Cache, and under Minify/HTML & XML minify settings, I had Inline CSS minification, Inline JS minification and Line break removal checked. I tried all the combinations of unchecking/checking these, but the only thing that worked was to disable the whole HTML & XML section.

    Too bad, I'd like to use as much minify as possible. Do you think there's any way to address this in your code?

    Thanks.

  10. shauno
    Member
    Posted 2 years ago #

    When I wrote the plugin, there was no clean way of doing the JS that is required for the ajax voting. This lead to ugly includes midway through the page, as well as apparently random pieces of inline JS.
    I'm not sure exactly what would need to change to satisfy the caching plugin, but I don't think I'm going to find the time to figure it out now.

    If you do look into it in detail and figure it out, feel free to let me know. I can possibly incorporate the changes into the next version.

Topic Closed

This topic has been closed to new replies.

About this Topic