WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] nextgen gallery slideshow keeps loading (35 posts)

  1. Frenkie
    Member
    Posted 1 year ago #

    Created a gallery, added the shortcode on my page and the loading icon keeps showing without showing images etc.

    Searched through the FAQ and tried to google the problem but without any result. Can someone help me out?

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. gabriana
    Member
    Posted 1 year ago #

    Ok, I'm having this same problem too!!! What is the solution? Are there too many photos in the gallery and that's why it isn't loading? Please help us!!!

    Thanks, Gabriana

  3. Funkyochris
    Member
    Posted 1 year ago #

    Hi,

    I have the same problem too. It happened to me after updating WordPress, as well as the plugin. Re-installing the plugin did not help (also re-installing older versions).
    Does anybody know how to fix it?

    Chris

  4. ehben
    Member
    Posted 1 year ago #

    I aslo have the same problem. I love this plugin and I don't want to change. I found an error :

    Uncaught TypeError: Object [object Object] has no method 'nggSlideshow'

    I don't know what to do.

  5. MarjoriesDaughter
    Member
    Posted 1 year ago #

    This has been problem for some time. The slideshow seems to work better if you click the link from a gallery, as opposed to using the slideshow shortcode.

    wordpress.org/support/topic/nextgen-slideshow-not-working-2

  6. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    Could you all reply with the following information?

    - WordPress up to date?
    - NextGEN up to date?
    - What version of NextGEN Gallery did you upgrade from? (i.e. I had 1.9.8, then upgraded to 1.9.12)

    (please confirm the following, with your server host tech) :
    - MySQL up to date (at least 5.2.4)?
    - PHP up to date (at least 5.0)?
    - The mod_rewrite Apache module activated?
    - PHP Safe Mode OFF?

    Additional information that will help us find a solution:
    - Who are you hosted with?
    - What theme are you running?
    - Which plugins do you have installed and activated?
    - Does this error still occur if you switch your theme to the WP default, and deactivate all plugins except NextGEN Gallery? (*be sure to clear your browser cache and reload your site after deactivating)

    Another thing to check server side, is that you have sufficient memory_allowed in your php.ini file (at least 120MB). What may be happening is that you are running out of memory and that is why you're seeing the constant loading icon.

    Hope this helps!

  7. davidutz
    Member
    Posted 1 year ago #

    i'm having the same problem wordpress/nextgen uptodat

  8. Funkyochris
    Member
    Posted 1 year ago #

    Info:
    - WordPress: 3.5.1
    - NextGEN:1.9.12
    - What version of NextGEN Gallery did you upgrade from? Don't remember
    - MySQL up to date (at least 5.2.4)? 5.5.3
    - PHP up to date (at least 5.0)? 5.3.21
    - The mod_rewrite Apache module activated? don't know
    - PHP Safe Mode OFF? yes

    My slidewhow does not work with the WordPress default themes. All other plugins are deactivated. I have a second (older WordPress installation) on the same server (using a different database) and here the slideshow works using WordPress 3.2.1, NextGen Gallery 1.8.2 and NextGen Flash Viewer 1.3.

  9. voeslav
    Member
    Posted 1 year ago #

    Nextgen slideshow works fine in WP 3.4.1. After upgrading WP (3.5.1) slideshow don't work.

  10. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @Funkyochris , @voeslav, Would you both deactivate NextGEN Gallery > Clear Browser Cache > Reactivate NextGEN Gallery only, and then reload your site and see if that works better?

  11. talkbacktohate
    Member
    Posted 1 year ago #

    @photocrati, I'm having the same problem. Not sure I have the skill to get you all of this information but I'll answer what I can... Please help! Thanks.

    - WordPress up to date?
    Yes

    - NextGEN up to date?
    Version: 1.9.12

    - What version of NextGEN Gallery did you upgrade from? (i.e. I had 1.9.8, then upgraded to 1.9.12)
    Not sure

    - MySQL up to date (at least 5.2.4)?
    Software version: 5.5.30-cll - MySQL Community Server (GPL)

    - PHP up to date (at least 5.0)?
    Not sure, but the plugin always worked before last week, and it seems that I can still access images from old galleries, just not the galleries themselves.

    - The mod_rewrite Apache module activated?
    Same as previous question.

    - PHP Safe Mode OFF?
    Same as previous question.

    Additional information that will help us find a solution:
    - Who are you hosted with?

    Name.com

    - What theme are you running?
    My developer's custom theme, which is based on HTML 5 Boilerplate and YAML I believe

    - Which plugins do you have installed and activated?
    Activated:

    Google Analytics By Joost;
    NextGEN Gallery;
    TablePress;
    Wordpress SEO.

    Installed, but inactive:
    Akismet
    VeriteCo TimelineS
    Easy FancyBox
    FitVids for WordPress
    Portfolio Slideshow
    prettyPhoto Media
    VeriteCo TimelineS
    WP Splash Image
    WP Video Lightbox

    - Does this error still occur if you switch your theme to the WP default, and deactivate all plugins except NextGEN Gallery? (*be sure to clear your browser cache and reload your site after deactivating)

    I'm afraid to do that!

    I did try deactivating the plugin, clearing cache, and then reactivating.

  12. cop4200
    Member
    Posted 1 year ago #

    Hi guys, I am having the exact same issue. in gallery, it just keeps loading. Anyone figured out the solution yet?

  13. eegz
    Member
    Posted 1 year ago #

    I'm having the same issue.

    Someone noted on a different thread that there may be a problem with jQuery: http://wordpress.org/support/topic/plugin-nextgen-slideshow-suddenly-stopped-working

    Not sure if this is the same problem. I don't currently know how to change the version of jQuery WP is using to find out.

    I turned on WP_DEBUG, but didn't see any warnings related to the gallery. The one message I did see I got rid of by disabling the relevant plugin but still had the same gallery issue with no warnings.

    Looking forward to someone figuring this one out.

  14. 1DMF
    Member
    Posted 1 year ago #

    Same problem, NextGen gallery doesn't work, all I get is a ghosted page with the word 'Loading' in red, when you click a thumbnail image and it then never loads.

    The flash option, just shows a black box and nothing loads.

    In slideshow mode all you get is a loading AJAX spinning icon and nothing ever loads.

    Answers to questions below
    ----------------------------------

    - WordPress up to date?

    Yes (3.5.1)

    - NextGEN up to date?

    Version: 1.9.12

    - What version of NextGEN Gallery did you upgrade from? (i.e. I had 1.9.8, then upgraded to 1.9.12)

    None, it's a new install.

    - MySQL up to date (at least 5.2.4)?
    Software version: 5.5.25 - MySQL Community Server (GPL)

    - PHP up to date (at least 5.0)?
    Yes (5.3)

    - The mod_rewrite Apache module activated?

    N/A (this is Windows 2008 with IIS7)

    - PHP Safe Mode OFF?

    ? what does that mean

    Additional information that will help us find a solution:
    - Who are you hosted with?

    It's our own server

    - What theme are you running?

    RT-THEME 15

    - Which plugins do you have installed and activated?

    Activated:
    NextGEN Gallery
    Site Replicator for WordPress networks
    WordPress MU Domain Mapping
    WP SMTP Config

    Installed, but inactive:
    Hello Dolly

    - Does this error still occur if you switch your theme to the WP default, and deactivate all plugins except NextGEN Gallery? (*be sure to clear your browser cache and reload your site after deactivating)

    Not going to happen, I have too many sites with too much at stake to be switching on and off themes, your plugin will go before my theme does!

    Hope this can be resolved soon, my client wants to go live with their site and this is the only thing holding back the launch!

    Regards,
    1DMF

  15. stacye
    Member
    Posted 1 year ago #

    I just got the call from a long time client that their site's slider is now broken. No updates have taken place on my side, and I'm getting the ajax spinner.

    - WordPress up to date? - no (3.2.1)
    - NextGEN up to date? - yes
    - What version of NextGEN Gallery did you upgrade from? (i.e. I had 1.9.8, then upgraded to 1.9.12) using 1.9.3 with no recent upgrades

    (please confirm the following, with your server host tech) :
    - MySQL up to date (at least 5.2.4)? yes
    - PHP up to date (at least 5.0)? yes
    - The mod_rewrite Apache module activated? yes
    - PHP Safe Mode OFF? yes

    Additional information that will help us find a solution:
    - Who are you hosted with? hostmonster
    - What theme are you running? Atahualpa 3.6.7
    - Which plugins do you have installed and activated?
    Adsense Widget
    Better WP Security
    BotBlocker
    Contact Form 7
    Easy Columns
    Featured Page Widget
    Flexo Archives
    FLV Gallery
    Image Mouseover
    Lightbox Plus
    Promotion Slider
    TinyMCE Advanced
    Widget Logic
    WP Google Fonts

    - Does this error still occur if you switch your theme to the WP default, and deactivate all plugins except NextGEN Gallery? (*be sure to clear your browser cache and reload your site after deactivating) Yes

  16. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    NOTE: As you upgrade WordPress and other plugins along with NextGEN, some compatibility issues can occur.

    A few things for you guys to check into:

    - LINUX HOSTING: Check with your server host that you're on their LINUX servers or if they can switch you to their Linux hosting servers. WordPress was made to work on Linux server host and not on Windows, you'll experience a lot of issues if you're on Windows, simply because the WordPress software is in the wrong type of environment. A list of fully compatible hosting services can be found on WordPress.org recommended list here: http://wordpress.org/hosting

    - PERMISSIONS: WordPress and our plugin should work well with 755 permissions, any higher permissions than that - you run the risk of exposing your entire site to hackers. You should never have to go higher than 755 (i.e. 777). Check with your server host tech support to see if any server-side permissions may be preventing your site gallery functionality from working properly. It may be that they need to reset your /wp-content directory to 755 permissions.

    - MEMORY: Your 'memory_allowed' setting in your server account php.ini file may be too low. Check with your server hosting support, and see if they can increase the memory allowed (to at least 128MB).

  17. eegz
    Member
    Posted 1 year ago #

    Thanks for trying to help photocrati.

    I'm running everything on my own server. All permissions are set to 755 and I upped the memory to 256M.

    I have a similar setup on a machine at work (although it's a win 2008 server). I haven't upgraded it for a few months and it's currently fine. I can try messing with it to see when it breaks. :)

  18. hodyshoran
    Member
    Posted 1 year ago #

    Same here, keeps loading but no picture appears

  19. 1DMF
    Member
    Posted 1 year ago #

    You're having a laugh right?

    WordPress is a PHP compatible piece of software which runs on Windows as does MySQL, you claim to be a WordPress plugin, but quite clearly this is false advertising as you now state that WordPress needs to be hosted on Linux, when it doesn't!

    You and your plugin are a joke!

    To run WordPress your host just needs a couple of things:
    ◾PHP version 5.2.4 or greater
    ◾MySQL version 5.0 or greater

    The requirements have changed as of WordPress 3.2. The minimum requirements for WordPress 3.1 are PHP 4.3 and MySQL 4.1.2.

    That’s really it. We recommend Apache or Nginx as the most robust and featureful server for running WordPress, but any server that supports PHP and MySQL will do.

    This was taken from the following WordPress URL : http://wordpress.org/about/requirements/

    NOTE the important bit 'any server that supports PHP and MySQL will do'

    You should be ashamed of yourself for spouting such lies that you are a WordPress plugin when clearly you are not!

    I'm disgusted by your atrocious support, your lies and incompetence and am immediately removing your plugin and recommend everyone else does the same!

  20. stacye
    Member
    Posted 1 year ago #

    1DMF, I agree with you. I'll be looking for another slider for my client's site. I've had problems with NGG in the past, but I had thought those might have been sorted with new "management", but things haven't changed.

    Any suggestions for a slider with a clean interface?

  21. 1DMF
    Member
    Posted 1 year ago #

    Unfortunately I don't , I've been looking for a decent 'free' plugin for a while, which is why I had high hopes for NextGen, but clearly I was misguided!

    This URL may help : http://www.eugenoprea.com/10-great-wordpress-photo-gallery-plugins/

    But I have found after installing a few that they seem great, until you go to use them and then find things like multiple images are only allowed if you pay for the 'Pro' version.

    If you find one please come back and let us all know!

    I've currently gone with the built in WP one, which is awful because the media link doesn't work and takes you to an image page for comments, and the site doesn't want comments!

    The theme I am using has a gallery built in, but that has problems with the thumbnails not working currently, though I am at least getting real support so far from the theme creator!

    It seems anything WordPress is flaky to say the least!

  22. stacye
    Member
    Posted 1 year ago #

    If you need one that allows custom links, I've used this one on several sites - http://wordpress.org/extend/plugins/promotion-slider/

    It hasn't been updated in a while, but I haven't seen any issues on my sites, and the support in the WP forum is good. I may wind up using it as the replacement for NGG (even if it's temporary), so I can get this one site back up and running.

    Yeah, there are a lot of flaky plugins, and WordPress has it's moments, too, but you get a lot of flexibility and power for the price. Once you get a solid set of plugins and a base theme you can work with, it makes life easier.

  23. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @1DMF - You're right, WordPress does mention that. What I meant to say is, WordPress and most robust plugins work better on Linux hosting. To correct my earlier statement, WordPress & our plugin will work on some Windows servers, but will work better on Linux hosting.

    More information on Windows vs. Linux for WordPress can be found in this thread discussion: http://wordpress.org/support/topic/what-is-better-to-have-a-windows-hosting-account-or-a-linux-hosting-account?replies=13

    http://wordpress.org/support/topic/can-i-install-wordpress-with-windows-hosting-better-than-linux-hosting?replies=3

  24. 1DMF
    Member
    Posted 1 year ago #

    Yup, and as the saying goes 'You get what you pay for!'.

    It just really grinds my gears when people start using the 'MS' BS as a blame for all ills when the software is meant to be platform independent!

    As if we are going to spend 10's of 1'000s of pounds to replace production servers servicing in-house systems and 50+ websites that all run perfectly fine, as a fix for a free WordPress plugin! That quite clearly doesn't work properly on *nix OSes anyway judging by the plethora of recent complaints!

    Even a plugin we bought for replicating sites has some Windows issues, but at least the author worked with me to isolate the 'unix' style commands causing the failure so I could amend the plugin with windows replacement shell commands!

    I just hope the theme author can fix their gallery so I can forget using a plugin altogether!

  25. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @1DMF - We are working on a PRO version of the plugin, where with that we can provide dedicated support like the premium plugin author you mentioned was able to work with you to help the plugin work with your Windows hosting. We do the best we can in terms of support for our free plugin. What I can tell you and others, in general, the plugin and WordPress work best in a linux hosting environment, with the proper permissions applied. We are close to releasing v2.0 Beta of NextGEN Gallery where we have dramatically reworked a lot of the coding, and it will likely improve the performance of the plugin overall for most users in all types of hosting environments. This Beta will hopefully be available within the next couple of weeks.

  26. eegz
    Member
    Posted 1 year ago #

    My server is Linux (Ubuntu) and I'm still having the issue the thread started with.

    Ubuntu Server
    - Not hosted, running in my own home
    - PHP 5.3.10 & MySQL 14.14 Dist 5.5.29 (haven't updated those in months)
    - mod_rewrite: Just enabled though I didn't need it before when it worked (still not working after enable and restart)
    - PHP Safe Mode: Off
    - WP version: 3.5.1
    - NextGEN Gallery version: 1.9.12
    - Theme: Pinboard
    - Javascript warnings: none
    - PHP warnings: none
    - Gallery memory set to 256M

    Of note:
    - Not sure if this is related, but since upgrade to latest WP, media gallery works by itself, but when I try to use the media library (to set header image for example) the gallery is blank (see thread on this topic at http://wordpress.org/support/topic/media-library-blank-empty?replies=7).

    Did someone find a solution or did we just get sidetracked?

  27. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @eegz - Does the gallery work better if you were to deactivate all plugins (including NextGEN Gallery), temporarily switch Theme to WP Default, then reactivate NextGEN Gallery only > clear browser cache, and reload your site?

  28. eegz
    Member
    Posted 1 year ago #

    @photocrati

    That was scary, but I went through the steps.

    Apparently the other themes I have (including the old ones) work, but the pinboard theme does not. Pinboard has an update available, but I'll destroy all my customizations if I take it so I haven't done that.

    I'm currently at Pinboard v 1.06. There's a 1.07 available (again don't know if it'll work, but I'm not willing to risk it at this time given I'll lose a lot of customizations and I'm in the middle of a job hunt using this site as my portfolio).

    Themes that worked:
    - Motion v 1.1.6
    - Twenty Eleven v 1.4
    - Twenty Ten v 1.4

    Big note: The media library also worked with the other themes as well (when choosing to set the header image). It doesn't work with Pinboard anymore after the 3.5.1 update.

    I didn't try any other themes.

    Here's hoping you can find the possible theme detail that I might be able to manually change to make this work.

  29. deegan
    Member
    Posted 1 year ago #

    Hello,

    I have the same problem... but i've tried so many things to make it work but nothing solved the problem so i've decided to delete the pluggin and use another gallery... even if your pluggin was sooo great ... i really liked it but my customers are really mad about having several issues from this pluggin on their websites.

  30. eegz
    Member
    Posted 1 year ago #

    I got this to work for myself. If you're lucky this applies to you to. :)

    My problem was that I had put some script includes at the top of my functions.php file. That's it.

    There were no error or warning messages of any kind that told me I had a problem, I just had to use the old school binary-yank-until-things-worked method.

    This fixed both my issues with this plugin as well as the media library. It also fixed my "recent" links problem.

    Don't know whether to be embarrassed for missing that or proud I found it (probably both). Hope this helps someone else out there!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic