WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery - Remove Title From Image Browser? (8 posts)

  1. crabbytech
    Member
    Posted 3 years ago #

    Hello everyone,

    Is there a way to keep the title of the image from displaying over the image when using the image browser gallery with the NextGEN Gallery plugin?

    I do screenshots for video games and end up with a lot of images and they all have ugly titles like "deadspace2-2011-01-30-14-14-57-79." It's not a huge deal, but it would look much nicer if that would just go away.

    http://www.gamesnoops.com/2011/01/30/dead-space-2-review/2/

    I've searched all over the admin panel and I either missed it or there is no way. Perhaps some snippet of code I could pluck from widgets.php or something to keep the title from being pulled?

    Thanks!

  2. VinnySem
    Member
    Posted 3 years ago #

    I am also looking for a solution to this!

  3. crabbytech
    Member
    Posted 3 years ago #

    So far the only solution I've found VinnySem is to go into the admin panel under the gallery and then just manually tab through and delete the titles for each picture. There is a title field and a description field in there.

    What I'm finding out is that the plugin is automatically generating the image titles and inputting that into the title field (based on filename) so that it will display. I'm sure for most people that is quite handy, but so far I haven't figured out a way to disable that feature so you don't have to manually delete the titles each time you post a new gallery.

    Probably have to dig into the code.

  4. VinnySem
    Member
    Posted 3 years ago #

    Seems like a significant bug, there is an option to not display captions in the Galleryview addon, and the captions still display.

  5. crabbytech
    Member
    Posted 3 years ago #

    I figured it out!

    Ok here is what is happening. When you upload an image to NextGEN Gallery, it automatically imports the title of the jpg to a field in the admin panel called "Title."

    This field is displayed over the image when using the image browser feature.

    Now the workaround I was using was to go back through and manually delete all of the titles out of those fields in the NextGEN Gallery admin panel through wp, but that was tedious and time consuming.

    However, there is a quick an easy way to just tell the plugin not to display whatever is in the title field. It actually thinks the title and description in the admin panel are "alttext."

    Go into Plugins > Editor > Select NextGEN Gallery in drop down menu > edit imagebrowser.php in the admin panel.

    Look for this line of code:

    <h3><?php echo $image->alttext ?></h3>

    Comment that out or delete it.

    Done.

  6. JimBoom
    Member
    Posted 3 years ago #

    Thanks for that tip, i was having trouble finding that particular file in the plugin. Another way to do this, btw, if you don't want to mess with the template file, is to do it in CSS, by adding a display:none; instruction to the element .ngg-imagebrowser h3
    Either way works.

  7. signaturecycles
    Member
    Posted 3 years ago #

    JimBoom,

    Would you mind adding a bit more detail to your solution? I'm naive enough not to be able to make this happen.

    To be clear, I'm trying to force no titles or description with the thumbnails in a gallery.

    Thanks very much.

  8. signaturecycles
    Member
    Posted 3 years ago #

    Sorted this out by adding display:none; to

    .ngg-gallery-thumbnail span

Topic Closed

This topic has been closed to new replies.

About this Topic