WordPress.org

Ready to get started?Download WordPress

Forums

NextGen Gallery: Permalinks not Working (6 posts)

  1. evossman
    Member
    Posted 6 years ago #

    I use the great plugin NextGen Gallery on my photoblog and recently tried to get permalinks working.

    My photos are stored in the default wp-content/gallery. I use WP 2.5, and my permalink structure is set to Day and Name. My htaccess file is set to writeable. I checked the permalinks box, and updated my permalinks structure.

    I was wondering if by setting permalinks the "wp-content/gallery" should go away? I'd like it to not say wp-content/gallery if possible. I can always setup a better folder name than in the wp-content folder but I was hoping permalinks would manage that?

    You can see what I mean here - just hover over any picture.

    Maybe just understanding the structure nextgen uses for permalinks would help.

    Thanks in advance.

    Aloha,
    Erik

  2. evossman
    Member
    Posted 6 years ago #

    After more digging, it appears I have to change the folder name. the permalinks just eleviates the random &'s and numbers and such, not the default folder location.

    Can anyone confirm this?

  3. Alex Rabe
    Member
    Posted 6 years ago #

    No nextgen work only with permalinks for naviagtion, albums and gallery pages instead of GET variables.

  4. bl4sfemi4
    Member
    Posted 5 years ago #

    Sorry for the stupid question, but how do you update your permalink structure? I know where and how it is done, but I just don't know what should be the new structure?

  5. bl4sfemi4
    Member
    Posted 5 years ago #

    I chose activate permalinks, I then went to "permalinks", clicked on update, and now I get 404 errors when trying to navigate the pages of a gallery. Can anyone offer some orientation?

  6. derebo
    Member
    Posted 5 years ago #

    dear all,

    evossman, i have the same problem... i install according to instructions. i'm interested in permalinks working so a link like yours:
    http://www.myweb.com/wp-content/gallery/firstgallery/firstpic.jpg

    could shouls like:
    http://www.myweb.com/firstgallery/firstpic.jpg

    so i uplodaded plugin and imagerotator.swf to
    /myweb.com/wp-content/plugins/nextgen-gallery

    then activate the plugin and then in options i check activate permalinks. then i regenerate permalinks by using the wordpress options--permalinks (keep everything the same actually) and then save changes.

    maybe that's not the way of regenerating permalinks and that's why images in a gallery under a new page or just about images anywhere keep on showing like
    http://www.myweb.com/wp-content/gallery/firstgallery/firstpic.jpg
    instea of
    http://www.myweb.com/firstgallery/firstpic.jpg

    .htaccess looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    please, any tip is welcome!

    greetings,

Topic Closed

This topic has been closed to new replies.

About this Topic