WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] NextGEN Gallery - how to change PHP upload limit? (11 posts)

  1. Aimee
    Member
    Posted 6 years ago #

    Is there a way to change the PHP max upload limit? It needs to be higher than 2MB. Thanks.

    Nevermind, googled it.

  2. mitchelljl
    Member
    Posted 6 years ago #

    I would like to know as well please?

  3. Aimee
    Member
    Posted 6 years ago #

    Make php.ini file under your public_html directory. Then put this in the php.ini file:

    upload_max_filesize = 100M
    post_max_size = 100M

    You can change the 100 to as low or as many MB's as you want.

    Then go to your .htaccess file and put this in:
    suPHP_ConfigPath /home/your_ftp_username/public_html

    Make sure to change 'your_ftp_username' to your ftp username of course. :)

  4. matjes
    Member
    Posted 5 years ago #

    There is an easier way.

    Just add these 2 lines to .htaccess:

    php_value upload_max_filesize 100M
    php_value post_max_size 100M

    And of course feel free to change the "100" to anything you need.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    matjes: That particular solution will only work for people who's servers are using mod_php.

    Also, please do not post the same post to every thread made on this topic in the last 6 months. It's a tad annoying.

  6. CowboyTed
    Member
    Posted 5 years ago #

    Hello,
    I tried both ways above to increase my upload sizes and with both I get a 500 internal error. There has to be any easy way to increase the file size or to get to the php.ini file. Can someone please help me???
    I am stuck with 5m of video upload

    I am using Network Solutions as my server and unix platform

  7. delikid
    Member
    Posted 5 years ago #

    I created a php.ini

    in it I put

    post_max_size = 50M
    upload_max_filesize = 40M
    max_execution_time = 900
    memory_limit = 30M

    I put the php.ini file in the /wp-admin/ folder

    Gallery now set to upload 40M

  8. kenspo
    Member
    Posted 5 years ago #

    i made an php.ini file..and put it in the /wp-admin/ folder..
    But still i get:

    * Operating System : Linux
    * Server : Apache
    * Memory usage : 11.7 MByte
    * MYSQL Version : 5.0.32-Debian_7etch8-log
    * SQL Mode : Not set
    * PHP Version : 4.4.9
    * PHP Safe Mode : On
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 16M
    * PHP Max Upload Size : 12M
    * PHP Max Post Size : 12M
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : No
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    what do i do wrong?

  9. julesgaffney
    Member
    Posted 5 years ago #

    Hi all,
    I used the method from delikid and it works great. i didn't try the method from aimeeish.
    the method from matjes gave me a 500 error so I don't recommend it.

  10. lepuzar
    Member
    Posted 5 years ago #

    I follow Jules, after setting up the download-monitor plugin for http://www.thecuracaoisland.com I experienced post-max error. The website is dedicated to bringing information about the island of Curacao (car rentals, banking, weather...) and as a freebie I offer a screensaver which is too large to be uploaded directly. I am hosting with 1&1 with an 8MB post limit and the screensaver is 14MB. I did not have access to php.ini. Creating a new php.ini and uploading it to the wp-admin folder did the trick.

  11. LJagermaster
    Member
    Posted 5 years ago #

    It's worth noting that this hack probably won't work for almost everyone using a free hosting plan. I know this from experience, and I also came to realise that the majority of free hosting plans have a "global" limit, where all accounts under the free plan are forced to abide by this restriction. If you are paying for hosting though, and can't pull this off, consider contacting your account provider, as they would have a better idea how to resolve this issue.

    NOTE: Be careful, your host may not allow this to be done, even if it is possible, so it'd be wise to start off by inquiring about it, rather than saying "I did this, but it won't work...why?". If they don't allow it they could delete your account without hesitation :-(

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.