WordPress.org

Ready to get started?Download WordPress

Forums

NextGen Gallery: Galleries don't display after 2.8! (47 posts)

  1. JasonGW
    Member
    Posted 5 years ago #

    *Sigh*, when will I ever learn to not upgrade right away? :P

    Subsequent to my upgrade to 2.8, NextGen gallery will not display my galleries embedded on pages anymore. I have tried removing the gallery, reinstalling it, upgrading it--you name it. I've tried everything except whatever the one thing is that will fix it.

    Anybody know what that one thing might be?

    http://www.uglybabystudios.com

  2. eharris
    Member
    Posted 5 years ago #

    Similar problem. Gallery will display thumbnails, but when I go to display the image itself, the JavaScript function kicks in and I get the "loading" screen, which never goes away.

    Sadly, 2.8 also hosed my theme. Thankfully, I did a database and file system backup immediately before upgrading, so while I had to delete and re-upload my whole website and restore the database, I'm running 2.7 without any problems once again. I got lazy and didn't sufficiently check 2.8 out on my test site.

    This is with NextGEN Gallery 1.3.3

  3. eyeini
    Member
    Posted 5 years ago #

    Same problem, just updated both wordpress and NextGen. Uploaded a Zip file, and said it successfully created thumbnails. When I go to the "manage" page, my new gallery does not show up. When I go to upload the zip file again, the drop down menu says my gallery is there. Help?

  4. JasonGW
    Member
    Posted 5 years ago #

    My gallery management side looks fine, but for some reason when I create a public facing "page" and embed a gallery, nothing shows up at all. No idea why. This is on two different sites now. I'm not upgrading anything else to 2.8 until I find out what's wrong.

    When will I learn not to be a damned early adopter! :)

  5. ac1969
    Member
    Posted 5 years ago #

    Same here. Just noticed this post, after having submitting one myself. I just did the upgrade to WP 2.8
    The galleries on my posts do show the thumbnails fine, but clicking on them brings you straight to the jpg file, rather than showing them in the effect box format I was used to when running 2.7.

  6. chris81cm
    Member
    Posted 5 years ago #

    Hi all,

    I have the same problem.
    After Upgrade to WordPress 2.8 :-( can anyone help us?

  7. bosnuk
    Member
    Posted 5 years ago #

    My galleries work fine, though flash uploading gets a bit jerky from time to time.
    The really weird effect I got after upgrade is that only every second [singlepic] is visible. I sometimes use more than one singlepic in one post and after an upgrade it looks like this: a normal thumb, then goes a piece of code like [singlepic id=xxxx h=400] instead of a picture, then again another image alright, then again a piece of code, and so on.

  8. kweilbacher
    Member
    Posted 5 years ago #

    has anyone tried to install Nextgen on a clean WordPress 2.8 installation?

  9. chit chat administrator
    Member
    Posted 5 years ago #

    I am having a similar problem.

    I can see the thumbnail pics in the gallery but the Upload image option does not work at all so the pics I have on my site front page will remain forever until this is fixed.

    I also upgraded to WordPress 2.8 - what a disaster. I had to restore my entire database on the weekend. The widget screen won't allow any widgets to be moved or added. Anyone else having this problem. I have created a ticket for it.

    Does anyone know how to add a description to slider pictures using NextGen. I have asked for weeks. I imbeded the slider code onto a post with sizing but I don't know what code should be part of the string to get the description to display and no one in the forums responds.

    I am also not sure how to downgrade to wp 2.7. I have downloaded the files onto my hard drive but attempts to send it over to the server side seem to fail. After having to restore the entire database I am afraid to fool around with this.

    Darlene

  10. Alex Rabe
    Member
    Posted 5 years ago #

    Hello together, to help on each issue, I need more information :

    a) Please post your server settings (See gallery -> overview)
    b) Please provide a sample link to your blog (for those users which have a problem at the frontend)
    c) Please don't comment this thread if you have a different problem, open your own thread. This makes it easier to answer....

    Therefore I start with JasonGW :
    Please disable other plugins and switch to the feault wordpress theme, do you have the same problems ?

  11. chris81cm
    Member
    Posted 5 years ago #

    Hi Alexrabe,

    thank you for your time :-)

    Here are the Informations for you:
    a) Server settings are:
    * Betriebssystem : Linux
    * Server : Apache
    * Speicherverbrauch : 37.32 MByte
    * MySQL Version : 5.0.32-Debian_7etch10-log
    * SQL Modus : Nicht gesetzt
    * PHP Version : 5.2.0-8+etch15
    * PHP Safe Mode : Aus
    * PHP Allow URL fopen : An
    * PHP Memory Limit : 64M
    * PHP Max Upload Größe : 50M
    * PHP Max Post Größe : 50M
    * PHP Max Script Execute Time : 60s
    * PHP Exif Modul : Ja ( V1.4 )
    * PHP IPTC Modul : Ja
    * PHP XML Modul : Ja
    b) the Link to the gallery is:
    http://www.christopher-mueller.eu/2008/10/27/venedig-italien-2008-venezia/?preview=true&preview_id=120&preview_nonce=28d6d09486
    after click on any Picture to access one of the Gallerys you will get an 404 error... That's my Problem

    C)
    I have also tryed the "disable other plugins and switch to the feault wordpress theme" way, but it didn't work for me :-/

    I hope you can help me and a big thanks for your support!

    Best Regards

    Chris

  12. JasonGW
    Member
    Posted 5 years ago #

    Alex,

    I tried what you suggested (disable all plugins except NextGen, switch to default theme) but the behavior remains identical. This is on http://www.uglybabystudios.com, where the gallery previously worked.

    Now, there's an interesting new development. I have another site, http://www.allthatgamingstuff.com, where I have not yet upgraded to WordPress 2.8 (still on 2.7.1), and yet it behaves in exactly the same way. Any ideas?

    Thanks!!

    Jason

  13. chit chat administrator
    Member
    Posted 5 years ago #

    I restored my database and site folder. The restore is still using 2.8 it says and I think it is right because the widget screen is the new lousy layout not the 2.7.1 version. I deactivated plugins and then reactivated each one by one which fixed my moving widgets and adding photos into gallery problem. You may want to try a restore from your host system if you can't get this fixed.

    By the way, does anyone have an answer to my code issue re: a slider. I can't seem to get anyone to answer it. I have been trying for weeks now.

  14. photosbykev
    Member
    Posted 5 years ago #

    copied from another forum thread, when I found this thread as it seems to be the central thread for this issue.

    * Operating System : Linux
    * Server : Apache
    * Memory usage : 14.82 MByte
    * MYSQL Version : 5.0.68-percona-3-log
    * SQL Mode : Not set
    * PHP Version : 5.2.2
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 32M
    * PHP Max Upload Size : 8M
    * PHP Max Post Size : 8M
    * PHP Max Script Execute Time : 15s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    Just updated to 1.3.3 of NextGEN and the singlepic command is no longer showing the image on the page, also using the '0' to display all images or defining the no. of columns doesn't appear to function any more in the galleries and albums. All the images in albums and galleries are just listed below each other. This can seen under the Photography link on the home page detailed below.

    I've tried disabling plugins, default theme and updating the permalinks which was normally the quick fix but nothing is fixing the issue.

    The problems can be seen at http://www.photosbykev.com and scanning down the page where the [singlepic ....] commands are only showing the alt-text for the image as a link rather than embedding a scaled image. This bug is occuring on every post and page on the site.

    regards
    Kev Lewis

  15. Aimee
    Member
    Posted 5 years ago #

    Yup, I'm getting the same problems too. I made sure jquery.js loaded before the thickbox files -- yep. This happened after I upgraded to WP 2.8 and NGG.

    Now, the thickbox works if I manually embed my own images. But the Thickbox does not work through NGG. It just shows the loading image.

  16. bosnuk
    Member
    Posted 5 years ago #

    Hi Alex.
    First - thanks for your wonderful plugin. I really appreciate all your hard work!

    Second - here go my details:
    Server Settings
    Operating System : Linux
    Server : Apache
    Memory usage : 13.6 MByte
    MYSQL Version : 5.0.70
    SQL Mode : Not set
    PHP Version : 5.2.8-pl2-gentoo
    PHP Safe Mode : Off
    PHP Allow URL fopen : Off
    PHP Memory Limit : 128M
    PHP Max Upload Size : 32M
    PHP Max Post Size : 8M
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes

    Sample page:
    http://www.wrongsideoftheart.com/2009/04/dracula-has-risen-from-the-grave-1968-uk/

    Thanks!

  17. Aimee
    Member
    Posted 5 years ago #

    Bump. Would REALLY like a fix for this. This is annoying.

  18. JasonGW
    Member
    Posted 5 years ago #

    I think I'm going to just go ahead and delete the plugin and its database tables and reinstall it. That oughtta work, anyway. I think.

  19. photosbykev
    Member
    Posted 5 years ago #

    Alex, if it helps with the debugging I am willing to provide full access to website/server so you can investigate the problem

  20. Aimee
    Member
    Posted 5 years ago #

    I can't delete the database tables and reinstall the entire plugin -- I have like 1000 photos stored.

  21. saberlight
    Member
    Posted 5 years ago #

    I had some problems after upgrading nextgen and wp. A couple of things that fixed it, just in case.

    1. Nextgen actually prompted me to update my nextgen gallery because it was out of date. I don't remember which page this prompt was on. I think it was on the main gallery page. This was just a click of the button and easy.

    2. I needed to update my permalink structure in WordPress from the settings page.

    These probably aren't your problems but thought I would post in case.

  22. Aimee
    Member
    Posted 5 years ago #

    I FIGURED IT OUT!!!

    On the options part of NGG, just remove the rel="%GALLERY_NAME%" and the Thickbox will work. So, I guess this is a temporary fix until Alex figures out a way to get the REL's back working properly.

  23. Ryan Paul
    Member
    Posted 5 years ago #

    aimeeish...

    I looked at ur html... I can't see anything for thickbox, lightbox, shutter etc...

    You should rename the nextgen gallery folder to something else, upload a brand new folder... and then disable the bad behaviour plugin... see if that works...

  24. eharris
    Member
    Posted 5 years ago #

    I just did two things, and my test gallery is fixed. I just updated my development site to 2.8.1-beta1, and then I re-imported some images into the Gallery database (they had been inadvertently deleted). I don't know which step fixed the problem.

    Here's my development site gallery, which also demonstrates how my 2.7 theme fails in 2.8. I haven't taken the time to fix that, but since I didn't want to ugprade and break my gallery, I didn't have much incentive.

  25. Aimee
    Member
    Posted 5 years ago #

    @othellobloke What are you looking at? I don't have the bad behavior plugin, and I'm pretty sure I have Thickbox installed. I'm using it now.

  26. bosnuk
    Member
    Posted 5 years ago #

    I think othellobloke was looking at my page. I have bad behaviour installed.
    However in my case renaming, deleting and re-uploading suff is not an option 'cause I have something like 2000-3000 images on my site.

  27. chris81cm
    Member
    Posted 5 years ago #

    Hi all,

    I have solved the my problem today!

    I describe the steps now, please write here if this way was successfully for you too!

    at the first of all, i know this from "the old ways" and it helped again - for me!

    Here the steps!
    - Go to your WordPress Admin Page
    - Options › Permalinks
    - klick some other option and click update, I have used Standard because I normally use Day and Name
    - after the saving progress you can check your Picture page again, it should be work now!
    - now go back to the options (Options › Permalinks)
    - activate your favorite settings and click Update Settings again!
    - end

    This was my way out of this issue.

    Best Regards

    Chris

  28. photosbykev
    Member
    Posted 5 years ago #

    Hi Chris,

    your method is the normal way I 'fix' my site after a nextgen upgrade but I tried it when I upgraded to wp2.8 and nextgen 1.3.3 without the expected success. I've recently updated to 2.8.1-beta and again tried the 'fix' without any change in the situation.

    Until Alex comes up with a bug fix I think I'm stuck with horrible looking website

  29. eharris
    Member
    Posted 5 years ago #

    Ignore my prior post.. The problem must have been "fixed" by replacing most of the images in my test gallery. I tried the various methods above on an operational site, and the gallery is still hosed. Thumbnails work fine, but when I click on one, it just churns away with the animated "wait" icon. I'm in the process of (again) restoring my 2.7.1 backup files and database.

  30. eharris
    Member
    Posted 5 years ago #

    Alex, my server settings are as follows:

    * Operating System : Linux
    * Server : Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635
    * Memory usage : 16.97 MByte
    * MYSQL Version : 5.1.30
    * SQL Mode : Not set
    * PHP Version : 5.2.8
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 64M
    * PHP Max Upload Size : 64M
    * PHP Max Post Size : 64M
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    The link to my site's gallery is http://www.kungfu-silat.com/photos - however, that gallery works, because I've reverted to WordPress 2.7.1. When I upgrade to 2.8, I can see the three galleries and the thumbnails in each, but attempting to display any image fails. I can, however, view a gallery with PicLens after upgrading WordPress.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.