WordPress.org

Ready to get started?Download WordPress

Forums

Nextgen Gallery (1.1.0) Flash-Viewer (1.2) and SimpleViewer (1.9) (6 posts)

  1. jph98
    Member
    Posted 5 years ago #

    This is with regards to WordPress 2.7 (can someone update the Version dropdown for the new forum post please :)

    I'm having some issues in getting Nextgen gallery, flash viewer and simpleviewer to work together. Seems a little odd, Nextgen works fine on it's own but I cannot get flash viewer (with simpleviewer) to work when I add the shortcut to the page. Details are below:

    - Nextgen Gallery 1.0
    http://downloads.wordpress.org/plugin/nextgen-gallery.zip
    Installed to nextgen-gallery

    I created three galleries under Nextgen Gallery with a bunch of photos

    - Nextgen Flash Viewer 1.2
    http://downloads.wordpress.org/plugin/nextgen-flashviewer.1.2.zip
    Installed to nextgen-flashviewer

    -SimpleViewer:
    Installed from here:
    http://www.airtightinteractive.com/simpleviewer/

    I dumped the viewer.swf into the flash folder for nextgen flash viewer. The permissions are correct.

    I then added this tag to a page called galleries my blog:

    [simpleviewer id="2" width="600" height="200" link="Gallery Link"]

    and got this when accessing the page:

    swfobject is not defined
    start()psphoto?page_id=2 (line 86)
    psphoto?page_id=2()psphoto?page_id=2 (line 89)
    [Break on this error] swfobject.embedSWF("http://www.oogly.co.uk/psphoto/wp-content/plugins/nextgen-...

    If I omit the link bit like so:
    [simpleviewer id="2" width="600" height="200"]

    then I get the following message:
    "The Flash Player and a browser with Javascript support are needed.."

    The link for the Flash player points to a way old version of Flash (on the macromedia site ?!?!?!?).

    A number of questions really:

    1. Is there a fix for this?
    2. Is the swfobject version used outdated?
    3. Is there a combination of Gallery, Flash Viewer and simple viewer that work together guaranteed.

    Many thanks for any help anyone can provide,
    Jon.

  2. jph98
    Member
    Posted 5 years ago #

    I fixed the Javascript error by bodging the swfobject.js script in from the latest version of swfobject from here:

    http://code.google.com/p/swfobject/

    It works in Internet Explorer 7 but not in Firefox 3 for simpleviewer. Work continues, it looks like this is an issue with the nextgen-flashviewer. It doesn't seem to work with the nextgen-gallery (released on the 26th Jan). I'll try and hack something together for this for the time being, bah.

    If anybdoy can help please let me know,
    Jon.

  3. Boris
    Member
    Posted 5 years ago #

    Hmm, I never had swfobject included in the head because NGG would have done that already. In the next version (should be coming out shortly) I'll enqueue the script. should fix the js errors. Haven't had a chance to look at NGG 1.1.0 yet (enjoying the beach life in India too much), but maybe something changed.

    nothing's guaranteed, though, mate! a link to the problem always helps!

  4. jph98
    Member
    Posted 5 years ago #

    I think I included the link to the problem off your homepage... regardless here it is:

    http://www.oogly.co.uk/psphoto/?page_id=2

    Also if I add the following to the link in the page:

    link="Test Gallery"

    then it breaks completely. I can always hack about with the php and Javascript... I just wondered whether you could point me in the right direction...

    Many thanks,
    Jon.

  5. Boris
    Member
    Posted 5 years ago #

    looks like you have wp-simpleviewer installed as well. you shouldn't use that together with my plugin. wp-simpleviewer already loads swfobject into your head, fyi.

  6. jph98
    Member
    Posted 5 years ago #

    Yeah, fyi I gave up on the nextgen-flashviewer approach and went with wp-simpleadmin instead. Works fine. Thanks for your suggestions.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.