WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] NextGEN Galleries not working on localhost MAMP installation (14 posts)

  1. digbymaass
    Member
    Posted 4 months ago #

    I can set up a gallery display type in a post, eg Basic Thumbnails; choose a gallery to display and make all the settings; see the gallery thumbnails in 'Sort or Exclude Images', click save and see the first thumb in the post dialog. All working fine.

    Then click preview or publish and view the post, and all that displays is the same thumb. No gallery thumbs, nothing.

    I have corrected the localhost paths in Gallery/Other options as suggested in various posts but this made no difference. I've reinstalled the latest plugin, cleared caches etc.

    I am stumped.

    https://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @digbymaass - Did you set your ports to 80 and 3306 for localhost and MySQL respectively in your MAMP installation?

    - Cais.

  3. digbymaass
    Member
    Posted 4 months ago #

    No. I tried but couldn't persuade any browser to ignore the :8888
    Also all the addressing in NextGen is to localhost:8888

  4. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @digbymaass - You will likely need to re-setup your WordPress environment after you change the ports.

    - Cais.

  5. digbymaass
    Member
    Posted 4 months ago #

    My browsers refuse to address http://localhost/
    they keep changing to http://localhost:8888/

    Are you saying that if I did all this they would not, and the galleries would work properly?

    And what do you mean by re-setup my WordPress environment?

  6. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @digbymaass -

    Basing this on a standard MAMP installation on a Mac and a "new" WordPress installation ...

    Create a new folder under your htdocs folder for your local environment (example: local-WordPress); don't forget to create a new database, too.
    Paste your WordPress core files into that folder.
    Start MAMP.
    Click on Preference > Ports ... Set Apache & MySQL ports to 80 & 3306. Click OK.
    Start Servers.
    Navigate in your browser to localhost/local-WordPress ... and start the WordPress installation.

    You should be good to go from there ...

    - Cais.

  7. digbymaass
    Member
    Posted 4 months ago #

    Did that.
    Copied over the whole of wordpress (I assume that's what you meant).
    The MAMP start page indeed comes up without the :8888
    But will the browser go to localhost? No.
    It persistently and stupidly autofills the :8888 in spite of repeated cache clearing.

    Is there any point in getting rid of the :8888? Will anything work better?

  8. digbymaass
    Member
    Posted 4 months ago #

    ...the sound of electronic sagebrush blowing across the forum...

  9. digbymaass
    Member
    Posted 3 months ago #

    More or less resolved - see this thread
    I've got the localhost installation working on the 80 and 3306 ports and the galleries now display properly. BUT... there's a permalink also showing below the thumbnails, and I don't know how to make it go away. It was also there when MAMP was set to ports 8888/9, when the galleries weren't working.

  10. photocrati
    Member
    Plugin Author

    Posted 3 months ago #

    @digbymaass - Unfortunately with a local installation it can be very challenging to help troubleshoot with as no one else can see it.

    Have you checked your current theme? Have you checked for conflict from other active plugins? I would suggest a screenshot but that would only confirm the link is there and would really not help with much more.

    - Cais.

  11. digbymaass
    Member
    Posted 3 months ago #

    The permalink (eg http://localhost/2014/05/3307/) appears with ALL plugins disabled. It appears if I post a gallery when the other plugins are disabled. If I then go on and disable nextgen, it remains there, pointing at the gallery. We are running eleven 40 pro theme. If I change themes, it's still there. I don't know how to attach a screenshot but the page source shows:
    <!-- Pagination -->
    <div class='ngg-clear'></div> </div></p>
    <p class="entry-permalink">http://localhost/2014/05/3307/</p></div>

    The actual gallery path is wp-content/gallery/carnethy5-2014
    If I click on 'scripts' in safari's inspector whilst the entry-permalink element is selected it goes to jquery.fancybox-1.3.4.pack.js but I don't know if this is coincidence and unrelated. It's a long complex bit of js and I'm not sure what I might be looking for.
    The gallery display IS set to fancybox. However changing to 'no lightbox' in other options makes no difference.
    I don't think I can come up with any better information. And I can't think of anything I haven't turned off and on again.

  12. photocrati
    Member
    Plugin Author

    Posted 3 months ago #

    @digbymaass - You may need to start at the beginning and set the local install to a "benchmark" of a default WordPress Twenty series theme and only have NextGEN Gallery active. In all of the instances I have ever created that has always worked with the above port settings you said you are now using.

    From there work forward to see if/when it breaks ... from there we may be able to offer more suggestions.

    - Cais.

  13. digbymaass
    Member
    Posted 3 months ago #

    Thanks. I'll do it when I've got time. As the local version is for testing at least the galleries seem to be working properly.

  14. photocrati
    Member
    Plugin Author

    Posted 3 months ago #

    @digbymaass - No worries, please let us know if you find anything. Perhaps start a new topic to isolate any issues you may find.

    - Cais.

Reply

You must log in to post.

About this Plugin

About this Topic