WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Nextgen 2.0 Caption Template / Column Problem (12 posts)

  1. mikeschumann
    Member
    Posted 11 months ago #

    Using Nextgen 2.0.7, when I display a gallery with the "gallery-caption.php" template, it screws up the column setting for the gallery. Specifically, if I set the gallery to display 2 columns, it works fine if I leave the template setting blank. If I specify the caption template, it displays the gallery in a single column.

    How can we get this fixed?

    http://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    @mikeschumann: Yup, I've duplicated this issue and created a high priority item. As far as I can tell, your caption template will always display one less column than what you specify in the settings. It appears something's off in how the column widths are begin calculated.

    Since I've seen a few issues on this, and given that you named the thread so well so others can find it, I'm just making this sticky so others with the issue will see it.

    For anyone else, if you having this and want to post details below, please do so. There's no quick fix for now, we just need to solve it and it should be in the next update, probably in about a week.

    Until then, you may want to switch to standard thumbnail galleries rather than using the caption template.

  3. duce
    Member
    Posted 11 months ago #

    It would be terribly good to have either the image number below/above the image or the image title.
    This is utterly important on websites where you want people ordering images for purchase. Many pro photographers use NextGEN to display images that are for sale.

  4. duce
    Member
    Posted 11 months ago #

    The way I had it setup on the older versions was to have the image title/number displaying above the image and then the description below the image.
    The reason for this is that I use ACDSee to write IPTC info to display the title as the image number and the description as a description of the image type and who the photographer is.
    When importing the images in NextGEN it automatically imports that IPTC info and displays it correctly.

  5. jrlorson
    Member
    Posted 11 months ago #

    Hi - I'm leaving the template blank and specifying 5 columns, but still getting only 1 column in all my galleries. It seems to be the same / similar issue as above. Any advice / info would be greatly appreciated.
    Thanks for this thread - I'll keep checking to see if this is resolved here.

  6. cse7
    Member
    Posted 11 months ago #

    I also find that the thumnbail gallery images overlap rather than resizing as the display width narrows. Is there a way to remove the specified image width attribute when the gallery is created?

    I am using the latest version of NextGen (2.0.7) and the thumbnails with caption option.

  7. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    Hi all: we've introduced a fix for this and released at part of our latest informal mini-release. If you are comfortably with FTP and manually updating your plugin files, you can download the new zip here:

    http://www.nextgen-gallery.com/nextgen-gallery-latest-beta

    Otherwise the fix will be included in the next official release, which we're expecting to push out roughly on Monday.

  8. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    @cse7: your issue sounds a bit different so I'm not sure if that's resolve with these other fixes or not. You can try it and let us know. Otherwise if it's not resolved, please provide a link so we can see the behavior. Thanks.

  9. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    Hey all: For now, I'm going to mark this as fixed because a fix is available now and also will included in the next release. That way people know when seeing the topic there's a fix. If for some reason it doesn't work, please just ask us to reopen, or start a new thread, as you prefer. Thanks.

  10. duce
    Member
    Posted 10 months ago #

    Could you perhaps include the fix in the subversion version as I update all my plugins with svn update?

    Thanks for the hard work. I know you guys are going through a rough patch but I am pretty sure all the new changes will be for the better in future! :)

  11. photocrati
    Member
    Plugin Author

    Posted 10 months ago #

    @duce, this fix hasn't been officially released yet. It should come out through the repository on Monday. For now, you'd have to download the zip and update manually from here:

    http://www.nextgen-gallery.com/nextgen-gallery-latest-beta

  12. nic0le24
    Member
    Posted 3 months ago #

    I'm having this issue with 2.0.59 - would love to know how to fix it?

Reply

You must log in to post.

About this Plugin

About this Topic