WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
nextgen 1.9.12 vs. 2.0 versions - still issues with how gallery views (6 posts)

  1. wmalowany
    Member
    Posted 8 months ago #

    When the new NextGen 2.0 version was available, I updated it, but had to manually go back to the old version because my gallery pages were all messed up. The images were not in the 3 columns of my settings and html coding was visible. I figured I would wait until the "bugs" were resolved, but had the same issues when I installed the new version in a new website I built for a fellow artist. Do the shortcut codes need to be changed or something else done in the settings to make the new version work? I am providing the url of my website and the websites I am using the old version of nextgen in case it is helpful for troubleshooting the problem:

    http://Wendy-Malowany.com
    http://Kathleen-Thorsen.com
    http://esastudiogallery.com

    Thanks in advance for any information you can provide, or hope looking at these website helps resolve the problem.

    - Wendy

    http://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 8 months ago #

    @wmalowany - Can you provide specific examples from each site (and the version you are using on that site) for reference ... that would be more helpful.

    As to the use of shortcodes, all have been translated from NextGEN Legacy to the current NextGEN Gallery and should work as they did in the past.

    There may be some settings that can be adjusted on your site but we would need to see under the page to have a better idea of what you are using ...

    Thanks!

    - Cais.

  3. wmalowany
    Member
    Posted 8 months ago #

    Hi Cais,

    I don't want to switch back to 2.0 to show you want happened because I can't have my website, or my clients' website not functioning correctly. Instead of three columns on the gallery page, I had thumbnails all in one column with some of my html code I have for the descriptions under each image showing up.

    Under the description for each image of my painting I include my title, media used, price, etc. and use html to make it look right. Like this:

    "Ker Floodplain"
    Oil on canvas, 30”x38”
    <center><font size="3" face="Comic Sans MS" color="#800000">SOLD</font>
    <p></p>

    All the sites I listed are currently using 1.9.12 because of the issue I had when I upgraded and also when I installed 2.0 on a new website.

    I have this on my Gallery page:

    <p style="text-align: center;">Click on the image or title to see all Wendy's artwork.</p>
    <p style="text-align: center;">[nggalbum id=1 template=extend]</p>
    <span style="font-size: small;">
    </span>

    And each gallery, such as, Architectural, Nature and Landscape, etc. has a page with the coding to show the correct gallery on that page:

    <p style="text-align: left;">Growing up in Glasgow, Scotland, Wendy was exposed to a variety of wonderful architecture. She is attracted to the strong angles, contrast in value, and variety of textures, She often contracts the strong linear aspects of architectural form with natural elements nearby. She paints in an expressive style with a strong use of colour.</p>
    <p style="text-align: center;">Please view Wendy's artwork by clicking on an image to enlarge...</p>
    <p style="text-align: center;">[nggallery id=1 template=caption]</p>

    As for my nextgen settings,

    Gallery settings:
    3 columns
    no slide show integration
    Thumbnails first
    Custom order

    Slideshow:
    JW rotator setting following selected:
    shuffle mode
    show next image on click
    show navigation bar
    Thumbnails

    for Effects I have chosen Shutter with the link code line as: class="shutterset_%GALLERY_NAME%"

    Hopefully that helps, but if you need more information, just let me know.

    Thanks!

    - Wendy

  4. tizz
    Member
    Posted 8 months ago #

    wmalowany, you can't have concrete help about the plugin last version having still installed 1.9.12, and showing the old version settings (and for 3 sites all at once?).
    At the moment, maybe, you can choose one of them for the upgrade, and keep it upgraded not only to show the error live, but to change the options you have to change and to familiarize with the new plugin, which is a bit different from the previous version.
    Then, it's a bad habit write HTML in post/page editor for styling the page, use CSS instead, and <p style="text-align: center;">[nggallery id=1 template=caption]</p> can't work, and indeed doesn't work on your page.
    If you make sites for job (you say you have clients...), you should know CSS, and also that the tests are to be done on not-in-production sites.

  5. wmalowany
    Member
    Posted 8 months ago #

    @tizz
    First, the sites were already live with the old version and working fine. On one of the new sites, I installed 2.0, but it didn't work correctly with the set up I wanted so I uninstalled it and reinstalled the older version. I use lots of plugins and upgrade to the new version without issues. I can simple use the old version of NextGen, but was posting the information so that perhaps those who worked on the upgrade could improve it so that users wouldn't have the issues I have had with 2.0.

    I don't know what page on my site you were looking at, but if you go to: http://wendy-malowany.com/gallery/architectural/

    You will see that my Architecture gallery certainly does work with the short code I posted, [nggallery id=1 template=caption]

    All of the pages and galleries on all the sites work fine with the 1.9.12 version.

    Also, I am not using html for styling the page, I am simply using html to format the caption in the NextGen description area.

    If those involved in editing the upgrade would like to see the issues I have had with the 2.0 version, I can install the plugin on another site of mine which is not using NextGen and create an album page and gallery pages with the galleries on them, with the same setting I am currently using with 1.9.12 so they can see the problem. I just won't include those pages on my menu so they won't be visible to visitors unless they have the url of those pages. Let me know and I can either post here once I have chance to set it up, or email the person wanting to trouble-shoot the problem.

  6. photocrati
    Member
    Plugin Author

    Posted 8 months ago #

    @tizz - Thanks for trying to help out here, as always, it is much appreciated!!

    @wmalowany - Please feel free to submit a Bug Report (http://www.nextgen-gallery.com/report-bug/ ... please reference this topic) and provide log in and FTP credentials for the test site on the Bug Report as well.

    Please also make every effort to mirror one of your existing client sites experiencing this issue so we can help you troubleshoot a "real" scenario.

    Once you have the current version of NextGEN Gallery installed and active on your "test" site you will notice (as @tizz pointed out) there are differences with how NextGEN Legacy and current NextGEN Gallery are set up and used. Please try to mimic the settings in 2.0.x that you are using in 1.19.12(?) and note anything you were not able to sort out.

    We'd be more than happy to try and get this sorted out with you and using our Bug Report procedures will help to keep your concerns of these URLs out of the public view as well.

    Thanks!

    - Cais.

Reply

You must log in to post.

About this Plugin

About this Topic