WordPress.org

Ready to get started?Download WordPress

Forums

Next Link (page/2/) Not Working (15 posts)

  1. WhollyHis
    Member
    Posted 9 years ago #

    I'm using WP 1.5. I noticed (and like) the link at the bottom of my main page to go to the next page of blog entries. However, it isn't working on my blog (http://www.whollyhis.net). When I click on the link (http://www.whollyhis.net/page/2/), I get a 404 error.

    This is also not workign for archive pages. I can load an archive fine (e.g. http://www.whollyhis.net/archives/2005/01/) but when I click on the link at the bottom of the page, it tries to go to http://www.whollyhis.net/archives/2005/01/page/2/ and I get a "sorry, no posts matched your criteria" error.

    Any ideas?

  2. bloodylamer
    Member
    Posted 9 years ago #

    I'm having this problem too---no solution on my end yet, but I will keep this thread handy!

  3. WhollyHis
    Member
    Posted 9 years ago #

    I made some progress. I checked the CHMOD on my .htaccess file and saw that it was set at 644. I changed it to 666. Then I disabled all my plugins and re-ran the upgrade.php that was part of the initial upgrade installation process. I then re-enabled my plugins.

    Now my main index "Next" link works. However, I still have the same problem as before on the archive pages.

  4. WhollyHis
    Member
    Posted 9 years ago #

    Problem #2 solved.

    I deleted .htaccess, went into the WP Admin area where it controls permalink structure and told it to update the permalink structure in .htaccess. It told me I couldn't because .htaccess wasn't writeable.

    I went it and changed the new .htaccess file to CHMOD 666. I then went back to the WP admin area and told it to try updating the permalink structure again and it did it successfully.

  5. bloodylamer
    Member
    Posted 9 years ago #

    tried exactly what you said w/ no luck :-(

    what do you have set as your category base?

    maybe that's what's wrong w/ mine

    http://www.bastardly.com/archives/category/all/page/2/

    I have no idea why there's an ALL there?! Anyone out there?

    When it's http://www.bastardly.com/page/2/, it works perfectly! so I'm kind of stuck here.

  6. shep
    Member
    Posted 9 years ago #

    i am having the same problem for my category base.

  7. shep
    Member
    Posted 9 years ago #

    well, after trying multiple times what whollyhis suggested, it finally worked.

    don't know why it took about 5 tries to do it, but it works now.

  8. EyeNo
    Member
    Posted 9 years ago #

    Same problem here.

    I deleted my .htaccess file, deactivated the plugins, created a blank .htaccess with 666 permissions and finally went back in and updated my permalink structure. Nothing gets written into the file.

    Right now I'm using an old file, site works but next page doesn't. I'll keep watching this thread

  9. WhollyHis
    Member
    Posted 9 years ago #

    EyeNo, try doing it in the order I did. (Maybe even a couple times per Shep's note.) I didn't create a new .htaccess file. I deleted the old one, then told WP to update permalink structures. It couldn't because of CHMOD. Then I went to the new.htaccess file (created when WP tried to modify it I assume), changed CHMOD to 666, and went back to WP to do the permalink update again.

  10. EyeNo
    Member
    Posted 9 years ago #

    WhollyHis

    Tried that, deleted .htaccess. Went to admin and updated permalink structure. No errors reported. Went back to / no .htaccess. Where the heck is it writing it?

  11. WhollyHis
    Member
    Posted 9 years ago #

    .htaccess should be in your root (the base directory with your www stuff in it) directory--it's the same one with files such as index.php, wp-atom.php, wp-blog-header.php, etc. I've heard that sometimes people have multiple copies distributed in various directories. I guess I would check to see if you have another copy of an .htaccess file in some other directory.

    One other potential problem I've heard about and partially encountered is .htaccess existing but not being displayed. I'm on a PC and when I access my site via an FTP client, my .htaccess file doesn't show up. I can however see and access my .htaccess file from within the Control Panel>File Manager setup provided by my webhost. (I've heard, but not experienced, problems with seeing .htaccess on macs but it may have been a more specific software issue.)

  12. WhollyHis
    Member
    Posted 9 years ago #

    I noticed other issues on your site just now. When I click on the "next" link, it opens in a new window and tries to go to

    http://www.eyeno.net/index.php/page/2/

    It should try to go to

    http://www.eyeno.net/page/2/

    I'm not an expert at all but I don't think that's the same thing mine was doing before I got it fixed. I think mine was going to the correct URI but not finding anything, or at least no posts.

    It also tries to open in a new window which I suspect is a customization you made. Can you disable that and see if it's related to the problem? If you have multiple plugins/adaptations trying to change how that link works, maybe they're conflicting with each other.

    I'm also assuming you did run the update php file when you upgraded to WP 1.5, yes?

    Also, your main column is overlapped by the sidebar in IE 6 (but not in Netscape 7.1). Maybe it's an IE thing, maybe a CSS problem, maybe a flaw in the theme. Just FYI.

  13. phschwager
    Member
    Posted 8 years ago #

    I had the exact same problem (www.digitalstakeholders.org/blog) and I tried the suggestions here with no luck. So using Fantastico I installed a new WP and it worked fine. Through some trouble shooting it appears that my problem was with the DC Nicer Archive plugin. Once I disabled this it worked fine. I am keeping my fingers crossed that this was indeed the problem.

    You might try disabling all your plugins and see if it works them. If it does then try adding your plugins back one by one to see where the conflict is.

    Good luck.

  14. AuntiAlias
    Member
    Posted 8 years ago #

    @WhollyHis, THANKS for posting what you did to solve the problem. I have now solved mine, which was similar.

    Problem was:
    main page to page 2 was okay
    date or month pages to page 2 got the "sorry no posts" response.

    1. I copied all the contents of my .htaccess file (I have lots of custom redirects in there).
    2. Deleted .htaccess file
    3. Created new, blank text file named 1.htaccess on my local computer
    4. uploaded via ftp to basie directory of my site (same place as where my index.php file is, one directory level higher than my /wp/ directory
    5. Renamed file to .htaccess (removed 1), set permissions (chmod) to 666
    6. In WordPress Control Panel, went to Options > Permalinks and pressed the Update Permalinnk Structure
    7. Tested a "bad" page and IT WORKED!!!!!
    8. Blessed WhollyHis
    9. Pasted all the static page redirects at the top of the page, before the # BEGIN WordPress line.
    10. Tested again. It works. So I posted results here.

    I am one! happy! camper!!

  15. ColourDreamer
    Member
    Posted 8 years ago #

    I have this problem, but I am using the trick to use a different page as the home page. There just is no 2nd page off of /blog.php/page/2

    I'm afraid to reinstall Word Press, because the blog's been going on for a while, and I don't want to lose anything.

    Can anyone help me with this situation?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.