WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] News pages all showing same posts - won't go past page 2 (7 posts)

  1. blonde_lili
    Member
    Posted 1 year ago #

    Hi, all,

    I've just taken over an established WordPress site and I've discovered a rather annoying problem. In the News section of the site, you are able to go back to Page 2, but not any further. Or, to be more accurate, the url shows that you can go back to Pages 3 and 4, but they display the same posts as Page 2.

    Here's a link to the site: http://midnightechomagazine.com/news/

    I'm using WordPress 3.4.1 and the theme is Easel 3.1. I am very new to WordPress (to the point of still figuring out how to navigate the Dashboard), so any advice on how to fix this problem (and where to do it) would be hugely appreciated.

    Thanks heaps!

  2. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    start by reviewing http://codex.wordpress.org/Pagination

    does the 'news' section template contain a custom query?

  3. blonde_lili
    Member
    Posted 1 year ago #

    Hi, alchymyth,

    Yep, it looks like it does. In the Pagination.php, it says:

    <?php

    function easel_pagination() {
    global $post, $wp_query;
    if(function_exists('easel_wp_pagenavi')) {
    easel_wp_pagenavi('<div id="wp-paginav">', '<div class="clear"></div></div>');
    } else { ?>
    <div id="pagenav">
    <div class="pagenav-right"><?php previous_posts_link(__('Newer Entries ↑','easel')) ?></div>
    <div class="pagenav-left"><?php next_posts_link(__('↓ Previous Entries','easel')) ?></div>
    <div class="clear"></div>
    </div>
    <?php }
    }

    ?>

    In the Reading settings, "Blog pages show at most" is set to 100. I'm wondering if removing the custom query coding entirely, then changing the blog pages limit to 5, would solve the problem, as WordPress supposedly defaults to those settings if you don't have a custom query.

  4. blonde_lili
    Member
    Posted 1 year ago #

    Sorry, I think that's the wrong bit of coding. In the Blog Page Template, it says:

    <?php
    /*
    Template Name: Blog
    */
    get_header();

    Protect();
    $blog_query = array(
    'paged' => get_query_var('paged')
    );
    $posts = &query_posts($blog_query);
    if (have_posts()) {
    while (have_posts()) : the_post();
    easel_display_post();
    endwhile;
    easel_pagination();
    }
    UnProtect();

    get_footer();
    ?>

  5. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    In the Reading settings, "Blog pages show at most" is set to 100.

    as the news section only shows 10 posts, there must be somewhere where this number is set -

    possibly ask in the direct support section of your theme:
    http://wordpress.org/support/theme/easel

  6. blonde_lili
    Member
    Posted 1 year ago #

    Thanks, alchymyth! If I get this fixed, I'll come back and share the instructions.

  7. blonde_lili
    Member
    Posted 12 months ago #

    After some help from Keesiemeijer and Frumph in the Easel forum, I ended up fixing this by going to Settings => Reading, then setting both "Blog pages show at most" and "Syndication feeds show the most recent" to 10 (formerly 100 and 20 respectively).

    I'm surprised this was so simple to fix, as I thought the code was meant to override the WordPress settings - but I'm not complaining ;).

Topic Closed

This topic has been closed to new replies.

About this Topic