WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Newly registered WPMU members get blank page while activating their accounts (5 posts)

  1. sarangan112
    Member
    Posted 3 years ago #

    New members who register at WPMU site get a blank page when they activate their account by clicking the link sent to their email.

    http://wpmu-site.com/wp-activate.php?key=xxxxxxxxxxxxxxxxxxxxxx

    How to reproduce this bug:

    1. Enable WMPU.
    2. Go to registration page and register a new blog.
    3. Check your email for an activating link looks like this: http://wpmu-site.com/wp-activate.php?key=xxxxxxxxxxxxxxxxxxxxxx

    4. Click on that link to activate your account.
    5. Da dang! Blank page.

    I tested this by disabled all plugins and still got the same blank page. When I enabled WordPress debug then I got this error messages:

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/xxx/public_html/wp-includes/functions.php on line 3389

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in //home/xxx/public_html/wp-includes/functions.php on line 3473

    Notice: Undefined index: page in /home/xxx/public_html/wp-content/themes/simplefolio/admin/index.php on line 272

    Notice: is_site_admin is deprecated since version 3.0! Use is_super_admin() instead. in /home/xxx/public_html/wp-includes/functions.php on line 3389

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/xxx/public_html/wp-includes/functions.php on line 3473

  2. FYI - It's not WPMU anymore, it's WordPress Multisite (WPMS if you must). WPMU specifically refers to the 2.9.2 and older version. Yes, it matters.

    Did you try this on the default theme?

  3. sarangan112
    Member
    Posted 3 years ago #

    Oh sorry for that.. I will never ever call WPMU anymore. :-)

    Yes I tried it with the default theme and it works fine. But most of my favorite themes are broken and have this problem.

    Anyway thanks for your help.

  4. You won't like my answer. Your theme is old and needs to be upgraded to work with WordPress 3.x.

    I mean, you know that cause of this:

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/xxx/public_html/wp-includes/functions.php on line 3389

    So make the changes the errors recommend or find a new theme. But that's your problem.

  5. Dion Hulse
    WordPress Dev
    Posted 3 years ago #

    Please note, that this should be fixed as of 3.2 RC1: http://core.trac.wordpress.org/ticket/17761

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.