WordPress.org

Ready to get started?Download WordPress

Forums

Newbie! WordPress returning too many pages' worth of entries in searches (6 posts)

  1. mixvio
    Member
    Posted 8 years ago #

    Hi everybody, marginal newbie here so any help will be appreciated. I recently moved over from Movable Type and I'm having a few skips along the way.
    I'm currently using a modified version of the "Connections" theme at mixvio.com/ and there're a few questions that I'm having some trouble with. Firstly, at the bottom of every page there's a "Next Page"/"Previous Page" navigation link. This would be fine except when it claims there's another page of entries when there actually isn't. Here, for example:
    mixvio.com/2006/01/page/2/
    In the month of January there are only six entries and they all fit on the first page, yet for some reason the Next Page link will continue indefinitely for however long you choose to click it, while every page shows "Sorry, no posts match your criteria."
    My first question is how can the "Next Page" link be removed when there ISN'T a next page? I can't seem to figure out how to do that.
    HOWEVER, my second question holds higher priority and the first one can be eliminated if this one is corrected. :)
    Intending this to be a work-around for the above problem, I downloaded and activated the wpPaginate (http://www.scriptygoddess.com/archives/2005/01/23/wppaginate-for-wp-15/) plugin. As you can see here I added the pages of results to the top of each search and archive page because I intended to delete the faulty next/previous links at the bottom.
    mixvio.com/2006/02/
    This would've been fine except for a problem similiar to the issue in my first question. At the top, beneath "February 2006" it says there are three pages of results. However, if you click on the link to page three, you get the "Sorry, no posts match your critera" link as before because the entries all fit within two pages.
    SO, can anybody explain to me why WordPress is presenting more pages' worth of entries than there actually are and how this can be shut off? I imagine it's not theme-specific but rather some other issue, because I've switched to several different themes and it still happens from my current theme to the default WordPress one. Any help will be much appreciated!

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Please do not post again with the same problem.

    1. Remove the paginate plugin for now.
    2. Paste here your permalink structure.

  3. mixvio
    Member
    Posted 8 years ago #

    I apologise, I tried to delete the first one because I read that bumping was discouraged (I didn't seem to notice that rule the first time I read through the forum rules, sorry!) and posts with 1 response got better results. I don't think I managed to delete it though.

    My permalink structure is custom, it is:

    /%year%/%monthnum%/%postname%/

  4. Mark (podz)
    Support Maven
    Posted 8 years ago #

    If you try with the default ?p= structure, does this error persist?

  5. mixvio
    Member
    Posted 8 years ago #

    I tried to switch to the default and it didn't change anything, I still get the same problem.

    also though I'd like to avoid anything that requires me to change the permastructure if possible, because I just spent the past week changing all the old links by hand to the new WordPress structure and I'd rather not need to repeat that if I can help it. thanks!

  6. mixvio
    Member
    Posted 8 years ago #

    well I seem to have fixed it somehow.

    out of frustration and lack of other ideas to try, I went into options and changed "Show at most ___ ____" from what it was originally -- show at most 7 days -- to "show at most 7 posts."

    then I tried checking the site again and somehow when I clicked the last page of entries, I got the last page. I went through and tried them all and it seems to be working fine now.

    so is this a bug?

Topic Closed

This topic has been closed to new replies.

About this Topic